Archivos de impresión en el orden correcto cuando se selecciona la opción Intercalar, o recibe un mensaje de error al utilizar formularios personalizados: "Con errores de aplicación spoolsv.exe"

Seleccione idioma Seleccione idioma
Id. de artículo: 977263 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Esta actualización corrige los siguientes problemas de impresión en un equipo que ejecuta Windows Vista o Windows Server 2008.

Problema 1

Considere el siguiente escenario:
  • Intenta imprimir un archivo en un equipo que ejecuta Windows Vista o Windows Server 2008.
  • La impresora utiliza el procesador de impresión WinPrint.
  • Se imprime una copia de un documento de varias páginas.
  • Imprimir varias copias de un documento de una página.
  • Selecciona elIntercalaropción en elImprimircuadro de diálogo.
En este escenario, el resultado está ordenado como si no está seleccionada la opción Intercalar.

NotaImpresoras pueden tener varias características que pueden hacer que la salida impresa para que contenga más páginas que el archivo original. Esto incluye las siguientes características:
  • Agregar tapas de frontales o posterior
  • Insertar páginas en ubicaciones específicas en un trabajo de impresión
  • Insertar páginas de separación
  • Imprimir con un trabajo guardado. Por ejemplo, agregando una carta de presentación para un documento guardado y ellos juntos como un trabajo de impresión.

Problema 2

Considere el siguiente escenario:
  • Configurar un clúster de conmutación por error de servidor de impresión en un equipo basado en Windows Server 2008.
  • Instalar a una impresora que admita formularios personalizados en el clúster. Soporte de formulario personalizado le permite imprimir formularios personalizados, como tarjetas de felicitación, tarjetas de presentación y otros formularios personalizados.
  • Crear una entrada del Registro DWORD denominadoAllowUserManageFormsen la siguiente subclave:

    HKLM\Cluster\Resources\<printspoolerguid>\Parameters</printspoolerguid>

    A continuación, establece el valor de la entrada del registro en 1.
  • EnPanel de control, haga clic enLas impresoras, y, a continuación, se crea un formulario personalizado en elPropiedades del servidor de impresióncuadro de diálogo.
  • Establecer las preferencias de impresión en la impresora para que la impresora puede utilizar el formulario personalizado.
  • Se mueve el recurso de cola de impresión rápidamente entre los dos nodos varias veces.
En este escenario, el servicio de cola de impresión (Spoolsv.exe) que se llama a este trabajo de impresión se bloquea. Además, se registra un mensaje de error similar al siguiente en el registro de aplicación:

Error de aplicación: ID. de suceso 1000
General: Con errores de aplicación spoolsv.exe, versión 6.0.6002.18005, marca de hora 0x49e03626, con error ntdll.dll de módulo, la versión 6.0.6002.18005, la marca de hora 0x49e0421d, el código de excepción 0xc0000005, desplazamiento de errores<offset></offset>, id. de proceso<id></id>, hora de inicio de la aplicación<start time=""></start>.

Cuando se produce este problema, el estado del recurso de cola de impresión se muestra como "Conexión pendiente," "Sin conexión pendiente" o "Online".

NotaTodavía puede recibir este mensaje de error cuando se mueve el recurso de cola de impresión en este nodo en el complemento Administración de clúster de conmutación por error. Este comportamiento se produce porque se ha reiniciado el servicio de cola de impresión.

Causa

Este problema se produce porque el servicio de cola de impresión intenta tener acceso a la memoria liberada. Esto hace que el servicio de cola de impresión se bloquea.

Solución

Hay una revisión tratar los problemas enumerados anteriormente.

NotaEl conjunto de impresora controlador debe explícitamente la clave del registroSinglePageKeepCollatepor la cola de impresión mediante una llamada a laProcesamiento: SetPrinterDataAPI. Este valor no se establece de forma predeterminada.

Información de la revisión

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si no aparece en esta sección, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos de soporte técnico usuales se aplicarán a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe estar ejecutando uno de los siguientes sistemas operativos:
  • Windows Vista Service Pack 1 (SP1)
  • Service Pack 2 (SP2) de Windows Vista
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
Para obtener más información acerca de cómo obtener un service pack de Windows Vista, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista
Para obtener más información acerca de cómo obtener un service pack de Windows Server 2008, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
968849Cómo obtener el service pack más reciente para Windows Server 2008

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que aparecen en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en hora Universal coordinada (UTC). Se muestran las fechas y las horas de estos archivos en el equipo local en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza ciertas operaciones en los archivos.
Notas de la información de archivo de Windows Vista y Windows Server 2008
ImportanteLas correcciones urgentes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo "Windows Vista" aparece en la página de solicitud de revisión. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece en "Windows Vista" en la página. Siempre hacen referencia a la sección "Aplicable A" los artículos para determinar el sistema operativo real que se aplica cada revisión.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SPn), y la rama de servicio (LDR, GDR) puede identificarse mediante el examen de los números de versión del archivo tal como se muestra en la tabla siguiente.
    Contraer esta tablaAmpliar esta tabla
    VersiónProductoSR_LevelRama de servicio
    6.0.6001.22xxxWindows Vista y Windows Server 2008SERVICE PACK 1LDR
    6.0.6002.22xxxWindows Vista y Windows Server 2008SERVICE PACK 2LDR
  • Service Pack 1 está integrado en la versión de lanzamiento de Windows Server 2008. Por lo tanto, los archivos de hito RTM sólo se aplican a Windows Vista. Los archivos de hito RTM tienen un número de versión 6.0.0000.XXXXXXnúmero de versión.
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instala para cada entorno estánla lista por separadoen la sección "información adicional de archivos para Windows Server 2008 y Windows Vista". Los archivos MUM y archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado del componente actualizado. Los archivos de catálogo de seguridad, para el que no se muestran los atributos, están firmados con una firma digital de Microsoft.
Para todas las versiones basadas en 86 de Windows Server 2008 y Windows Vista x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Localspl.dll6.0.6001.22598637,95206-Ene-201017: 23x 86
Localspl.dll6.0.6002.22303624,12806-Ene-201016: 03x 86
Para todas las versiones de 64 compatibles de Windows Server 2008 y Windows Vista x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Localspl.dll6.0.6001.22598793,60006-Ene-201016: 47x 64
Localspl.dll6.0.6002.22303774,65606-Ene-201016: 07x 64
Localspl.dll6.0.6001.22598637,95206-Ene-201017: 23x 86
Localspl.dll6.0.6002.22303624,12806-Ene-201016: 03x 86
Para todas las versiones basadas en IA-64 de Windows Server 2008

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Localspl.dll6.0.6001.225981,625,08806-Ene-201017: 07IA-64
Localspl.dll6.0.6002.223031,625,08806-Ene-201015: 55IA-64
Localspl.dll6.0.6001.22598637,95206-Ene-201017: 23x 86
Localspl.dll6.0.6002.22303624,12806-Ene-201016: 03x 86

Solución

Para evitar el problema 2, establezca el valor de la entrada de registro AllowUserManageForms en 0. Se trata de una configuración global que impide el uso de formularios personalizados.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Para obtener más información acerca de la cola de impresión, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn.Microsoft.com/en-us/library/aa371800 (en inglés) (.aspx)

Para obtener más información acerca de la administración de impresión en Windows Server 2008, visite el siguiente sitio Web de MSDN:
http://technet.Microsoft.com/en-us/library/cc753109 (WS.10) (.aspx)

Información adicional de archivos

Información adicional sobre archivos para Windows Vista y Windows Server 2008

Archivos adicionales para todas las versiones basadas en 86 de Windows Vista y Windows Server 2008 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNo aplicable14,44206-Ene-201019: 30No aplicable
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNo aplicable14,42306-Ene-201019: 08No aplicable
Archivos adicionales para todas las versiones de 64 compatibles de Windows Vista y Windows Server 2008 x

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Windows-Amd64_microsoft-p...ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_8c6a50e6646ae4a8.manifestNo aplicable14,51206-Ene-201019: 13No aplicable
Windows-Amd64_microsoft-p...ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_8ead128e614cbcc7.manifestNo aplicable14,49306-Ene-201019: 08No aplicable
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNo aplicable14,44206-Ene-201019: 30No aplicable
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNo aplicable14,42306-Ene-201019: 08No aplicable
Admiten de archivos adicionales para todas las versiones basadas en IA-64 de Windows Server 2008

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Windows-Ia64_microsoft-p...ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304d5958ac0b7c6e.manifestNo aplicable14,45806-Ene-201009: 19No aplicable
Windows-Ia64_microsoft-p...ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_32901b00a8ed548d.manifestNo aplicable14,45806-Ene-201018: 52No aplicable
Tabla de OneNote de contents.onetoc2No aplicable3,65619-Ene-201016: 06No aplicable
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6001.22598_none_304bb562ac0d7372.manifestNo aplicable14,44206-Ene-201019: 30No aplicable
X86_microsoft-windows-p...ooler-core-localspl_31bf3856ad364e35_6.0.6002.22303_none_328e770aa8ef4b91.manifestNo aplicable14,42306-Ene-201019: 08No aplicable

Propiedades

Id. de artículo: 977263 - Última revisión: jueves, 7 de abril de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Windows HPC Server 2008
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
Palabras clave: 
kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix kbmt KB977263 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 977263

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com