FIX: Files are not written to an absolute path as expected in a BizTalk project

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Article ID: 977329 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Microsoft BizTalk Server 2006 R2, you create a BizTalk project in Microsoft Visual Studio.
  • In the project Properties page in Visual Studio, you configure the output directory to an absolute path.
  • You move the BizTalk project files from one drive to another drive.
  • You open the BizTalk project.
  • You build the project.
In this scenario, the output files from the build operation are not written to the directory that you configured as the output directory.

CAUSE

This problem occurs because the absolute path that you configured as the output directory is converted to a relative path. This relative path is saved in the BizTalk project file. For example, you create a BizTalk project that is located at C:\BizTalkProject\Project1\Project1, and you configure the output directory to C:\BizTalkProject\Output. In this case, BizTalk Server saves the output directory as the relative path ...\...\Output\.

RESOLUTION

Hotfix information

For BizTalk Server 2006 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.mapper.dll3.6.1555.2264,04818-Dec-200910:08x86
Microsoft.biztalk.studio.utilities.dll3.6.1555.2206,72818-Dec-200910:08x86

For BizTalk Server 2006 R2 SP1


The hotfix that resolves this problem is included in cumulative update package 1 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
982061 Cumulative update package 1 for BizTalk Server 2006 R2 Service Pack 1

For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563 List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how to create a BizTalk Server project, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn.microsoft.com/en-us/library/aa559046(BTS.20).aspx
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information on BizTalk Server hot fixes

Properties

Article ID: 977329 - Last Review: September 3, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
Keywords: 
kbbtsmapper kbbiztalk2006r2presp2fix kbsurveynew kbqfe kbautohotfix kbexpertiseadvanced KB977329

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