The "Proxy server name" field is shown incorrectly in Outlook Web Access in an Exchange Server 2007 CAS-to-CAS proxy environment

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Article ID: 977425 - View products that this article applies to.
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SYMPTOMS


Consider the following scenario.
  • In a Microsoft Office Exchange Server 2007 environment, Client Access server (CAS) servers exist in multiple Active Directory Sites.
  • Client-facing servers CAS A1 and CAS A2 are located in Active Directory Site A. CAS servers CAS B1 and CAS B2 are located in Active Directory Site B.
  • A load balancer exists in front of the CAS servers in Active Directory Site A. For example, the https://mail.contoso.com URL resolves to a load balancer that proxies HTTPS connections to either of the two CAS servers within Active Directory Site A.
  • You have a mailbox that is located on an Exchange Server 2007 mailbox server in Active Directory Site B.
  • All CAS servers in Active Directory Site B are configured as nonclient-facing CAS servers. These configurations are set to the NULL value for the ExternalURL property in the OWA virtual directories.
  • You try to access your mailbox by using Microsoft Office Outlook Web Access through the https://CASA1.contoso.com/owa URL or through the https://mail.contoso.com/owa URL.

    Note The target mailbox and the client-facing CAS servers do not exist in the same Active Directory Site. Therefore, a client-facing CAS server proxies the HTTPS connection to an internal CAS server in Active Directory Site B. In this scenario, the client-facing CAS A1 server proxies the user’s connection to one of the internal CAS servers. Then, the internal CAS server accesses the user’s mailbox in Active Directory Site B.
In this CAS-to-CAS proxy environment, you log on to Outlook Web Access, and then click the Options item. Then, you click the About item on the navigation bar to view various information about CAS servers. However, the Proxy server name field on the Outlook Web Access Web page incorrectly shows either "CAS B1" or "CAS B2" instead of the “CAS A1” client-facing server. In this scenario, it is difficult to troubleshoot the data path because the About page does not provide the name of the client-facing CAS server in the Proxy server name field. You must filter the data by time and interpret the IIS logs on all CAS servers in Active Directory Site A. Then, you can determine whether you are connected to client-facing server CAS A1. Note This problem may also occur without load balancers or if you have only one CAS server for each Active Directory Site.

CAUSE

The incorrect proxy server name is caused by a code defect that occurs in the CAS-to-CAS proxy environment.

RESOLUTION

To resolve this problem, install the following update rollup:
972076 Description of Update Rollup 2 for Exchange 2007 Service Pack 2

MORE INFORMATION

In a CAS-to-CAS proxy environment, the following fields exist on the “About" page:
  • Outlook Web Access host address: Provides the URL of the internal CAS server.
  • Outlook Web Access Proxy Host Address: Provides the URL that is entered into your Web browser. Frequently, this is the name of the load-balanced array.
  • Proxy server name: Provides the fully qualified domain name of the client-facing CAS server.
  • Client Access server name: Provides the fully qualified domain name of the internal CAS server.
For more information about how a CAS server can act as a proxy for other CAS servers in an organization, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb310763(EXCHG.80).aspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 977425 - Last Review: January 22, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2007 Service Pack 2, when used with:
    • Microsoft Exchange Server 2007 Enterprise Edition
    • Microsoft Exchange Server 2007 Standard Edition
Keywords: 
kbqfe kbexpertiseinter kbhotfixrollup kbsurveynew KB977425

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