There is a decrease in performance for a real-time application on a computer that is running Windows Server 2003 SP2 if the Performance Monitor or the Logman tool collects lots of performance counter

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Article ID: 977440 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Windows Server 2003 Service Pack 2 (SP2), you use Performance Monitor or the Logman tool to collect lots of performance counter data.
  • Some real-time applications or services are running at the same time. For example, an Office Communication Server (OCS) video conference is running on the same computer.
In this scenario, these real-time applications encounter a periodic decrease in performance. For example, a poor performance issue occurs every 15 seconds. The interval for this periodic decrease in performance is based on the data logging time interval.

CAUSE

The Performance Logs and Alerts service (smlogsvc.exe) threads run at the "Time Critical" priority as real-time application threads. When the Performance Logs and Alerts service logs lots of performance counters, the counter collection threads compete with the threads of some real-time applications for processor time. This behavior causes a periodic decrease in performance of the real-time applications.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2003 Service Pack 2 (SP2).

For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Installation instructions

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

After you install this hotfix, the following registry item is added to the registry:

Location: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SysmonLog

Name: LimitThreadPriority

Type: REG_DWORD

Value: 1


If the value is 1, the Performance Logs and Alerts service threads run at priority 10.

If the value is 0, or if this item is deleted, the performance logs data collection runs at the "Time Critical" priority (15).

Restart requirement

You do not have to restart the computer after you apply this hotfix.

You must restart the Smlogsvc service after you install this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Smlogsvc.exe5.2.3790.461896,76812-Nov-200915:48x86
For all supported x64-based versions of Windows Server 2003

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Smlogsvc.exe5.2.3790.4618133,63212-Nov-200917:15x64SP2
Wsmlogsvc.exe5.2.3790.461896,76812-Nov-200917:15x86SP2
For all supported IA-64-based versions of Windows Server 2003

Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Smlogsvc.exe5.2.3790.4618232,44812-Nov-200917:13IA-64SP2
Wsmlogsvc.exe5.2.3790.461896,76812-Nov-200917:13x86SP2

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 977440 - Last Review: December 23, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Server 2003 Service Pack 2, when used with:
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Keywords: 
kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseinter kbbug kbfix KB977440

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