L'icona "Connesso" non appare nell'area di notifica quando ci si collega a un'applicazione remota tramite Accesso Web Desktop remoto in un computer con Windows Server 2008 R2

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Sintomi

Quando ci si collega a un'applicazione remota tramite Accesso Web Desktop remoto in un computer con Windows Server 2008 R2, l'icona Connesso non appare nell'area di notifica.

Nota Quando un'applicazione remota viene eseguita per la prima volta, nell'area di notifica viene visualizzata l'icona Connesso.

WebSSO (Web Single Sign On) non funziona come previsto, causando un "doppio prompt" per le credenziali nelle applicazioni avviate tramite RemoteApps pubblicate tramite Accesso Web Desktop remoto in Windows Server 2008 R2.

Cause

Questo problema si verifica quando sul computer client esistono più cookie non scaduti.

Workaround

Per risolvere questo problema, eliminare i cookie.

Per risolvere il problema automaticamente, accedere alla sezione "Correzione automatica". Per risolvere il problema autonomamente, accedere alla sezione "Correzione manuale".

Correzione automatica



Per risolvere il problema automaticamente, fare clic sul pulsante o sul collegamento Fix it. Fare clic su Esegui nella finestra di dialogo Download file e attenersi alla procedura guidata Fix it.


Risolvere il problema
Microsoft Fix it 50631


Note
  • Questa procedura guidata potrebbe essere disponibile solo in lingua inglese. La correzione automatica, tuttavia, funziona anche per versioni di Windows in altre lingue.
  • Se non si sta utilizzando il computer che presenta il problema, è possibile salvare la soluzione Fix it su un'unità di memoria flash o su un CD ed eseguirla sul computer interessato dal problema.

Accedere, quindi, alla sezione "Il problema è stato risolto?".



Correzione manuale

Per eliminare i cookie in Windows Internet Explorer 8, attenersi alla seguente procedura:
  1. Fare clic sul pulsante Start, scegliere Pannello di controllo, fare clic su Rete e connessioni Internet, quindi scegliere Opzioni Internet.
  2. Nella scheda Generale, scegliere Elimina.
  3. Per eliminare solo i cookie, fare clic per selezionare la casella di controllo Cookie, quindi fare clic per deselezionare tutte le altre caselle di controllo.
  4. Scegliere Elimina.

Un'altra opzione che non prevede l'eliminazione dei cookie consiste nella modifica del file script C:\windows\Web\RDWeb\Pages\renderscripts.js nel server Accesso Web Desktop remoto.

Per modificare il file di script C:\windows\Web\RDWeb\Pages\renderscripts.js, attenersi alla seguente procedura:

1. Accedere al server Accesso Web Desktop remoto come membro del gruppo di amministratori locali.
2. Individuare il file jscript seguente, fare clic con il pulsante destro del mouse e selezionare Modifica.

C:\windows\Web\RDWeb\Pages\renderscripts.js

3. Individuare l'implementazione della funzione seguente in tale file jscript.
function getCookieContents(strNameOfCookie)

4. Modificare i codici nel file jscript in modo che corrispondano a quanto di seguito indicato:


Codice esistente nel file Renderscripts.js:

------------------------------------------
function getCookieContents(strNameOfCookie)
{
var objCookie;
var objCookieName;
var objCookieContents = null;

if ( strNameOfCookie != null &&
strNameOfCookie != "" &&
document.cookie.length > 0 )
{
var objCookies = document.cookie.split(";");
for (var iIndex = 0; iIndex < objCookies.length; iIndex++)
{
objCookie = objCookies[iIndex];
objCookieName = objCookie.substring(0, strNameOfCookie.length);



Modificare la sezione precedente nel file Renderscripts.js in modo che corrisponda a quanto di seguito indicato:

---------------------------------------------------------------------------------------
// Aggiungere una funzione denominata trim come metodo prototipo
// oggetto del costruttore String.
String.prototype.trim = function()
{
// Utilizzare un'espressione regolare per sostituire la parte iniziale e quella finale
// spazi con la stringa vuota
return this.replace(/(^\s*)|(\s*$)/g, "");
}
// Fine della funzione appena aggiunta

function getCookieContents(strNameOfCookie)
{
var objCookie;
var objCookieName;
var objCookieContents = null;

if ( strNameOfCookie != null &&
strNameOfCookie != "" &&
document.cookie.length > 0 )
{
var objCookies = document.cookie.split(";");
for (var iIndex = 0; iIndex < objCookies.length; iIndex++)
{
objCookie = objCookies[iIndex];
objCookie = objCookie.trim(); //Richiamo della funzione appena aggiunta
objCookieName = objCookie.substring(0, strNameOfCookie.length);

Il problema è stato risolto?

  • Controllare se il problema è stato risolto. Se il problema è stato risolto, non è necessario continuare la lettura di questa sezione. Se il problema non è stato risolto, contattare il supporto tecnico.
  • I commenti degli utenti sono molto utili. Per fornire commenti o segnalare problemi relativi a questa soluzione, lasciare un commento nel blog "Correzione automatica" o inviare un messaggio di posta elettronica a Microsoft.

Informazioni

Questo problema può verificarsi in presenza delle seguenti condizioni: 
  • Accesso Web Desktop remoto è un sottodominio che dispone di un dominio padre.
  • Il dominio padre, o qualunque altro sottodominio, scrive un cookie che dispone del dominio impostato sul livello di dominio padre. Questo meccanismo consente di condividere il cookie tra tutti i sottodomini.
Se Accesso Web Desktop remoto viene collocato al livello del dominio padre, l'icona di connessione appare nell'area di notifica. Inoltre, la funzione SSO (Single Sign On), l'applicazione remota e la connessione desktop funzionano come previsto quando ci si collega all'applicazione remota.


Questo problema potrebbe verificarsi anche quando il cookie ripresentato al client dal server Web contiene ulteriori informazioni del cookie.



Nota: questo è un articolo a "PUBBLICAZIONE RAPIDA", creato direttamente all'interno dell'organizzazione di supporto Microsoft. Le informazioni contenute nel presente documento vengono fornite "così come sono" in risposta alle problematiche riscontrate. A causa della rapidità con cui vengono resi disponibili, i materiali possono contenere errori di battitura e sono soggetti a modifica senza preavviso, in qualsiasi momento. Per altre considerazioni, vedere le Condizioni per l'utilizzo.

Proprietà

Identificativo articolo: 977507 - Ultima modifica: venerdì 21 ottobre 2011 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
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