Un recurso de disco físico permanece en el estado de "Conexión pendiente" o la utilidad Chkdsk se inicia automáticamente para que se ejecute en un servidor que ejecuta Windows Server 2008

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Síntomas

Al poner en conexión un recurso de disco físico en un servidor que ejecuta Windows Server 2008, puede experimentar uno de los síntomas siguientes:

Síntoma 1

Al ver el recurso disco físico en el complemento Administración de clúster de conmutación por error, el recurso puede mostrar el estado Conexión pendiente. Además, la siguiente mensaje de error se registra en el registro del sistema:
Nombre del registro: sistema
Origen: Microsoft-Windows-FailoverClustering
ID. de suceso: 1066
Categoría de tarea: Recurso de disco físico de
Nivel: advertencia
Descripción:
Recurso de disco de clúster 'Disco 3 de clúster' indica daños en el volumen ' \\?\Volume{ec2fa15d-b438-11de-88bc-00155dd99d36}'. Se ejecuta Chkdsk para reparar los problemas. El disco no estará disponible hasta que termine de Chkdsk. Salida de CHKDSK se registrará en el archivo '3_Disk2Part1.log de C:\Windows\Cluster\Reports\ChkDsk_ResCluster disco'.
Chkdsk también puede escribir información en el registro de sucesos de aplicación.
Además, la siguiente mensaje de error se registra en el registro del clúster:
ERR [RES] de disco físico <cluster disk="" 3="">: VerifyFS: no se pudo abrir el archivo \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt Error: 5.</cluster>

Síntoma 2

Al ver el recurso disco físico en la utilidad Administrador de clústeres de Microsoft, puede experimentar uno o varios de los síntomas siguientes:
  • El recurso no puede ponerse en conexión o puede ponerse en conexión tras un breve retraso.
  • La utilidad Chkdsk junto con el /F modificador se inicia automáticamente para ejecutarse en el disco duro compartido.
  • ID. de suceso 1066 que tiene una descripción similar al siguiente aparece en el registro del sistema, el Visor de sucesos:
    Disco Y: el recurso de clúster: está dañado. Ejecución de ChkDsk /F para reparar los problemas.

Causa

Estos problemas se producen para uno de los siguientes motivos.

Causa del síntoma 1

Este problema se produce porque un archivo de sólo lectura se encuentra en el directorio raíz del recurso. Cuando se conecte un recurso de disco físico compartido, el servicio de Cluster Server enumera los archivos del directorio raíz y se intenta abrir cada archivo junto con acceso completo. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y que el volumen no está dañado. Si alguno de los archivos son de sólo lectura en el directorio raíz del recurso, se considera que el volumen dañado y Chkdsk se ha iniciado. Para evitar este problema, utilice la solución que se menciona en la sección "Solución 1".

Causa del síntoma 2

Este problema se produce porque se ha establecido el indicador "sucio" para el volumen. Cuando se conecte un recurso de disco físico compartido, el servicio de Cluster Server enumera los archivos del directorio raíz y se intenta abrir cada archivo junto con acceso completo. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y que el volumen no está dañado. Si alguno de los archivos tiene el indicador de "sucio" establecido en el directorio raíz del recurso, se considera que el volumen dañado y Chkdsk se ha iniciado. Para evitar este problema, utilice la solución que se menciona en la sección "Solución 2".

Solución

Solución 1

Para evitar este problema, siga uno de estos procedimientos:
  • Desactive el atributo de sólo lectura de los archivos viendo las propiedades de archivo o mediante la attrib - r comando en un símbolo del sistema.
  • Mueva los archivos que tienen el atributo de sólo lectura desde el directorio raíz del recurso a una subcarpeta adecuada.

NOTA: Si no puede conectar el disco y realizar cualquier verificación adicional en los archivos, establezca la propiedad privada del disco físico DiskRunChkDsk para una propiedad de (4ChkDskDontRun). Esto deshabilitará comprobaciones de montaje de volumen. Para obtener más información, consulte:

No se puede poner en línea el disco compartido en el clúster de Windows Server 2008
http://support.Microsoft.com/kb/2517696


Solución 2

Para evitar este problema, determine primero si se ha establecido el indicador "sucio" para el volumen especificado.

Para determinar si se ha establecido el indicador "sucio" para el volumen en Windows Server 2008, utilice la herramienta de Chkntfs.

Para obtener más información acerca de la herramienta de Chkntfs, visite el siguiente sitio Web de Microsoft TechNet:
http://technet.Microsoft.com/en-us/library/cc731298 (WS.10) (.aspx)
Para determinar si se ha establecido el indicador "sucio" para el volumen en Windows Server 2008 R2, utilice el validar un asistente de configuración.

Para obtener más información sobre el validar un asistente de configuración, visite el siguiente sitio Web de Microsoft TechNet:
http://technet.Microsoft.com/en-us/library/cc772055.aspx
Si se establece el indicador "sucio" para el volumen, ejecute la utilidad Chkdsk junto con el modificador/f.

Para obtener más información acerca de la utilidad Chkdsk, visite el siguiente sitio Web de Microsoft TechNet:
http://technet.Microsoft.com/en-us/library/cc730714 (WS.10) (.aspx)

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Propiedades

Id. de artículo: 977516 - Última revisión: martes, 17 de mayo de 2011 - Versión: 0.1
La información de este artículo se refiere a:
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
Palabras clave: 
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Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 977516

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