Un recurso de disco físico permanece en el estado Pendiente en línea o la utilidad Chkdsk comienza a ejecutarse automáticamente en un servidor que ejecuta Windows Server 2008

Este artículo ayuda a corregir un problema por el que se pueden registrar varios mensajes de errores al poner en línea un recurso de disco físico.

Se aplica a: Windows Server 2012 R2
Número de KB original: 977516

Síntomas

Al poner en línea un recurso de disco físico en un servidor que ejecuta Windows Server 2008, puede experimentar uno de los síntomas siguientes:

Síntoma 1

Al ver el recurso de disco físico en el complemento Administración de clústeres de conmutación por error, el recurso puede mostrar un estado Pendiente en línea. Además, se registra el siguiente mensaje de error en el registro del sistema:

Nombre de registro: Sistema
Origen: Microsoft-Windows-FailoverClustering
Identificador de evento: 1066
Categoría de tarea: Recurso de disco físico
Nivel: Advertencia
Descripción:
El recurso de disco del clúster "Disco de clúster 3" indica daños en el volumen '\\?\Volume{ec2fa15d-b438-11de-88bc-00155dd99d36}'. Chkdsk se está ejecutando para reparar problemas. El disco no estará disponible hasta que se complete Chkdsk. La salida de Chkdsk se registrará en el archivo "C:\Windows\Cluster\Reports\ChkDsk_ResCluster Disk 3_Disk2Part1.log".
Chkdsk también puede escribir información en el registro de eventos de la aplicación.

Además, se registra el siguiente mensaje de error en el registro de clúster:

ERR [RES] Disco de clúster de disco <físico 3>: VerifyFS: No se pudo abrir el archivo \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt Error: 5.

Síntoma 2

Al ver el recurso de disco físico en la utilidad Administrador de clústeres de Microsoft, puede experimentar uno o varios de los síntomas siguientes:

  • Es posible que el recurso no esté en línea o que se conecte después de un breve retraso.

  • La utilidad Chkdsk junto con el modificador /F comienza a ejecutarse automáticamente en el disco duro compartido.

  • El identificador de evento 1066 que tiene una descripción similar a la siguiente aparece en el registro del sistema de la Visor de eventos:

    El recurso de clúster Disk Y:: está dañado. Ejecución de ChkDsk /F para reparar problemas.

Causa

Estos problemas se producen por una de las siguientes razones.

Causa del síntoma 1

Este problema se produce porque un archivo de solo lectura se encuentra en el directorio raíz del recurso. Cuando se conecta un recurso de disco físico compartido, el servicio de clúster enumera los archivos del directorio raíz e intenta abrir cada archivo junto con acceso completo. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y de que el volumen no está dañado. Si alguno de los archivos es de solo lectura en el directorio raíz del recurso, el volumen se considera dañado y se inicia Chkdsk. Para solucionar este problema, use la solución alternativa que se menciona en la sección Solución alternativa del síntoma 1 .

Causa del síntoma 2

Este problema se produce porque se establece la marca "dirty" para el volumen. Cuando se conecta un recurso de disco físico compartido, el servicio de clúster enumera los archivos del directorio raíz e intenta abrir cada archivo junto con acceso completo. Este comportamiento se produce para asegurarse de que el sistema de archivos es coherente y de que el volumen no está dañado. Si alguno de los archivos tiene establecida la marca "dirty" en el directorio raíz del recurso, el volumen se considera dañado y se inicia Chkdsk. Para solucionar este problema, use la solución alternativa que se menciona en la sección Solución alternativa del síntoma 2 .

Solución alternativa del síntoma 1

Para solucionar este problema, realice una de las siguientes acciones:

  • Borre el atributo de solo lectura de los archivos mediante la visualización de las propiedades del archivo o mediante el comando en un símbolo del attrib -r sistema.
  • Mueva los archivos que tienen el atributo de solo lectura del directorio raíz del recurso a una subcarpeta adecuada.

Nota:

Si no puede poner el disco en línea y realizar una comprobación adicional en los archivos, establezca la propiedad privada DiscoRunChkDsk en una propiedad de 4 (ChkDskDontRun). Esto deshabilitará las comprobaciones de montaje de volumen.

Solución alternativa del síntoma 2

Para solucionar este problema, determine primero si se establece la marca "dirty" para el volumen especificado.

Para determinar si la marca "dirty" está establecida para el volumen en Windows Server 2008, use la herramienta Chkntfs.

Para obtener más información sobre la herramienta Chkntfs, visite el siguiente sitio web de Microsoft TechNet:
Chkntfs

Para determinar si la marca "dirty" está establecida para el volumen en Windows Server 2008 R2, use el Asistente para validar una configuración.

Para obtener más información sobre el Asistente para validar una configuración, visite el siguiente sitio web de Microsoft TechNet:
Validación de una configuración de clúster de conmutación por error

Si se establece la marca "dirty" para el volumen, ejecute la utilidad Chkdsk junto con el modificador /F.

Para obtener más información sobre la utilidad Chkdsk, visite el siguiente sitio web de Microsoft TechNet:
Chkdsk

Estado

Microsoft ha confirmado que se trata de un problema en los productos de Microsoft que aparecen al principio de este artículo.