Um recurso disco físico permanece no estado "Pendente Online" ou o utilitário Chkdsk inicia automaticamente para ser executado num servidor que esteja a executar o Windows Server 2008

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Sintomas

Quando colocar online um recurso de disco físico num servidor que esteja a executar o Windows Server 2008, poderá detectar um dos seguintes sintomas:

Sintoma 1

Quando visualiza o recurso de disco físico no snap-in Gestão de Cluster de activação pós-falha, o recurso poderá apresentar um Estado Pendente online. Além disso, a seguinte mensagem de erro é registada no registo do sistema:
Iniciar sessão nome: sistema
Origem: Microsoft-Windows-FailoverClustering
ID do evento: 1066
Categoria de tarefa: Recurso de disco físico
Nível: aviso
Descrição:
Recurso de disco de cluster '3 de disco de Cluster' indica danos para o volume ' \\?\Volume{ec2fa15d-b438-11de-88bc-00155dd99d36}'. O CHKDSK está a ser executado para reparar problemas. O disco não estará disponível até que o Chkdsk esteja concluída. Saída do CHKDSK será registada para o ficheiro 'disco de C:\Windows\Cluster\Reports\ChkDsk_ResCluster 3_Disk2Part1.log'.
Chkdsk pode também escrever informações no registo de eventos aplicação.
Além disso, a seguinte mensagem de erro é registada no registo de Cluster:
ERR disco físico [RES] <cluster disk="" 3="">: VerifyFS: Falha ao abrir o ficheiro \\?\GLOBALROOT\Device\Harddisk2\Partition1\TextDocument.txt erro: 5.</cluster>

Sintoma 2

Quando visualiza o recurso de disco físico no utilitário do administrador de clusters da Microsoft, poderá detectar um ou mais dos seguintes sintomas:
  • O recurso não pode ficar online ou pode ficar online após um breve atraso.
  • O utilitário Chkdsk juntamente com o /F parâmetro inicia automaticamente para ser executado no disco rígido partilhado.
  • ID de evento 1066 que tenha uma descrição semelhante à seguinte é apresentada no registo de sistema do Visualizador de eventos:
    /Y: disco de recurso de cluster: está danificado. Executar o ChkDsk /F para reparar problemas.

Causa

Estes problemas ocorrem por uma das seguintes razões.

Causa do sintoma 1

Este problema ocorre porque um ficheiro só de leitura está localizado no directório raiz do recurso. Quando um recurso disco físico partilhada for colocado online, o serviço de cluster enumera os ficheiros do directório raiz e tenta abrir cada ficheiro juntamente com acesso total. Este comportamento ocorre para se certificar de que o sistema de ficheiros é consistente e que o volume não está danificado. Se algum dos ficheiros são só de leitura no directório raiz do recurso, o volume é considerado danificado e Chkdsk é iniciado. Para contornar este problema, utilize a solução alternativa mencionada na secção "Como contornar 1".

Causa do sintoma 2

Este problema ocorre porque o sinalizador "dirty" para o volume está definido. Quando um recurso disco físico partilhada for colocado online, o serviço de cluster enumera os ficheiros do directório raiz e tenta abrir cada ficheiro juntamente com acesso total. Este comportamento ocorre para se certificar de que o sistema de ficheiros é consistente e que o volume não está danificado. Se tiver qualquer um dos ficheiros o sinalizador "dirty" definido no directório raiz do recurso, o volume é considerado danificado e Chkdsk é iniciado. Para contornar este problema, utilize a solução alternativa mencionada na secção "Como contornar 2".

Como contornar

Solução 1

Para contornar este problema, efectue um dos seguintes procedimentos:
  • Desmarque o atributo só de leitura a partir dos ficheiros, visualizando as propriedades de ficheiro ou utilizando o attrib - r comando numa linha de comandos.
  • Mova os ficheiros que têm o atributo só de leitura do directório raiz do recurso para uma subpasta apropriada.

NOTA: Se conseguir colocar o disco online e efectuar qualquer verificação suplementar nos ficheiros, defina a propriedade privada do disco físico DiskRunChkDsk para uma propriedade de 4 (ChkDskDontRun). Este procedimento desactivará a controlos de montagem de volume. Para mais informações, consulte:

Disco partilhado num cluster do Windows Server 2008 não consegue ficar online
http://support.microsoft.com/KB/2517696


Solução 2

Para contornar este problema, determine primeiro se o sinalizador "dirty" para o volume especificado está definido.

Para determinar se o sinalizador "dirty" está definido para o volume no Windows Server 2008, utilize a ferramenta Chkntfs.

Para mais informações sobre a ferramenta Chkntfs, visite o seguinte Web site Microsoft TechNet:
. aspx http://technet.microsoft.com/en-us/library/cc731298 (WS.10)
Para determinar se o sinalizador "dirty" está definido para o volume no Windows Server 2008 R2, utilize o Assistente para validar uma configuração.

Para mais informações sobre o Assistente para validar uma configuração, visite o seguinte Web site Microsoft TechNet:
http://technet.microsoft.com/en-us/library/cc772055.aspx
Se o sinalizador "dirty" está definido para o volume, execute o utilitário Chkdsk juntamente com o parâmetro /F.

Para mais informações sobre o utilitário Chkdsk, visite o seguinte Web site Microsoft TechNet:
. aspx http://technet.microsoft.com/en-us/library/cc730714 (WS.10)

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Propriedades

Artigo: 977516 - Última revisão: 17 de maio de 2011 - Revisão: 0.1
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Web Server 2008
Palavras-chave: 
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Tradução automática
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