Reciba DFSR evento ID 2212 después de reiniciar el servicio DFSR en Windows Server 2008

Seleccione idioma Seleccione idioma
Id. de artículo: 977518 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando reinicie el servicio de replicación de sistema archivo distribuido (DFSR) en un servidor que ejecuta Windows Server 2008 o reiniciar el servidor, el suceso siguiente puede grabarse en el registro de replicación DFS:
Nombre de registro: Replicación de DFS
Origen: DFSR
ID. de suceso: 2212
Categoría de tareas: ninguno
Nivel: advertencia
Palabras clave: clásico
Usuario: N/d
Equipo: MyDfsrMember. contoso.com
Descripción:
El servicio de replicación DFS ha detectado un apagado inesperado en volumen Drive_Letter. Esto puede ocurrir si el servicio se terminó de forma anormal (debido a una pérdida de alimentación, por ejemplo) o se ha producido un error en el volumen. El servicio automáticamente ha iniciado un proceso de recuperación. El servicio volverá a generar la base de datos si se determina de forma confiable no puede recuperar. No se requiere ninguna acción de usuario.
Una vez transcurrido algún tiempo, DFSR registra el suceso ID 2214. Este evento indica que ha terminado el proceso de recuperación de base de datos. Durante la recuperación de la base de datos, se retrasa el performance de replicación.

Causa

Este problema se produce porque el Administrador de control de servicios (SCM) utiliza el valor de tiempo de espera predeterminado de 20 segundos para detener un servicio. En algunas implementaciones complejas DFSR, este valor de tiempo de espera puede ser demasiado corto y DFSR deja antes de que se cierre la base de datos adecuada. En el reinicio del servicio, DFSR detecta esta condición y realiza la recuperación de la base de datos.

Solución

Para resolver este problema, puede cambiar el valor predeterminado de tiempo de espera que el SCM utiliza agregando el valor del registro siguiente:

Nombre del valor WaitToKillServiceTimeout
Tipo de datos REG_SZ
Cadena 20000 milisegundos (valor predeterminado)

Para especificar el tiempo de espera, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Ejecutar, escriba regedit y, a continuación, haga clic en Aceptar.
  2. Busque y haga clic en la siguiente clave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. En el menú Edición, seleccione nuevo y, a continuación, haga clic en Valor de cadena.
  4. Escriba WaitToKillServiceTimeout y, a continuación, presione ENTRAR.
  5. En el menú Edición, haga clic en Modificar.
  6. Escriba 60000 y, a continuación, haga clic en Aceptar.
  7. Salir del Editor del registro.
  8. Reinicie el servidor.
Si el intervalo de tiempo es un valor distinto de 60 segundos, puede establecer el valor del valor del registro WaitToKillServiceTimeout a la diferencia de tiempo en milisegundos, entre los dos sucesos siguientes en el registro de sucesos DFSR:
  • 1006 El servicio de replicación DFS se está deteniendo.
  • 1008 Se detuvo el servicio de replicación DFS.

Referencias

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
146092Cómo aumentar el tiempo de apagado para que los servicios cerrar correctamente

Propiedades

Id. de artículo: 977518 - Última revisión: viernes, 20 de noviembre de 2009 - Versión: 1.1
La información de este artículo se refiere a:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
Palabras clave: 
kbmt kbtshoot kbexpertiseinter kbsurveynew kbprb KB977518 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 977518

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com