Vous recevez l’ID d’événement DFSR 2212 après avoir redémarré le service DFSR dans Windows Server 2008
Cet article décrit un problème dans lequel vous recevez l’événement de réplication DFS 2212 et DFSR s’arrête après le redémarrage de Windows Server 2008. Peu de temps plus tard, l’événement 2214 est enregistré dans le journal de réplication DFS.
S’applique à : Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 977518
Symptômes
Lorsque vous redémarrez le service de réplication de système de fichiers distribué (DFSR) sur un serveur exécutant Windows Server 2008, ou que vous redémarrez le serveur, l’événement suivant peut être enregistré dans le journal de réplication DFS :
Nom du journal : Réplication DFS
Source : DFSR
ID d’événement : 2212
Catégorie de la tâche : Aucun
Niveau : Avertissement
Mots clés : classique
Utilisateur : N/A
Ordinateur : MyDfsrMember.contoso.com
Description :
Le service de réplication DFS a détecté un arrêt inattendu sur le volume Drive_Letter. Cela peut se produire si le service s’est arrêté anormalement (en raison d’une perte de courant, par exemple) ou si une erreur s’est produite sur le volume. Le service a automatiquement lancé un processus de récupération. Le service régénère la base de données s’il détermine qu’elle ne peut pas être récupérée de manière fiable. Aucune action de l’utilisateur n’est requise.
Après un certain temps, DFSR journalise l’ID d’événement 2214. Cet événement indique que le processus de récupération de base de données est terminé. Pendant la récupération de la base de données, les performances de réplication sont ralenties.
Cause
Ce problème se produit car le Gestionnaire de contrôle de service (SCM) utilise la valeur de délai d’attente par défaut de 20 secondes pour arrêter un service. Dans certaines implémentations DFSR complexes, cette valeur de délai d’attente peut être trop courte et DFSR s’arrête avant la fermeture de la base de données appropriée. Au redémarrage du service, DFSR détecte cette condition et effectue la récupération de la base de données.
Résolution
Pour résoudre ce problème, vous pouvez modifier la valeur de délai d’attente par défaut utilisée par le SCM en ajoutant la valeur de Registre suivante :
Nom de la valeur WaitToKillServiceTimeout
Type de données REG_SZ
Chaîne 20 000 millisecondes (valeur par défaut)
Pour spécifier le temps d’attente, procédez comme suit :
Cliquez sur Démarrer, sur Exécuter, tapez
regedit
, puis cliquez sur OK.Recherchez et cliquez sur la clé suivante dans le Registre :
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control
Dans le menu Modifier , pointez sur Nouveau, puis cliquez sur Valeur de chaîne.
Tapez WaitToKillServiceTimeout, puis appuyez sur Entrée.
Dans le menu Edition, cliquez sur Modifier.
Tapez 60000, puis cliquez sur OK.
Fermez l’Éditeur du Registre.
Redémarrez le serveur.
Si l’intervalle de temps est différent de 60 secondes, vous pouvez définir la valeur de la valeur de Registre WaitToKillServiceTimeout sur la différence de temps, en millisecondes, entre les deux événements suivants dans le journal des événements DFSR :
1006 - Le service de réplication DFS s’arrête.
1008 - Le service de réplication DFS s’est arrêté.
Veillez à installer kb 2549760 pour garantir les performances correctes de la valeur de Registre WaitToKillServiceTimeout
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