REVISIÓN: El contenido de un documento MIME o S/MIME se pierde en BizTalk Server

Seleccione idioma Seleccione idioma
Id. de artículo: 977529 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Recibirá una MIME o MIME seguro (S/MIME) documento de Microsoft BizTalk Server 2006 R2.
  • El documento MIME o S/MIME tiene un archivo adjunto, y hay una imagen en el cuerpo del mensaje.
En este escenario, el contenido del cuerpo del mensaje se pierde después de se procesa mediante BizTalk Server 2006 R2.

Este problema puede producirse si uno de las siguientes condiciones es verdadera:
  • Utilice el Adaptador POP3 para recuperar datos de un servidor que alberga buzones POP3.
  • Utilice el Archivo adaptador para recibir Algunos MIME o S/MIME archivos, y el procesar estos archivos mediante el uso de una canalización que utilice el MIME o S/MIME descodificador componente.

NotaSi utiliza BizTalk Server 2009, la categoría de sucesos en por encima de los eventos y el origen de eventos son "2009 de BizTalk Server".

Causa

Este problema se produce porque el MIME o S/MIME componente descodificador realiza de manera no recursiva procesar los niveles MIME en un mensaje cuerpo.

Solución

Información de la revisión

Información de actualización acumulativa

BizTalk Server 2009

La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 2 para BizTalk Server 2009.

Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

2497794Paquete 2 de la actualización acumulativa para BizTalk Server 2009
A hotfix compatible está disponible desde Microsoft. Sin embargo, esta revisión se diseñó Para corregir el problema descrito en este artículo. Aplicar este revisión sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, hay disponible una descarga de revisión"" sección en la parte superior de este artículo de Knowledge Base. Si esta sección no aparecen, enviar una solicitud de servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicará a las cuestiones y problemas que no reúnan los requisitos para Esta revisión en cuestión. Para obtener una lista completa de servicio al cliente de Microsoft y Compatibilidad con los números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:-
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque un revisión no está disponible para ese idioma.

Requisitos previos

Debe tener BizTalk Server 2006 R2 instalado para aplicar esta revisión.

Requisito de reinicio

No es necesario reiniciar el equipo después de aplicar esta revisión.

Información de reemplazo de hotfix

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene el archivo atributos (u otros posteriores) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice elTiempo Zonaficha en laFecha y horaelemento de Panel de Control.
Microsoft BizTalk Server 2006 R2
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoArchivo tamañoFechaTiempoPlataforma
Btsmimecomps.dll3.6.1555.2160,60018-Dic-200909: 41x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de MIME y S/MIME descodificador componente de canalización, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
http://msdn.Microsoft.com/en-us/library/dd760874%28BTS.10%29.aspx
Para obtener más información información acerca de las revisiones de BizTalk Server, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
2003907Información sobre revisiones de BizTalk Server

Propiedades

Id. de artículo: 977529 - Última revisión: viernes, 18 de marzo de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft BizTalk Server 2006 R2 Branch
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Palabras clave: 
kbbiztalk2006r2presp2fix kbbtspipeline kbsurveynew kbqfe kbHotfixServer kbautohotfix kbexpertiseadvanced kbbiztalk2009presp1fix kbmt KB977529 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 977529

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com