Article ID: 977560 - Last Review: December 9, 2009 - Revision: 1.0

Update fails when you use a CDO application to update a recurrence task on Exchange Server 2010

System TipThis article applies to a different operating system than the one you are using. Article content that may not be relevant to you is disabled.
Expand all | Collapse all

SYMPTOMS

When you use a Collaboration Data Objects (CDO) application to update a recurrence task on Microsoft Exchange Server 2010, the update fails.
For example, you create a weekly recurrence task and remove a recurrence flag of the task by using a CDO application. After you remove the recurrence flag, you find that the task is still a recurrence task in Microsoft Office Outlook.

CAUSE

When you remove the recurrence flag for a recurrence task, the corresponding recurrence property value of the task is set as "NULL". However, the related recurrence property value is also checked internally. This internal check treats the "NULL" value as an abnormal value.

RESOLUTION

To resolve this problem, install the following update rollup:
976573  (http://support.microsoft.com/kb/976573/ ) Description of Update Rollup 1 for Exchange Server 2010

APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbfix kbqfe kbexpertiseinter kbhotfixrollup KB977560