VSS backup process stops responding when you try to perform a Volume Shadow Copy Service (VSS) backup for Exchange Server 2010 databases

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Article ID: 977561 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You have a Microsoft Exchange Server 2010 server that is installed with multiple databases.
  • These databases are mounted.
  • You have circular logging for these databases enabled.
  • You disable circular logging for these databases.
  • You try to perform an incremental Volume Shadow Copy Service (VSS) backup for these databases based on a full VSS backup.
In this scenario, some logs are overwritten by new logs caused by enabling and disabling circular logging. Then, when you try to perform the incremental VSS backup, the incremental VSS backup process and the corresponding database crash. At the same time, you find the following two Event errors:


Source: ESE
Event ID: 2008
Task Category: ShadowCopy
Description:
Information Store (9180) Shadow copy instance 3 starting. This will be an Incremental shadow copy.

Source: ESE
Event ID: 459
Description:
Information Store (9180) Mailbox Database 1918355318: The file C:\Program Files\Microsoft\Exchange Server\V14\Mailbox\Mailbox Database 1918355318\E0000000110.log is missing and could not be backed-up.

CAUSE

The issue described in the "Symptoms" section occurs because of an internal deadlock in the Exchange Database Engine (ESE).

RESOLUTION

To resolve this problem, install the following update rollup:
976573 Description of Update Rollup 1 for Exchange Server 2010

Note This update cannot prevent the incremental VSS backup from failing, as some required logs are still missing caused by switching circular logging on and off before you try to perform the incremental VSS backup.

MORE INFORMATION

For more information about Exchange Server 2010 and VSS Backup, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/dd876874(EXCHG.140).aspx

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 977561 - Last Review: December 9, 2009 - Revision: 1.0
APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbfix kbexpertiseinter kbhotfixrollup kbqfe kbsurveynew KB977561

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