Article ID: 977633 - Last Review: March 4, 2010 - Revision: 1.0

Certain third-party IMAP4 clients cannot connect to Exchange Server 2003 mailboxes through an Exchange Server 2010 CAS server

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SYMPTOMS

In a mixed Microsoft Exchange Server 2003 and Microsoft Exchange Server 2010 environment, the Exchange Server 2003 mailboxes are accessed through an Exchange Server 2010 Client Access Server (CAS) server. In this case, users cannot access their Exchange Server 2003 mailboxes by using certain third-party IMAP4 clients. Additionally, the users may receive the following error message:
"Login to server <servername> failed"

CAUSE

This problem occurs because certain third-party IMAP4 clients use the PLAIN authentication mechanism. The Exchange Server 2010 CAS server performs an additional check on the namespace in the Exchange Server 2003 server. However, the responses from the Exchange Server 2003 server are mishandled by the Exchange Server 2010 CAS server. Therefore, users cannot access their Exchange Server 2003 mailboxes by using certain third-party IMAP4 clients.

RESOLUTION

To resolve this problem, install the following update rollup:
979611  (http://support.microsoft.com/kb/979611/ ) Description of Update Rollup 2 for Exchange Server 2010: February 18, 2010

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the IMAP4 protocol and the PLAIN authentication mechanism, visit the following IETF Web sites:



APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbsurveynew kbfix kbhotfixrollup kbexpertiseinter kbqfe KB977633