Error al cambiar la identidad de un grupo de aplicaciones mediante el Administrador de IIS desde un equipo remoto: El conjunto de claves no existe
En este artículo se resuelve el error No existe el conjunto de claves. El error se produce al cambiar la identidad de un grupo de aplicaciones mediante Microsoft Internet Information Services (IIS) Manager desde un equipo remoto.
Versión original del producto: Windows Server 2008, Windows Server 2008 R2
Número de KB original: 977754
Síntomas
Imagine la siguiente situación:
- En un servidor que ejecuta Windows Server 2008 o Windows Server 2008 R2, habilita la administración remota para IIS.
- El servidor tiene más de un grupo de aplicaciones configurado en IIS.
- Uno de los grupos de aplicaciones está configurado para usar la identidad de usuario personalizada.
- Use el Administrador de IIS para conectarse al servidor como administrador desde un equipo remoto.
En este escenario, cuando intente cambiar la identidad de cualquier grupo de aplicaciones, recibirá el siguiente mensaje de error:
Se produjo un error al realizar esta operación.
Detalles:
El conjunto de claves no existe (excepción de HRESULT: 0x80090016)
Causa
La cuenta DE SERVICIO LOCAL es la cuenta de servicio de la Servicio de administración web de IIS (también conocida como WMSvc). Este problema se produce porque la cuenta DE SERVICIO LOCAL no tiene acceso de lectura en la iisWasKey
clave que se encuentra en la %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys
carpeta.
Este es el nombre de archivo de la iisWasKey
clave:
76944fb33636aeddb9590521c2e8815a_GUID
Solución
Para resolver este problema, siga estos pasos:
- Busque la
%ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys
carpeta . - Haga clic con el botón derecho en el archivo 76944fb33636aeddb9590521c2e8815a_GUID y, a continuación, seleccione Propiedades.
- Seleccione la pestaña Seguridad y, a continuación, seleccione Editar. Si se le pregunta si desea continuar con la operación, seleccione Continuar. A continuación, la lista de nombres de grupo y nombres de usuario que tienen acceso a este archivo de clave aparece en el cuadro de diálogo Permisos .
- Seleccione Agregar. A continuación, aparece el cuadro de diálogo Seleccionar usuarios, equipos, cuentas de servicio o grupos .
- Escriba LOCAL SERVICE y, a continuación, seleccione Comprobar nombres.
- Seleccione Aceptar.
- En la lista Nombres de grupo o de usuario , seleccione SERVICIO LOCAL. Asegúrese de que la casilla Leer esté activada en la lista Permisos para SERVICIO LOCAL .
- Seleccione Aceptar.
Más información
Este problema se ha corregido en Windows Server 2008 Service Pack 2.
Comentarios
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