Erro ao alterar a identidade de um pool de aplicativos usando o IIS Manager de um computador remoto: o conjunto de chaves não existe

Este artigo resolve que o conjunto de chaves não existe erro. O erro ocorre quando você altera a identidade de um pool de aplicativos usando Serviços de Informações da Internet da Microsoft (IIS) Manager de um computador remoto.

Versão original do produto: Windows Server 2008, Windows Server 2008 R2
Número de KB original: 977754

Sintomas

Considere o seguinte cenário:

  • Em um servidor que está executando o Windows Server 2008 ou Windows Server 2008 R2, você habilita o gerenciamento remoto para IIS.
  • O servidor tem mais de um pool de aplicativos configurado no IIS.
  • Um dos pools de aplicativos está configurado para usar a identidade do usuário personalizada.
  • Você usa o IIS Manager para se conectar ao servidor como administrador de um computador remoto.

Nesse cenário, ao tentar alterar a identidade de qualquer pool de aplicativos, você receberá a seguinte mensagem de erro:

Houve um erro ao executar essa operação.
Detalhes:
O conjunto de chaves não existe (Exceção de HRESULT: 0x80090016)

Motivo

A conta SERVIÇO LOCAL é a conta de serviço do Serviço de Gerenciamento da Web do IIS(também conhecido como WMSvc). Esse problema ocorre porque a conta LOCAL SERVICE não tem acesso de leitura na iisWasKey chave localizada na %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys pasta.

Aqui está o nome do arquivo da iisWasKey chave:
76944fb33636aeddb9590521c2e8815a_GUID

Resolução

Para resolver este problema, execute as seguintes etapas:

  1. Localize a %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys pasta.
  2. Clique com o botão direito do mouse no arquivo 76944fb33636aeddb9590521c2e8815a_GUID e selecione Propriedades.
  3. Selecione a guia Segurança e selecione Editar. Se você for perguntado se deseja continuar a operação, selecione Continuar. Em seguida, a lista de nomes de grupo e nomes de usuário que têm acesso a esse arquivo de chave aparece na caixa de diálogo Permissões .
  4. Selecione Adicionar. Em seguida, a caixa de diálogo Selecionar Usuários, Computadores, Contas de Serviço ou Grupos é exibida.
  5. Digite SERVIÇO LOCAL e selecione Verificar Nomes.
  6. Selecione OK.
  7. Na lista Grupo ou nomes de usuário , selecione SERVIÇO LOCAL. Verifique se a caixa Ler marcar está marcada na lista Permissões para SERVIÇO LOCAL.
  8. Selecione OK.

Mais informações

Esse problema é corrigido no Windows Server 2008 Service Pack 2.