Um valor inválido para o tempo decorrido aparece quando você usa um driver WDM em um computador que esteja executando o Windows Vista ou Windows Server 2008

Traduções deste artigo Traduções deste artigo
ID do artigo: 977926 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • Um driver WDM (Windows Driver Model) é usado em um computador que esteja executando o Windows Server 2008 ou Windows Vista. O driver fornece um contador de desempenho para relatar um tempo decorrido.
  • O driver calcula o tempo decorrido consultando os dados retornados do provedor WDM.
Nesse cenário, o contador retorna dados inválidos ao usar o Monitor de desempenho para coletar os dados desse contador.

Por exemplo, o valor esperado é um número. No entanto, o valor retornado é exibido como o valor "---".

Causa

O provedor WDM fornece dados incorretos para o campo Frequency_PerfTime e o campo Timestamp_PerfTime. Esse comportamento faz o driver calcular um valor inválido para o tempo decorrido.

Resolução

Informações sobre hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem o problema descrito neste artigo. Este hotfix pode ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo do Knowledge Base. Se esta seção não exibida, contate o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: Se ocorrem problemas adicionais ou se for necessária qualquer solução de problemas, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa dos números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Observação: O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque não há um hotfix disponível disponível para esse idioma.

Pré-requisitos

Para aplicar esse hotfix, seu computador deve estar executando o Windows Vista Service Pack 2 (SP2) ou Windows Server 2008 Service Pack 2 (SP2).

Para obter mais informações sobre como obter o service pack do Windows Vista, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
935791Como obter o service pack mais recente do Windows Vista
Para obter mais informações sobre como obter um Windows Server 2008 service pack, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
968849Como obter o service pack mais recente para o Windows Server 2008

Requisito de reinicialização

Não é necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui um hotfix lançado anteriormente.

Instruções de instalação

Informações do arquivo

A versão em inglês (Estados Unidos) deste hotfix instala arquivos com os atributos listados nas tabelas a seguir. As datas e horários para esses arquivos estão listados no horário de universal coordenado (UTC). As datas e os horários desses arquivos no computador local são exibidos no seu horário local junto com a diferença do horário de verão (DST) atual. Além disso, as datas e os horários pode ser alteradas quando você executa certas operações nos arquivos.

Observações das informações sobre o arquivo do Windows Vista e Windows Server 2008


Importante Os hotfixes do Windows Vista e os hotfixes do Windows Server 2008 estão incluídos em pacotes do mesmos. No entanto, apenas "Windows Vista" é listado na página solicitação Hotfix. Para solicitar o pacote de hotfix que se aplica a um ou ambos esses sistemas operacionais, selecione o hotfix listado em "Windows Vista" na página. Sempre consulte a seção "Aplica-se A" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.
  • Os arquivos que se aplicam a um produto específico, SR_Level (RTM, SPn) e ramificação do serviço (LDR, GDR) podem ser identificados ao examinar os números da versão do arquivo conforme mostrado na tabela seguinte.
    Recolher esta tabelaExpandir esta tabela
    VersãoProdutoSR_LevelRamificação do serviço
    6.0.600 2. 22xxxWindows Vista e Windows Server 2008SP2LDR
  • Service Pack 1 está integrado na versão de lançamento do Windows Server 2008. Portanto, os arquivos da etapa RTM se aplicam somente ao Windows Vista. OS arquivos da etapa RTM tem um número de versão 6.0.0000. xxxxxx número da versão.
  • Os arquivos MANIFEST (.manifest) e os arquivos MUM (.mum) para cada ambiente instalados são listed separately na seção "Informações para o Windows Server 2008 e Windows Vista de arquivo adicionais". MUM e MANIFEST arquivos e os arquivos do catálogo (.cat) de segurança associadas, são extremamente importantes para manter o estado do componente atualizado. Os arquivos do catálogo de segurança, para o qual os atributos não estiverem listados, são assinados com uma assinatura digital da Microsoft.
Para todas as versões com base em 86 do Windows Server 2008 e do Windows Vista x

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Wmiprov.dll6.0.6002.22276152,57626-Nov-200914: 06x 86
Para todas as versões com base em 64 do Windows Server 2008 e do Windows Vista x

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Wmiprov.dll6.0.6002.22276228,35226-Nov-200912: 02x 64
Para todas as versões com base em IA-64 do Windows Server 2008 com suporte

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Wmiprov.dll6.0.6002.22276481,79226-Nov-200912: 02IA-64

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre o WDM (Windows Driver Model), visite o seguinte site da Microsoft:
http://www.microsoft.com/whdc/archive/wdm.mspx
Para obter mais informações sobre a terminologia da atualização, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão usada para descrever as atualizações de software

Informações de arquivo adicionais

Informações de arquivo adicionais para o Windows Vista e Windows Server 2008

Arquivos adicionais para todas as versões com base em 86 do Windows Vista e do Windows Server 2008 x

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
X86_62be60a76ff0c252076832eb3349543d_31bf3856ad364e35_6.0.6002.22276_none_7715f2e9609bcd57.manifestNão aplicável70427-Nov-200911: 33Não aplicável
X86_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_7c5d34987886f6ab.manifestNão aplicável9,40427-Nov-200900: 01Não aplicável
Arquivos adicionais para todas as versões com base em 64 do Windows Vista e do Windows Server 2008 x

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Amd64_e2fab5784caba3b222b162e91fd38422_31bf3856ad364e35_6.0.6002.22276_none_7d90f138ae76b433.manifestNão aplicável70827-Nov-200911: 33Não aplicável
Amd64_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_d87bd01c30e467e1.manifestNão aplicável9.68826-Nov-200913: 30Não aplicável
Arquivos adicionais para todas as versões com base em IA-64 do Windows Server 2008 compatíveis com o

Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Ia64_d0050597da94fd1dfc4d745843fcdbb4_31bf3856ad364e35_6.0.6002.22276_none_c09a873a9ec7819c.manifestNão aplicável70627-Nov-200911: 33Não aplicável
Ia64_microsoft-windows-wmi-wdm-provider_31bf3856ad364e35_6.0.6002.22276_none_7c5ed88e7884ffa7.manifestNão aplicável9,67427-Nov-200910: 34Não aplicável

Propriedades

ID do artigo: 977926 - Última revisão: segunda-feira, 8 de fevereiro de 2010 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Windows Server 2008 Service Pack 2 nas seguintes plataformas
    • Windows Server 2008 Datacenter without Hyper-V
    • Windows Server 2008 Enterprise without Hyper-V
    • Windows Server 2008 for Itanium-Based Systems
    • Windows Server 2008 Standard without Hyper-V
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Web Server 2008
    • Windows Server 2008 Standard
    • Windows HPC Server 2008
  • Windows Vista Service Pack 2 nas seguintes plataformas
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Starter
    • Windows Vista Ultimate
Palavras-chave: 
kbmt kbqfe kbhotfixserver kbsurveynew kbautohotfix kbexpertiseadvanced kbbug kbfix KB977926 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 977926

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com