No se pueden administrar directorios virtuales de OWA, Exchange ActiveSync, ECP o OAB desde Consola de administración de Exchange en Exchange Server 2010

Número de KB original: 977966

Síntomas

Imagine la siguiente situación:

  • Está trabajando en un entorno nativo de Microsoft Exchange Server 2010 o en un entorno mixto de Exchange Server 2010 y Exchange Server 2007.
  • No puede administrar los siguientes directorios virtuales desde Consola de administración de Exchange (EMC):
    • Outlook Web App (OWA)
    • Exchange ActiveSync
    • Exchange Panel de control (ECP)
    • Libreta de direcciones sin conexión (OAB)
  • Al expandir la lista de configuración del servidor en EMC, verá una lista de servidores de servidor de acceso de cliente (CAS) en el lado derecho.
  • Al intentar seleccionar un servidor CAS de Exchange Server 2007 o un servidor CAS de Exchange Server 2010, detecta que no es accesible.

En este escenario, recibirá un mensaje de error como este:

La tarea no pudo conectarse a IIS en el nombre> del servidor CAS del servidor<. Asegúrese de que el servidor existe y se puede acceder a él desde este equipo. El servidor RPC no está disponible. Estaba ejecutando el comando "Get-OwaVirtualDirectory".

Causa

Cuando intenta seleccionar el CAS en EMC, el servidor de Exchange Server 2010 ejecuta un Get-OwaVirtualDirectory comando en el fondo Exchange Server. Sin embargo, no puede administrar ninguno de los directorios virtuales de los servidores CAS de Exchange Server si el comando no puede acceder a ninguno de los servidores CAS de Exchange Server.

Solución alternativa

Para solucionar este problema, espere hasta que el Exchange Server servidor CAS que no responde vuelva a estar en línea o use el Shell de administración de Exchange para administrar explícitamente los directorios virtuales.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se aplica a".