Не удается управлять виртуальными каталогами OWA, Exchange ActiveSync, ECP или OAB из консоли управления Exchange в Exchange Server 2010 г.

Исходный номер базы знаний: 977966

Симптомы

Рассмотрим следующий сценарий.

  • Вы работаете в собственной среде Microsoft Exchange Server 2010 или в смешанной среде Exchange Server 2010 и Exchange Server 2007.
  • Вы не можете управлять следующими виртуальными каталогами с помощью консоли управления Exchange (EMC):
    • Outlook Web App (OWA)
    • Exchange ActiveSync
    • Exchange панель управления (ECP)
    • автономная адресная книга (OAB);
  • При развертывании списка конфигурации сервера в консоли управления exchange вы увидите список серверов клиентского доступа (CAS) в правой части.
  • При попытке выбрать сервер CAS Exchange Server 2007 или сервер CAS Exchange Server 2010, вы обнаружите, что он недоступен.

В этом сценарии появляется сообщение об ошибке, подобное следующему:

Задаче не удалось подключиться к СЛУЖБАм IIS по имени> сервера CAS сервера<. Убедитесь, что сервер существует и доступен с этого компьютера. Сервер RPC недоступен. Она выполняла команду Get-OwaVirtualDirectory.

Причина

При попытке выбрать cas-сервер в EMC сервер Exchange Server 2010 выполняет Get-OwaVirtualDirectory команду в Exchange Server фоновом режиме. Однако вы не можете управлять виртуальными каталогами для серверов CAS Exchange Server, если команда не может получить доступ к одному из серверов CAS Exchange Server.

Обходной путь

Чтобы обойти эту проблему, подождите, пока сервер Exchange Server CAS, который не отвечает, вернется в очередь, или используйте командную консоль Exchange для явного управления виртуальными каталогами.

Состояние

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Применимо к».