Article ID: 978305 - View products that this article applies to.
הרחב הכל | כווץ הכל

On This Page

מאפייני הבעיה

Fאשר אתה מנסה להפעיל את Windows Vista, Windows Server 2008, Windows 7 או Windows Server 2008 R2, ייתכן שתקבל אחת מהודעות השגיאה הבאות:
Code: 0xC004C003

תיאור: שרת ההפעלה קבע כי מפתח המוצר שצוין נחסם.
Code: 0xC004E002

תיאור: שירות רישוי התוכנה דיווח שמאגר הרישיונות מכיל נתונים לא עקביים.

סיבה

בעיה זו מתרחשת מכיוון שהוגדרו הרשאות שגויות לקובץ Tokens.dat או שקובץ זה פגום.

פתרון הבעיה

כדי לפתור בעיה זו, נסה את השיטות הבאות לפי הסדר.

שיטה 1: הגדר את ההרשאות המתאימות לקובץ Tokens.dat

  1. לחץ על התחל ולאחר מכן הקלד cmd בתיבה חיפוש.
  2. לחץ באמצעות לחצן העכבר הימני על cmd ולאחר מכן לחץ על הפעלה כמנהל.
  3. בשורת הפקודה, הקלד את הפקודה הבאה בהתאם למערכת ההפעלה ולאחר מכן הקש על ENTER:
    עבור Windows Vista או Windows Server 2008:
    icacls %windir%\serviceprofiles\networkservice\appdata\roaming\microsoft\softwarelicensing /grant "BUILTIN\Administrators:(OI)(CI)(F)" "NT AUTHORITY\SYSTEM:(OI)(CI)(F)" "NT Service\slsvc:(OI)(CI)(R,W,D)"


    עבור Windows 7 או Windows Server 2008 R2:
    icacls %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform /grant "BUILTIN\Administrators:(OI)(CI)(F)" "NT AUTHORITY\SYSTEM:(OI)(CI)(F)" "NT Service\sppsvc:(OI)(CI)(R,W,D)" "NETWORK SERVICE:(OI)(CI)(F)"
  4. סגור את חלון שורת הפקודה.
הערות
  • עליך להקליד פקודה זו משורת פקודה עם הרשאות מלאות.
  • ההרשאות הבאות לקובץ Tokens.dat צריכות לעבור בירושה מהתיקייה המכילה:
    • NT AUTHORITY\SYSTEM: (I)(F)
    • BUILTIN\Administrators: (I)(F)
    • NT SERVICE:\slsvc: (I)(R,W,D)

שיטה 2: שנה את השם של קובץ Tokens.dat

כדי שאנו נשנה עבורך את השם של קובץ Tokens.dat, עבור לסעיף "תקנו עבורי". אם אתה מעדיף לתקן בעיה זו בעצמך, עבור לסעיף "אני מעדיף לתקן בעצמי".

תקנו עבורי



כדי לתקן בעיה זו באופן אוטומטי, לחץ על הלחצן או על הקישור תקן. אז לחץ על הפעלה בתיבת הדו-שיח הורדת קובץ ופעל בהתאם לשלבים באשף התיקון.


תקן בעיה זו
Microsoft Fix it 50718


הערות
  • ייתכן שאשף זה מוצג באנגלית בלבד. עם זאת, התיקון האוטומטי פועל גם עבור גרסאות של Windows בשפות אחרות.
  • אם אינך נמצא מול המחשב שבו אירעה הבעיה, שמור את הפתרון בכונן הבזק או בתקליטור ולאחר מכן הפעל אותו במחשב שבו אירעה הבעיה.
  • אל תפעיל את התיקון האוטומטי במחשב שבו בעיה זו אינה קיימת.
  • התיקון האוטומטי לא ישנה את שם קובץ Tokens.dat עבורך אם tokens.bar כבר קיים.

כעת עבור אל הסעיף "האם הבעיה נפתרה?".



אני מעדיף לתקן בעצמי

  1. לחץ על התחל ולאחר מכן הקלד cmd בתיבה חיפוש.
  2. לחץ באמצעות לחצן העכבר הימני על cmd ולאחר מכן לחץ על הפעלה כמנהל.
  3. בשורת הפקודה, הקלד את הפקודה הבאה ולאחר מכן הקש על ENTER.

    עבור Windows Vista או עבור Windows Server 2008
    net stop slsvc

    עבור Windows 7 או עבור Windows Server 2008 R2
    net stop sppsvc
    שים לב: אם תקבל הודעה עם שאלה האם ברצונך להמשיך בפעולה זו, הקלד Y ואז הקש על ENTER.
  4. הקלד את הפקודה הבאה ואז הקש על ENTER.

    עבור Windows Vista או עבור Windows Server 2008
    cd %windir%\serviceprofiles\networkservice\appdata\roaming\microsoft\softwarelicensing
    עבור Windows 7 או עבור Windows Server 2008 R2
    cd %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform
  5. הקלד את הפקודה הבאה ולאחר מכן הקש על ENTER:
    ren tokens.dat tokens.bar
  6. הקלד את הפקודה הבאה ולאחר מכן הקש ENTER:

    עבור Windows Vista או Windows Server 2008
    net start slsvc

    עבור Windows 7 או Windows Server 2008 R2
    net start sppsvc
  7. הקלד את הפקודה הבאה ולאחר מכן הקש ENTER:
    cd %windir% \System32
  8. הקלד את הפקודה הבאה ולאחר מכן הקש ENTER:
    cscript slmgr.vbs -rilc
  9. הפעל מחדש את המחשב פעמיים כדי להחיל את השינויים.

האם הבעיה נפתרה?

  • בדוק אם הבעיה נפתרה. אם הבעיה נפתרה, סעיף זה הושלם. אם הבעיה לא נפתרה, באפשרותך לפנות לתמיכה.
  • אנו מעריכים את המשוב שלך. כדי לספק משוב או כדי לדווח על בעיות כלשהן בפתרון זה, השאר הערה בבלוג "תקנו עבורי" או שלח לנו דואר אלקטרוני.

הערה זהו מאמר "פרסום מהיר" שנוצר ישירות מתוך ארגון התמיכה של Microsoft. המידע הכלול במסמך זה מסופק כפי שהוא בתגובה לבעיות שצצות. לאור הקצב המהיר של פרסום החומרים, ייתכן שהחומרים יכללו שגיאות הקלדה ואנו עשויים לתקן אותם בכל עת, ללא הודעה מוקדמת. למידע על שיקולים אחרים, עיין בתנאי השימוש.

מאפיינים

Article ID: 978305 - Last Review: יום שני 01 אוקטובר 2012 - Revision: 2.0
המידע במאמר זה חל על:
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Home Basic 64-bit edition
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
מילות מפתח 
kbsurveynew kbexpertiseinter kbtshoot kbfixme kbmsifixme KB978305

ספק משוב

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com