Error message when you install the Office Communications Server 2007 R2 database update package that is dated July, 2009: "Error 1722"

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Article ID: 978377 - View products that this article applies to.
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SYMPTOMS

When you try to install the Microsoft Office Communications Server 2007 R2 database update package that is dated July, 2009, the installation fails. Additionally, you receive the following error message:

Product: Microsoft Office Communications Server 2007 R2 (KB969834) -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action CA_DBUpdateSE, location: Drive:\Program Files\Common Files\Microsoft Office Communications Server 2007 R2\DBSetupQfe\, command: Drive:\Windows\SysWOW64\cscript.exe dbqfeupdate.wsf /Role:SE


The following error message is also logged in the QFE_DBSetup log:

Updating SE server database stored procedures. This will take a while ...
cscript dbsetup.wsf /SqlServer:(local)\rtc /Role:se /Verbose
Microsoft (R) Windows Script Host Version 5.7
Copyright (C) Microsoft Corporation. All rights reserved.

Connecting to SQL Server on (local)\rtc
SqlMajorVersion : 9
SqlMinorVersion : 00
SqlBuildNo : 3042
SQL validation: Reconfigure encountered no errors, and SQL version is acceptable: 9.00.3042.00
Opened database rtc
Db schema version is 37
Db sproc version is 70
Db qfe version is 2
(Major upgrade of database required.)

This database contains a newer Qfe version and hence cannot be re-used. It must be dropped and a new one created if necessary.
To preserve data, you must use this product's backup/export restore/import solution. Examine the product documentation for instructions.


Additionally, the User Services component fails on the Office Communications Server 2007 R2 font-end server or on the Office Communications Server 2007 R2 Standard Edition server that connect to the back-end database. When this behavior occurs, you receive the following error message:

Login failed for user 'Contoso\RTCService'. [CLIENT: <local machine>]
------------------------

Failed to connect to back-end database. Office Communications Server will continuously attempt to reconnect to the back-end. While this condition persists, incoming messages will receive error responses.

Back-end Server: (local)\rtc Database: rtc Connection string of:
driver={SQL Native Client};Trusted_Connection=yes;AutoTranslate=no;server=(local)\rtc;database=rtc;network=dbmslpcn;
Cause: Possible issues with back-end database.
Resolution:
Ensure the back-end is functioning correctly.
------------------------

Failed processing conference status requests. This error might delay the freeing up of PSTN meeting ids in conference directories homed on this pool.

Error code: 0x800407D0
Cause: Possible issues with back-end or Office Communications Server health.
Resolution:
Ensure the Office Communications Server service is healthy.

CAUSE

This issue occurs when you install the Office Communications Server 2007 R2 database update package that is dated January, 2010, before you install the Office Communications Server 2007 R2 database update package that is dated July, 2009.

WORKAROUND

When this issue occurs, the level of the Restrict Access setting for the RTC database and for the RTCDyn database is set to RESTRICTED_USER. When the RESTRICTED_USER level is set, database connections fail. To work around this issue, follow these steps:
  • Connect to Microsoft SQL Server.
  • Close all connections to RTC databases and to RTCDyn databases.
  • Set the level of the Restrict Access setting for RTC databases and for RTCDyn databases to MULTI_USER.
  • Restart the RTCSRV service process on the front-end server.

Properties

Article ID: 978377 - Last Review: January 15, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Office Communications Server 2007 R2 Enterprise Edition
  • Microsoft Office Communications Server 2007 R2 Standard Edition
Keywords: 
kbexpertiseinter kbtshoot kbsurveynew kbprb KB978377

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