FIX: Messages are not delivered to the destination after you change the host for a send handler in BizTalk Server

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Article ID: 978404 - View products that this article applies to.
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SYMPTOMS

On a computer that is running BizTalk Server 2006 or BizTalk Server 2009, messages are put into an incorrect BizTalk host queue for processing. Therefore, BizTalk Server does not process these messages. Additionally, no output message is delivered to the destination that is specified in the send port.

Typically, this issue occurs when the following conditions are true:
  • You use some ordered send ports that use the same adapter.
  • You change the host of one send handler to another host.
For example, consider the following scenario:
  • You have two BizTalk Server hosts, HostA and HostB.
  • You create a file adapter send handler for each host.
  • You run two applications in BizTalk Server. These applications are AppA and AppB.
  • AppA contains an ordered send port that uses the file adapter. The send port uses the HostA send handler.
  • AppB contains an ordered send port that uses the file adapter. The send port uses the HostB send handler.
  • You create a new BizTalk Server host, NewHostB.
  • You change the host of the HostB send handler to NewHostB. Then, you restart NewHostB and AppB so that the change takes effect.
In this scenario, messages that belong to the send port in AppA are routed to NewHostB. Therefore, the messages are not delivered to the destination folder that is specified in the send port, and the messages seem to be lost.

CAUSE

This issue occurs because of an error in the stored procedure that retrieves subscriptions for hosts in the BizTalk Management database.

RESOLUTION

Hotfix information

For BizTalk Server 2006 and BizTalk Server 2009

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 or BizTalk Server 2009 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported versions of BizTalk Server 2006
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Admin_server_logic.sqlNot applicable72,80903-Feb-201021:59Not applicable
For all supported versions of BizTalk Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Admin_server_logic.sqlNot applicable72,83226-Feb-201017:41Not applicable

For BizTalk Server 2006 R2 SP1


The hotfix that resolves this problem is included in cumulative update package 1 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
982061 Cumulative update package 1 for BizTalk Server 2006 R2 Service Pack 1

For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563 List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about ordered message delivery, visit the following Microsoft Developer Network (MSDN) Web site:
Ordered delivery of messages
For more information about how to create and delete adapter handlers in the BizTalk Server Administration console, visit the following MSDN Web site:
How to create and delete adapter handlers
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk Server hot fixes

Properties

Article ID: 978404 - Last Review: September 3, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2006 Developer Edition
  • Microsoft BizTalk Server 2006 Enterprise Edition
  • Microsoft BizTalk Server 2006 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbbtsadmin kbbiztalk2009presp1fix kbbiztalk2006presp1fix kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB978404

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