Windows 7-Aktualisierung fehlschlägt und dann die Ergebnisse in einer Schleife Neustart mit der Meldung "die Aktualisierung war nicht erfolgreich"

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 978421 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Beim Versuch, einen Computer von Windows Vista, Windows 7 zu aktualisieren, die Aktualisierung fehlschlägt, und Sie erhalten die folgende Fehlermeldung angezeigt:
Die Aktualisierung war nicht erfolgreich.

Ihrer vorherige Windows-Version wird wiederhergestellt.

Kein Neustart des Computers während dieser Zeit.
Jedoch beim Neustart des Computers, es wird nicht Rollback auf Windows Vista. Beim Aktualisierungsvorgang wird erneut gestartet und dann mit derselben Fehlermeldung fehlschlägt. Dieses Problem wiederholt auftritt, und der Aktualisierungsvorgang steckt in einer Schleife Neustart.

Ursache

Dieses Problem kann auftreten, weil der Computer eine oder mehrere Shellordner (Dokumente, Bilder, Musik usw. enthält), die zu Positionen innerhalb Ihrer eigenen Pfade umgeleitet werden.

Lösung

Neustart die endlose zu beheben, müssen Sie Zugriff auf die Wiederherstellung der Windows-Umgebung, suchen die doppelten Ordner, und verschieben Sie die doppelten Ordner an einen temporären Speicherort. Nachdem das System erfolgreich nach Windows Vista Rollback, müssen Sie zusätzliche Schritte Unternehmen, um das Problem zu vermeiden, vor der Aktualisierung zu Windows 7.

Schritt 1: Zugriff auf die Windows-Wiederherstellungsumgebung

Auf der Windows-Wiederherstellungsumgebung zugreifen möchten, gehen Sie folgendermaßen vor:
  1. Legen Sie die Windows 7-Installationsmedium in das DVD-Laufwerk und starten den Computer.
  2. Drücken Sie eine Taste, wenn Sie aufgefordert werden, zum Starten von der CD.
  3. In derInstallieren von WindowsFenster, wählen Sie eine Sprache, eine Zeit, eine Währung, eine Tastatur-Eingabemethode oder andere Eingabemethode, und klicken Sie dann aufNächste.
  4. In derInstallieren von WindowsKlicken Sie im FensterReparatur des Computers.
    Hinweis:Klicken Sie nicht auf dieJetzt installierenSchaltfläche.
  5. In derSystem Recovery OptionsFenster, klicken Sie auf die Version des Betriebssystems Windows 7 die zu reparieren, notieren Sie sich den Laufwerkbuchstaben, der dem Betriebssystem zugewiesen wird (z. B. C:), und klicken Sie dann aufNächste.
  6. In derSystem Recovery OptionsKlicken Sie im FensterEingabeaufforderung.
  7. Eine Eingabeaufforderung wird geöffnet.

In Schritt 2: Suchen nach doppelten Ordner

Doppelten Ordner gefunden haben, gehen in die Windows-Wiederherstellungsumgebung:
  1. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie dann die EINGABETASTE:
    CD/ d c:\Benutzer

    Hinweis:Ersetzen Sie "C:" mit dem System-Laufwerk Buchstaben.
  2. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie dann die EINGABETASTE:
    Dir/s | suchen "ist zu lang" |mehr
    Bild minimierenBild vergrößern
    Beispiel
  3. Wenn dieser Befehl Daten bereitstellt, beachten Sie die Ordnernamen, die angezeigt werden, und gehen Sie zu Schritt 3.
  4. Wenn "? Weitere ?" wird am unteren Rand der Seite angezeigt wird, drücken Sie die LEERTASTE, um zum nächsten Bildschirm fortzufahren. Beachten Sie die neuen Ordnernamen ein, die angezeigt werden. Wiederholen Sie diesen Vorgang, bis "? Weitere ?" nicht mehr am unteren Rand des Bildschirms angezeigt wird, und gehen Sie zu Schritt 3.
  5. Wenn dieser Befehl keine Daten zur Verfügung stellt, dieses Problem wird nicht durch die Ordnerumleitung Shell verursacht und die restlichen Schritte in diesem Artikel nicht befolgt werden sollten.

Schritt 3: Verschieben Sie die doppelten Ordner an einem temporären Speicherort

Diese doppelten Ordner an einem temporären Speicherort verschieben möchten, gehen Sie folgendermaßen vor:
  1. Geben Sie an der Eingabeaufforderung den folgenden Befehl ein, und drücken Sie dann die EINGABETASTE:
    Verschieben[Identified_folder][Destination_location]
    Geben Sie beispielsweise Folgendes:
    C:\Users\Bob\Documents\Documents C:\Temp zu verschieben.
  2. Mithilfe des Befehls "verschieben" die duplizierte Ordner verschieben, die identifiziert werden.
  3. Verwendung derCD c:\BenutzerundDir/s | suchen "ist zu lang" |mehrBefehle, um sicherzustellen, dass keine anderen doppelten Ordner.
  4. An der Eingabeaufforderung TypBeenden, und drücken Sie dann die EINGABETASTE.
  5. Neustart des Computers. Die Meldung "die Aktualisierung war nicht erfolgreich" wird erneut angezeigt. Aber dieses Mal die Meldung auf dem Bildschirm mehr bleibt und eine Statusanzeige aktiv. Nach einiger Zeit müssen der Computer neu gestartet und das System auf Windows Vista zurücksetzen.

Schritt 4: bestätigen, dass die Shellordner nicht umgeleitet werden

  1. In Windows Vista, öffnen Sie den Ordner "C:\Users" und öffnen Sie Ihr persönlicher Ordner oder der Benutzerordner mit den Problemen.
  2. Bestätigen, dass die Shellordner nicht an andere Speicherorte umgeleitet werden.

    Bestätigen ein Shell-Ordner nicht umgeleitet, gehen Sie folgendermaßen vor:
    1. Klicken Sie auf einen Shell-Ordner, klicken Sie aufEigenschaften, und klicken Sie dann aufSpeicherort.
    2. Bestätigen Sie, dass der Pfad korrekt dargestellt, den Pfad zu diesem Ordner angezeigt.

      Beispielsweise müsste der Ordner "C:\Users\Bob\Documents" den Pfad "C:\Users\Bob\Documents" angezeigt wird, auf dieSpeicherortRegisterkarte.
    3. Wenn der Pfad nicht korrekt ist, klicken Sie aufStandard wiederherstellen.
  3. Starten Sie den Computer neu, und wiederholen Sie dann den Aktualisierungsvorgang.

Weitere Informationen

Shell-Ordner in Windows Vista

Windows Vista umfasst standardmäßig die folgenden Shellordner:
  • C:\Users\Benutzername\Contacts
  • C:\Users\Benutzername\Desktop
  • C:\Users\Benutzername\Dokumente
  • C:\Users\Benutzername\Downloads
  • C:\Users\Benutzername\Favoriten
  • C:\Users\Benutzername\Links
  • C:\Users\Benutzername\Musik
  • C:\Users\Benutzername\Bilder
  • C:\Users\Benutzername\Saved Spiele
  • C:\Users\Benutzername\Searches
  • C:\Users\Benutzername\Videos

Dinge versuchen

Eigenschaften

Artikel-ID: 978421 - Geändert am: Mittwoch, 4. August 2010 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows 7 Enterprise
Keywords: 
kbgraphxlink kbsurveynew kbprb kbmt KB978421 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 978421
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com