Article ID: 97869 - Last Review: October 31, 2006 - Revision: 1.1 Cannot Delete Stuck Print Jobs when Using HPREDIRThis article was previously published under Q97869 SUMMARY
The Hewlett-Packard (HP) Network Printer system, which redirects OS/2
print queues to printers directly attached to the network, does not
allow you to delete a stuck print job from a queue and let the other
queued jobs print. Instead, it requires you to reboot the server to
delete stuck jobs, which may not be possible in a production environment.
Below is a workaround to this restriction.
Note: The new PMSPL.DLL comes with the OS/2 1.3 for LAN Manager 2.1a and 2.2. If you are not upgrading, you can copy the new PMSPL.DLL to your OS/2 server and replace the old one. If you are using HPFS386, copy the .DLL by shutting down your server and rebooting with HPFS386 Recovery Disk 1. If you are not using HPFS386, boot from the Microsoft OS/2 1.3 floppy disk. When you have done this, copy the new PMSPL.DLL onto C:\OS2\DLL. SYMPTOMS
When the OS/2 print spooler attempts to delete a job it tries to
close both the spool file and the device that it is printing to. It
cannot do this and you are unable to delete the job.
CAUSE
The spooler apparently has trouble interacting with the HP print
device HPREDIR. If you shut down HPREDIR, the print device is
considered closed and you can then cancel the stuck print job.
WORKAROUND
If HPREDIR is running as a detached process, HP has provided a back
door that lets you shut it down without taking down the server.
Follow this procedure:
DETACH HPREDIR
After a few seconds your printers should be functioning properly
again.
| Article Translations
|

Back to the top
