Niektóre ustawienia Edytora Visual Basic włączone we wcześniejszej wersji aplikacji pakietu Office są wyłączone w pakiecie Office 2010

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 978753 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Rozwiń wszystko | Zwiń wszystko

Symptomy

Przykładowy scenariusz: Użytkownik tworzy plik w aplikacji pakietu Microsoft Office 2007 lub we wcześniejszej wersji aplikacji. Niektóre ustawienia Edytora Visual Basic firmy Microsoft są włączone w aplikacji, na przykład opcja Require Variable Declaration (Wymagaj deklaracji zmiennej) i opcja Compile on Demand (Kompiluj na żądanie). Po otwarciu tego samego pliku w aplikacji pakietu Microsoft Office 2010 okazuje się, że te ustawienia są wyłączone.

Przyczyna

Ten problem występuje, ponieważ język Visual Basic for Applications (VBA) został w pakiecie Microsoft Office 2010 uaktualniony do wersji 7.0. W związku z tym wpisy rejestru odpowiadające ustawieniom Edytora Visual Basic znajdują się w innym podkluczu. W pakiecie Office 2010 wpisy rejestru znajdują się w następującym podkluczu:
HKEY_CURRENT_USER\Software\Microsoft\VBA\7.0\Common
We wcześniejszych wersjach pakietu Office wpisy rejestru znajdują się w następującym podkluczu:
HKEY_CURRENT_USER\Software\Microsoft\VBA\6.0\Common


Aby automatycznie rozwiązać ten problem, przejdź do sekcji Automatyczne rozwiązywanie problemu. Aby samodzielnie obejść ten problem, przejdź do sekcji Samodzielne rozwiązywanie problemu.

Automatyczne rozwiązywanie problemu

Aby automatycznie rozwiązać ten problem, należy kliknąć łącze Rozwiąż ten problem. Następnie należy kliknąć przycisk Uruchom w oknie dialogowym Pobieranie pliku i wykonać kroki kreatora.

Rozwiąż ten problem
Poprawka automatyczna firmy Microsoft 50347


Uwaga Ten kreator może być dostępny tylko w języku angielskim. Jednak ta poprawka automatyczna działa również w innych wersjach językowych systemu Windows.

Uwaga Jeśli używany komputer nie jest tym, którego dotyczy problem, można zapisać tę poprawkę automatyczną na dysku flash lub dysku CD i uruchomić ją na odpowiednim komputerze.

Samodzielne rozwiązywanie problemu

Aby samodzielnie obejść ten problem, należy włączyć ustawienia ręcznie. W tym celu należy skorzystać z jednej z następujących metod:

Metoda 1

  1. Uruchom aplikację pakietu Office 2010.
  2. Na karcie Deweloper kliknij pozycję Visual Basic.

    Uwaga W przypadku uruchomienia programu Microsoft Access 2010 należy kliknąć pozycję Visual Basic na karcie Narzędzia bazy danych.
  3. W menu Narzędzia kliknij polecenie Opcje.
  4. W oknie dialogowym Opcje zaznacz dowolną opcję, którą chcesz włączyć, a następnie kliknij przycisk OK.

Metoda 2

Ważne W tej sekcji, metodzie lub w tym zadaniu podano informacje dotyczące modyfikowania rejestru. Niepoprawne zmodyfikowanie rejestru może jednak być przyczyną poważnych problemów. Dlatego należy uważnie wykonywać podane czynności. Aby zapewnić dodatkową ochronę, przed zmodyfikowaniem rejestru należy wykonać jego kopię zapasową. Dzięki temu będzie można przywrócić rejestr w przypadku wystąpienia problemu. Aby uzyskać więcej informacji dotyczących wykonywania kopii zapasowej i przywracania rejestru, kliknij następujący numer artykułu w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
322756 Jak wykonać kopię zapasową rejestru i przywrócić go w systemie Windows
  1. Kliknij przycisk Start, kliknij polecenie Uruchom, wpisz ciąg regedit, a następnie kliknij przycisk OK.
  2. Odszukaj następujący podklucz rejestru:
    HKEY_CURRENT_USER\Software\Microsoft\VBA\6.0\Common
  3. W menu Plik kliknij polecenie Eksportuj.
  4. W oknie dialogowym Eksportuj plik rejestru wskaż ścieżkę dla eksportowanego pliku i podaj jego nazwę.
  5. Upewnij się, że jest włączona opcja Wybrana gałąź, a następnie kliknij przycisk Zapisz.
  6. Otwórz wyeksportowany plik w Notatniku.
  7. Odszukaj następujący ciąg:
    [HKEY_CURRENT_USER\Software\Microsoft\VBA\6.0\Common]
    Następnie zamień ten ciąg na poniższy:
    [HKEY_CURRENT_USER\Software\Microsoft\VBA\7.0\Common]
  8. Zapisz, a następnie zamknij plik w Notatniku.
  9. W Edytorze rejestru kliknij polecenie Importuj w menu Plik.
  10. W oknie dialogowym Importuj plik rejestru zaznacz zapisany przed chwilą plik, a następnie kliknij przycisk Otwórz.
  11. Kliknij przycisk OK.

Stan

Firma Microsoft potwierdziła, że jest to problem występujący w produktach firmy Microsoft wymienionych w sekcji „Informacje zawarte w tym artykule dotyczą”.

Więcej informacji

Aby wyświetlić kartę Deweloper na wstążce w pewnych aplikacjach pakietu Microsoft Office 2010, wykonaj następujące czynności:
  1. Na karcie Plik kliknij pozycję Opcje.
  2. Na karcie Dostosowywanie Wstążki zaznacz kliknięciem pole wyboru Deweloper w sekcji Dostosuj Wstążkę, a następnie kliknij przycisk OK.

Właściwości

Numer ID artykułu: 978753 - Ostatnia weryfikacja: 13 września 2011 - Weryfikacja: 2.0
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Access 2010
  • Microsoft Excel 2010
  • Microsoft PowerPoint 2010
  • Microsoft Word 2010
Słowa kluczowe: 
kbmsifixme kbfixme kbtshoot kbexpertiseadvanced kbsurveynew kbprb KB978753

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com