ボリューム シャドウ コピー サービス復元操作を実行するとエラー メッセージ:"0x80042409"

文書翻訳 文書翻訳
文書番号: 978773 - 対象製品
すべて展開する | すべて折りたたむ

現象

ボリューム シャドウ コピー サービス (VSS) のバックアップまたは VSS 復元操作を実行します。[バックアップまたは復元の操作中に、次のようなイベントがアプリケーション ログに書き込まれます。

イベント ID: 12289

ボリューム シャドウ コピー サービス エラー: 予期しないエラーの以前のライターのセッション状態を削除します。.hr 0x80042409、= ライター状態は 1 つまたは複数の作成者が使用できるではありません。ライターが利用可能なバックアップの復元セッションの状態の数には制限に達しています可能性があります。

操作:イベントを preRestore します。

コンテキスト:
古いスナップショット セット: {41379de8-f7e7-4c76-bb47-7f080443e189}
古い操作: 1019年
古い状態: 5
古いエラー: 0x800423f4
古いは障害 hr 拡張: 0x1
古い拡張エラー メッセージ: 0
実行コンテキスト: ライター
ライター クラス Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
ライター名: マイクロソフト ハイパー V VSS
ライターライター インスタンス ID: {7eef8900-84b4-406e-a461-ce19e5e7ae7f}

原因

このエラーをバックアップまたは復元セッション状態、VSS ライターで正しくクリーンアップされないために発生します。VSS ライター インフラストラクチャ セッション状態オブジェクトの VSS ライターが所属バックアップと復元セッションごとに作成されます。使用されていないと一般的な状況では、ライターのセッション状態オブジェクト クリーンアップされます。通常セッション状態のクリーンアップには、次の状況で発生します。
  • バックアップ ・ アプリケーションを送信します。 BackupComplete 応答を送信して、ライターのステータスを確認します。 GatherWriterStatus.
  • バックアップ ・ アプリケーションを送信します。 PostRestore 応答を送信して、ライターのステータスを確認します。 GatherWriterStatus クエリです。
  • ライター、セッションの OnAbort イベントのコールバックを受け取る。バックアップ セッションは、バックアップ アプリケーション、ライターまたは、VSS インフラストラクチャによって明示的にでしたがとき、OnAbort イベントのコールバックが呼び出されます。
VSS ライター インフラストラクチャの残りのセッション状態の定期的なガベージ コレクションを実行します。Infrustructure、2 日間よりも古いバージョンです各セッション状態オブジェクトの以前のイベント ログに記録します。イベント ログは、不適切に動作するバックアップ アプリケーションを可能性があります、ライターで破棄されたセッションを識別するものです。一連の不完全なバックアップされたことを示す、またはリストア セッション複数のライターから連続でいくつかの類似したイベントを参照してくださいすることができます。この問題は、テスト環境で最も頻繁に発生します。

回避策

このエラーの断続的な発生を無視します。応答してでバックアップが開始されるか、復元操作のガベージ コレクション アクティビティ関連のイベントが記録されます。ただし、これらのエラー、アクティブなバックアップには関連していませんまたはセッションを復元します。エラーが一貫して再現可能である場合は、バックアップ アプリケーション ベンダーすべての VSS バックアップ セッション クリーンアップ ガイドラインに従っていることを確認します。

プロパティ

文書番号: 978773 - 最終更新日: 2013年7月10日 - リビジョン: 4.0
この資料は以下の製品について記述したものです。
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
キーワード:?
kbsurveynew kbexpertiseadvanced kbtshoot kbmt KB978773 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:978773
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com