볼륨 섀도 복사본 서비스는 복원 작업을 수행할 때 오류 메시지: "0x80042409"

기술 자료 번역 기술 자료 번역
기술 자료: 978773 - 이 문서가 적용되는 제품 보기.
모두 확대 | 모두 축소

현상

VSS (볼륨 섀도 복사본 서비스) 백업 또는 VSS 복원 작업을 수행합니다. 백업 또는 복원 작업 동안 응용 프로그램 로그에 다음과 유사한 이벤트가 기록됩니다.

이벤트 ID: 12289

볼륨 섀도 복사본 서비스 오류: 예기치 않은 오류가 있는 이전 기록기 세션 상태를 제거하는 중입니다. . hr = 0x80042409, 기록기 상태 하나 이상의 작성자가 사용할 수 없습니다. 작성자가 사용할 수 있는 백업 복원 세션 상태 수 제한에 도달했습니다 수도 있습니다.

이벤트 작업: PreRestore

CONTEXT:
이전 스냅숏 집합에: {41379de8-f7e7-4 c 76-bb47-7f080443e189}
이전 작업이: 1019
이전 상태: 5
이전 실패: 0x800423f4
이전 실패 hr 확장: 0x1
기존의 확장 오류 메시지: 0
실행 컨텍스트: 작성기
작성기 클래스 ID: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
Microsoft Hyper-V VSS 기록기가 이름:
작성기 작성기 인스턴스 ID: {7eef8900-84b4-406e-a461-ce19e5e7ae7f}

원인

VSS 기록기 사용하여 백업 또는 복원 세션 상태를 제대로 정리하지 않았기 때문에 이 오류가 발생합니다. VSS 기록기가 인프라 VSS 기록기를 참여하는 각 백업 및 복원 세션에 대한 세션 상태 개체를 만듭니다. 일반적인 상황에서는 사용되지 않고 있을 때 작성자가 세션 상태 개체가 정리됩니다. 기본 세션 상태 정리 다음과 같은 상황에서 발생합니다.
  • 백업 응용 프로그램은 BackupComplete 응답을 보내고 기록기 상태 GatherWriterStatus 보내 확인합니다.
  • 백업 응용 프로그램은 PostRestore 응답을 보내고 기록기 상태 GatherWriterStatus 쿼리를 보내 확인합니다.
  • 작성자에서 세션에 대해 OnAbort 이벤트 콜백을 받습니다. 백업 응용 프로그램에서 작성기를 사용하거나, VSS 인프라는 백업 세션 명시적으로 실패한 경우 OnAbort 이벤트 콜백이 호출됩니다.
VSS 기록기가 인프라의 나머지 세션 상태 정기적으로 가비지 수집을 수행합니다. 이틀 보다 오래된 각 세션 상태 개체에 대한 이전 이벤트 로그, infrustructure 다음 기록합니다. 이벤트 로그 백업 응용 프로그램이 제대로 작동하지 않는 것 기록기 버려진된 세션을 식별하는 데 도움을 주기 위한 것입니다. 완료되지 않은 백업 일련의 없음을 나타내는 또는 세션 복원 여러 작성자가 빠르게 연속해서 여러 가지 유사한 이벤트를 볼 수 있습니다. 테스트 환경에서 이 문제가 자주 볼 수 있습니다.

해결 과정

이 오류는 일시적인 항목을 무시하십시오. 의해 백업을 시작하거나 복원 작업을 가비지 수집 작업에 대한 응답으로 관련된 이벤트가 기록되지 않습니다. 그러나 이러한 오류는 현재 백업이 관련되지 않은 또는 세션 복원합니다. 이 오류를 일관성 있게 재현할 경우 백업 응용 프로그램 공급업체에 모든 VSS 백업 세션 정리 지침을 따르면 됩니다 확인하십시오.

속성

기술 자료: 978773 - 마지막 검토: 2009년 12월 22일 화요일 - 수정: 1.1
본 문서의 정보는 다음의 제품에 적용됩니다.
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard
키워드:?
kbmt kbsurveynew kbexpertiseadvanced kbtshoot KB978773 KbMtko
기계 번역된 문서
중요: 본 문서는 전문 번역가가 번역한 것이 아니라 Microsoft 기계 번역 소프트웨어로 번역한 것입니다. Microsoft는 번역가가 번역한 문서 및 기계 번역된 문서를 모두 제공하므로 Microsoft 기술 자료에 있는 모든 문서를 한글로 접할 수 있습니다. 그러나 기계 번역 문서가 항상 완벽한 것은 아닙니다. 따라서 기계 번역 문서에는 마치 외국인이 한국어로 말할 때 실수를 하는 것처럼 어휘, 구문 또는 문법에 오류가 있을 수 있습니다. Microsoft는 내용상의 오역 또는 Microsoft 고객이 이러한 오역을 사용함으로써 발생하는 부 정확성, 오류 또는 손해에 대해 책임을 지지 않습니다. Microsoft는 이러한 문제를 해결하기 위해 기계 번역 소프트웨어를 자주 업데이트하고 있습니다.
이 문서의 영문 버전 보기:978773

피드백 보내기

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com