Řešení selhání instalace nástroje Data Protection Manager 2007 Protection Agent (ID chyby: 370)

Překlady článku Překlady článku
ID článku: 978900 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Souhrn

Při instalaci Microsoft System Center Data Protection Manager 2007 Protection Agent cílový server zobrazí chyba operace agenta se nezdařilo. (ID: 370) následovaný jiné chybě ID. Tento článek popisuje řešení potíží s chybami instalaci agenta na základě druhé id chyby, které obdržíte.

Příznaky

Při instalaci cílový server Microsoft System Center Data ochrana správce (DPM) 2007 Protection Agent, můžete obdržet následující chybovou zprávu:
ID: 370
Agent operace se nezdařila.
Poté zobrazí se jedna z následující ID chyby:
  • ID chyby: 7:
    Nelze se připojit k databázi služba Active Directory Domain Services. Ujistěte se, že DPM server je členem domény a spuštěné řadiče domény. Také ověřte, zda je síťové připojení mezi serverem DPM a řadič domény
    ID: 7
    Podrobnosti: Zadaný adresář atribut nebo hodnota služby neexistuje (0x8007200A)
  • ID chyby: 277:
    Nelze se připojit ke správci řízení služby v FQDN_Server_Name. (ID: 277)

    1) Zkontrolujte, zda tento FQDN_Server_Name je online a DPM serveru vzdáleně k dispozici.
    2) Pokud je v FQDN_Server_Name povolena brána firewall, ujistěte se, neblokuje požadavky ze serveru DPM.
  • ID chyby: 302:
    Operace agenta ochrany se nezdařila, protože nezískal přístup k ochranu agent na serveru % FQDN_of_Production_Server %. Server % FQDN_of_Production_Server % může být spuštěn DPM nebo agent ochranu DPM mohly být nainstalovány jiným počítačem DPM. (ID: 302)
  • ID chyby: 313: DPM 2007 můžete úspěšně nasadit agenti členských serverů v doméně systému Windows Server 2003. Agent však nelze zavést libovolného řadiče domény. Instalace dosáhne hodnoty 90 % a poté se nezdaří s touto chybou:
    Nainstalujte agenta ochranu computername se nezdařilo. Chyba 313: Operace agenta: tuto se nezdařilo, protože došlo k chybě při spuštění instalačního programu na computername. Podrobnosti o chybě: závažná chyba během instalace [0x80070643].
  • ID chyby: 326:
    Ochranu agenta operace se nezdařila, protože byl odepřen přístup k serveru Servername DPM. (ID: 326)
  • ID chyby: 337:
    Nástroj Data Protection Manager ID chyby: 337

    Agent ochranu nelze nainstalovat na targetserver, protože byl odepřen přístup k počítači.

Příčina

Tyto chyby dojít z následujících důvodů:
  • ID chyby: 7: Tato chyba dojde, pokud je cílový server v jiné organizační jednotce ve službě Active Directory a ověření uživatelé nemají přístup pro čtení s touto organizační jednotkou. Účet služby DPM proto nelze nalézt server ve službě Active Directory.
  • ID chyby: 277: Tato chyba nastane, pokud je zakázán přístup pomocí koordinátoru DTC sítě.
  • ID chyby: 302 a ID chyby: 337: těmto chybám dochází při Service Principal Names (SPN) pro server nejsou konzistentní ve službě Active Directory. Instalace agenta může nesprávné informace použít k dokončení instalace a připojení. Tento problém může způsobit, že mnoho příznaků.
  • ID chyby: 313: Tato chyba nastane, pokud Průvodce instalací agenta DPM nemá dostatečná oprávnění k zápisu souborů do adresáře nebo podklíč registru. Tato chyba se může zobrazit také při selhání instalace agenta DPM na toto nebo jiné řadiče domény v rámci domény.
  • ID chyby: 326: Tato chyba nastane, pokud se zobrazí dialogové okno na cílovém serveru při instalaci agenta DPM. Toto dialogové okno je pouze viditelné z konzoly serveru. Toto dialogové okno vyžaduje ruční interakci pro potvrzení a zavřete dialogové okno. Toto dialogové okno je pouze viditelné z konzoly serveru. Dokud není uzavřen v tomto dialogovém nelze nasadíte agenta DPM k tomuto serveru.

Řešení

Tento problém můžete vyřešit rozlišení pro konkrétní chyba ID, které obdržíte.

Rozlišení pro ID chyby: 7

Tuto chybu lze odstranit, změnit skupinu Authenticated Users tak, aby ji má oprávnění ke čtení pro organizační jednotku, která cílový server je členem. Postupujte takto:
  1. V řadiči domény otevřete Active uživatelé a počítače služby Directory konzoly MMC.
  2. Klepněte pravým tlačítkem myši na organizační jednotku, která obsahuje cílový server a potom klepněte na příkaz Vlastnosti.
  3. Na kartě zabezpečení přidejte skupinu Authenticated Users a přiřaďte jim oprávnění pro čtení.
  4. Znovu nasaďte agent DPM ochrany chráněných serveru.

Rozlišení pro ID chyby: 277

Chcete-li vyřešit tento problém, postupujte podle pokynů uvedených v článku znalostní báze Microsoft Knowledge Base 817064 a pak znovu nasaďte agent DPM oba uzly clusteru.
817064Jak povolit síťový přístup pomocí koordinátoru DTC v systému Windows Server 2003

Rozlišení pro ID chyby: 302 a ID chyby: 337

Chcete-li tento problém vyřešit, spusťte nástroj SetSPN a zkontrolujte názvy hlavní Service pro server, který nelze stisknutí agent.

Poznámka:Další informace o tom, jak získat nejnovější verzi nástroje SetSPN naleznete následujících článku znalostní báze Microsoft Knowledge Base:
970536Setspn.exe podporu nástroje aktualizace pro systém Windows Server 2003
  1. Přihlaste se jako správce domény.
  2. Na příkazovém řádku zadejte následující příkaz a poté stiskněte klávesu ENTER:
    setspn -L Servername
    Poznámka: V tomto příkazu Servername zastupuje cílového serveru, který nelze nasadíte DPM agenta.

    Výsledný výstup by panelu vypadat takto:
    ~~~~~~~~~~~~~~~~~~~~~~~~~
    Registered ServicePrincipalNames for CN=TARGETSERVER,OU=Member 
    Servers,DC=<Servername>,DC=com:
    SMTPSVC/targetserver.<Servername>
    NtFrs-88f5d2bd-b646-11d2-a6d3-00c04fc9b232/targetserver.<Servername>
    HOST/targetserver.www.<Incorrect_Servername>/Incorrect_Servername
    HOST/targetserver.www.<Incorrect_Servername>
    exchangeMDB/targetserver.www.<Incorrect_Servername>
    SMTPSVC/targetserver.www.<Incorrect_Servername>
    HOST/targetserver.www.<Incorrect_Servername> /www.<Incorrect_Servername>
    exchangeRFR/targetserver.www.<Incorrect_Servername>
    exchangeRFR/targetserver.<Servername>
    exchangeMDB/targetserver.<Servername>
    exchangeRFR/TARGETSERVER
    exchangeMDB/TARGETSERVER
    SMTPSVC/TARGETSERVER
    HOST/TARGETSERVER
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Všimněte si, že všechny "HOST /" SPN položky, které jsou uvedeny ve výstupu označují, že primární DNS je nastavena na Incorrect_Servername, Servername. Při nasazení agent, DPM serveru je překládání názvu TARGETSERVER SERVERNAME a jedná co používá k vytvoření hlavní název služby, které ji probíhá požadované v době zavádění agenta. Však vzhledem k tomu, že SPN, které jsou registrovány pro targetserver jsou pro www. Incorrect_Servername, pokus o připojení pomocí protokolu Kerberos se nezdaří a je proveden pokus o anonymní připojení. To může výsledky v události ID 6033 zaprotokolována na serveru Exchange.
  3. Ověřte, zda jsou k dispozici žádné duplicitní SPN cílový server. Na příkazovém řádku zadejte následující příkaz a poté stiskněte klávesu ENTER:
    setspn -X
    Prohlédněte si výstup všech duplikátů hlavní název služby požadované pro cílový server.
  4. Chcete-li se přesvědčit, zda je správně zaregistrována SPN hostitel, zadejte na příkazovém řádku následující příkazy. Každý příkaz potvrďte stisknutím klávesy ENTER.
    setspn - a HOST / Servername targetserver targetserver.
    Setspn - a HOST/targetserver targetserver
  5. Replikaci změn v rámci služby Active Directory.
  6. Znovu nasaďte agent DPM ochrany na ohrožené servery.
Další informace o nástroji SetSPN na následujícím webu Microsoft TechNet:
Setspn Overview

Rozlišení pro ID chyby: 313

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Metoda 1

Chcete-li oprávnění problém vyřešit, zkontrolujte soubor protokolu instalace Msdpm, který je umístěn v klientském počítači do následující složky:
%windir%\temp\msdpm*.log
Určit, které podklíč registru nebo složky nelze získat přístup k a pak poskytují skupiny Administrators v klientském počítači oprávnění k zápisu do nich.

Metoda 2

Pokud předchozí selhal pokus o instalaci agenta na tento řadič domény nebo do jiného řadiče domény, ověřte a odstraňte položky v kontejneru Users nástroj Active Directory uživatelé a počítače, podobné následujícím:
  • DPMRADCOMTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 - b4fa - 7d945440e08b
  • DPMRADmTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 - b4fa - 7d945440e08b
Tyto položky můžete bezpečně odstranit, protože jsou duplikáty skupiny DPMRADCOMTrustedMachines a DPMRADmTrustedMachines. Mohou snadno lze identifikovat porovnáním CNF: GUID text, který je připojen k jednotlivé položky. Po odstranění těchto položek spustit Repadmin.exe vynucení replikace změn do služby Active Directory do jiných řadičů domény, nebo můžete poskytnout služby Active Directory dostatek času na replikaci těchto změn na ostatní řadiče domény.

Rozlišení pro ID chyby: 326

Chcete-li tento problém vyřešit, přihlaste se k relaci konzoly na cílovém serveru a potom ručně potvrdit dialogového okna po zopakovat instalaci agenta DPM.

Vlastnosti

ID článku: 978900 - Poslední aktualizace: 10. března 2010 - Revize: 1.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft System Center Data Protection Manager 2007
Klíčová slova: 
kbmt kbdeployment kbinstallation kbtshoot kbexpertiseadvanced kbsurveynew kbprb KB978900 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:978900

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com