Behandlung von Data Protection Manager 2007 Protection-Agent-Installationsfehler (FEHLERKENNUNG: 370)

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Zusammenfassung

Wenn Sie ein Microsoft System Center Data Protection Manager 2007 Protection-Agent auf einem Zielserver installieren, erhalten Sie einen Fehler-Agent-Vorgang ist fehlgeschlagen. (ID: 370) gefolgt von einem anderen Fehler-ID. Dieser Artikel beschreibt die Behandlung von Agent-Installationsfehlern basierend auf dem zweiten Fehler-Id, die angezeigt werden.

Problembeschreibung

Bei der Installation von Microsoft System Center Data Protection Manager (DPM) 2007 Protection-Agent auf einem Zielserver erhalten Sie die folgenden Fehlermeldung:
ID: 370
Fehler bei Agent-Vorgang.
Anschließend erhalten Sie eine der folgenden Fehler-IDs:
  • Fehler-ID: 7:
    Keine Verbindung mit der Active Directory-Domänendienste-Datenbank. Stellen Sie sicher, dass der DPM-Server Mitglied einer Domäne ist und dass ein Domänencontroller ausgeführt wird. Stellen Sie außerdem sicher, dass Netzwerkkonnektivität zwischen dem DPM-Server und dem Domänencontroller
    ID: 7
    Details: Das angegebene Verzeichnisdienstattribut bzw. der Wert (0x8007200A) existiert nicht
  • Fehler-ID: 277:
    Die Verbindung zum Dienstkontroll-Manager auf FQDN_Server_Name konnte nicht hergestellt werden. (ID: 277)

    1) Stellen Sie sicher, dass die FQDN_Server_Name ist jetzt online und Remote vom DPM-Server zur Verfügung.
    2) Wenn eine Firewall auf FQDN_Server_Name aktiviert ist, stellen Sie sicher, dass er Anforderungen vom DPM-Server nicht blockiert ist.
  • Fehler-ID: 302:
    Der Schutz der Agent-Vorgang ist fehlgeschlagen, da den Schutz der Agent auf dem Server % FQDN_of_Production_Server nicht zugegriffen werden konnte. Das Server % FQDN_of_Production_Server % DPM ausgeführt werden kann, oder der Schutz DPM-Agent möglicherweise von einem anderen DPM-Computer installiert wurden. (ID: 302)
  • Fehler-ID: 313: DPM 2007 Agenten auf Mitgliedsserver in einer Windows Server 2003-Domäne bereitstellen können. Einen Agent kann jedoch nicht für alle anderen Domänencontroller bereitgestellt werden. Installation 90 % erreicht, und es dann mit diesem Fehler fehl:
    Installieren Sie Schutz-Agent auf computername ist fehlgeschlagen. Fehler 313: Der Agent-Vorgang ist fehlgeschlagen, da beim Ausführen des Installationsprogramms auf computername ist ein Fehler aufgetreten. Fehlerdetails: Schwerwiegender Fehler bei der Installation [0 x 80070643].
  • Fehler-ID: 326:
    Der Schutz der Agent-Vorgang ist fehlgeschlagen, da der Servername DPM-Server der Zugriff verweigert wurde. (ID: 326)
  • Fehler-ID: 337:
    Data Protection Manager-FEHLERKENNUNG: 337

    Der Schutz-Agent kann nicht auf Targetserver installiert werden, da der Zugriff auf den Computer verweigert wurde.

Ursache

Diese Fehler werden aus den folgenden Gründen auftreten:
  • Fehler-ID: 7: Dieser Fehler tritt auf, wenn der Zielserver in einer anderen Organisationseinheit in Active Directory ist und authentifizierte Benutzer haben keinen Lesezugriff auf diese Organisationseinheit. Daher kann das DPM-Dienstkonto den Server in Active Directory nicht finden.
  • Fehler-ID: 277: Dieser Fehler tritt auf, wenn die Netzwerk-DTC-Zugriff deaktiviert ist.
  • Fehler-ID: 302 und FEHLERKENNUNG: 337: Diese Fehler treten auf, wenn die Dienstprinzipalnamen (SPNs) für den Server nicht in Active Directory konsistent sind. Die Agentinstallation möglicherweise falsche Informationen verwenden, um die Installation und Verbindung abzuschließen. Dieses Problem kann dazu führen, dass viele Symptome.
  • Fehler-ID: 313: Dieser Fehler tritt auf, wenn der DPM-Agent-Setup-Assistent keine ausreichende Berechtigungen, Dateien zu schreiben, um ein Verzeichnis oder einen Registrierungsunterschlüssel. Dieser Fehler wird möglicherweise auch angezeigt, wenn es eine fehlerhafte Installation des DPM-Agent auf diesem oder anderen Domänencontrollern innerhalb der Domäne wurde.
  • Fehler-ID: 326: Dieser Fehler tritt auf, wenn auf dem Zielserver wird ein Dialogfeld angezeigt, in dem Sie den DPM-Agent installieren. Dieses Dialogfeld wird nur von der Konsole des Servers angezeigt. In diesem Dialogfeld erfordert manuelle Interaktion bestätigen und das Dialogfeld zu schließen. Dieses Dialogfeld wird nur von der Konsole des Servers angezeigt. Bis das Dialogfeld geschlossen wird, kann den DPM-Agent für diese Server nicht bereitgestellt werden.

Lösung

Um dieses Problem zu beheben, verwenden Sie die Auflösung für die spezifischen Fehler-ID, die angezeigt werden.

Auflösung für den Fehler-ID: 7

Um diesen Fehler zu beheben, ändern Sie die Gruppe "Authentifizierte Benutzer", sodass Berechtigungen für die Organisationseinheit gelesen hat, die der Zielserver ein Mitglied ist. Gehen Sie hierzu folgendermaßen vor:
  1. Öffnen Sie die Active Directory-Benutzer und Computer MMC, auf dem Domänencontroller.
  2. Klicken Sie mit der rechten Maustaste auf die Organisationseinheit, die den Zielserver enthält, und klicken Sie dann auf Eigenschaften.
  3. Auf der Registerkarte Sicherheit die Gruppe "Authentifizierte Benutzer" hinzufügen und mit READ Berechtigungen versehen.
  4. Erneutes Bereitstellen des DPM-Schutz-Agents auf dem geschützten Server.

Auflösung für den Fehler-ID: 277

Um dieses Problem zu beheben, führen Sie die Schritte im Microsoft Knowledge Base-Artikel 817064 und anschließende erneute Bereitstellen des DPM-Agents auf beiden Clusterknoten.
817064Gewusst wie: Aktivieren von DTC-Netzwerkzugriff in Windows Server 2003

Auflösung für den Fehler-ID: 302 und FEHLERKENNUNG: 337

Um dieses Problem zu beheben, führen Sie das Tool SetSPN und überprüfen Sie den Dienstprinzipalnamen für den Server, dem Sie push-den Agent können nicht.

Hinweis:Weitere Informationen dazu, wie Sie die neueste Version des Dienstprogramms SetSPN zu erhalten klicken Sie auf die folgende KB-Artikelnummer:
970536"Setspn.exe" Support Tools Update für Windows Server 2003
  1. Melden Sie sich als Domänenadministrator.
  2. Geben Sie in der Eingabeaufforderung den folgenden Befehl ein und drücken Sie dann die [Eingabetaste]:
    Setspn ? L Servername
    Hinweis: In diesem Befehl steht der Platzhalter Servername den Zielserver, dem Sie bereitstellen, den DPM-Agent können nicht.

    Die resultierende Ausgabe sollte etwa Folgendes aussehen:
    ~~~~~~~~~~~~~~~~~~~~~~~~~
    Registered ServicePrincipalNames for CN=TARGETSERVER,OU=Member 
    Servers,DC=<Servername>,DC=com:
    SMTPSVC/targetserver.<Servername>
    NtFrs-88f5d2bd-b646-11d2-a6d3-00c04fc9b232/targetserver.<Servername>
    HOST/targetserver.www.<Incorrect_Servername>/Incorrect_Servername
    HOST/targetserver.www.<Incorrect_Servername>
    exchangeMDB/targetserver.www.<Incorrect_Servername>
    SMTPSVC/targetserver.www.<Incorrect_Servername>
    HOST/targetserver.www.<Incorrect_Servername> /www.<Incorrect_Servername>
    exchangeRFR/targetserver.www.<Incorrect_Servername>
    exchangeRFR/targetserver.<Servername>
    exchangeMDB/targetserver.<Servername>
    exchangeRFR/TARGETSERVER
    exchangeMDB/TARGETSERVER
    SMTPSVC/TARGETSERVER
    HOST/TARGETSERVER
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    
    Beachten Sie, dass alle der "HOST /" Dienstprinzipalnamen-Einträge, die in der Ausgabe aufgeführt werden weisen darauf hin, dass der primäre DNS-Incorrect_Servername, nicht Servername festgelegt ist. Wenn der Agent bereitgestellt wird, der DPM-Server des Namens TARGETSERVER. SERVERNAME und dies ist, was den SPN zu erstellen, die es gerade verwendet wird zum Zeitpunkt der Agent Bereitstellung angefordert. Da die SPNs, die für die Targetserver registriert sind für Www. Incorrect_Servername, der Kerberos-Verbindungsversuch schlägt jedoch fehl, und es wird versucht, eine anonyme Verbindung herzustellen. Dies kann die Ergebnisse in einem Ereignis-ID 6033 auf dem Exchange-Server angemeldet.
  3. Stellen Sie sicher, dass keine doppelte SPNs des Zielservers. Geben Sie in der Eingabeaufforderung den folgenden Befehl ein und drücken Sie dann die [Eingabetaste]:
    Setspn X -
    Untersuchen Sie die Ausgabe für alle Duplikate der gewünschte Dienstprinzipalname (SPN) für den Zielserver.
  4. Geben Sie die folgenden Befehle an einer Eingabeaufforderung um sicherzustellen, dass die Host-SPNs ordnungsgemäß registriert sind. Drücken Sie nach jedem Befehl die [EINGABETASTE].
    Setspn - a HOST / Targetserver. Servername Targetserver
    Setspn-a HOST-Targetserver targetserver
  5. Replizieren der Änderungen im gesamten Active Directory.
  6. Erneut bereitstellen Sie, den Schutz DPM-Agent auf dem betroffenen Server.
Weitere Informationen zum Dienstprogramm SetSPN finden Sie auf den folgenden Microsoft TechNet-Website:
Setspn Overview

Auflösung für den Fehler-ID: 313

Wenden Sie eines der folgenden Verfahren an, um dieses Problem zu beheben.

Methode 1

Untersuchen Sie Msdpm Protokolldatei für die Installation, die auf dem Clientcomputer in den folgenden Ordner befindet, um das Berechtigungen-Problem zu beheben:
%Windir%\temp\msdpm*.log
Bestimmen Sie, welche Ordner oder Registrierungsschlüssel Unterschlüssel konnte nicht zugegriffen werden, und geben Sie den Clientcomputer Administratoren über eine Schreibberechtigung für diese Gruppe.

Methode 2

Wenn es sich bei ein vorherigen fehlgeschlagener Versuch zum Installieren des Agents auf diesen Domänencontroller oder einem anderen Domänencontroller vorhanden war, überprüfen Sie, und löschen Sie alle Einträge in den Container <a0>Benutzer</a0> des Dienstprogramms Active Directory-Benutzer und Computer, die wie folgt aussehen:
  • DPMRADCOMTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 - b4fa - 7d945440e08b
  • DPMRADmTrustedMachinesCNF:28f84c90 - fa10 - 4ff7 - b4fa - 7d945440e08b
Sie können diese Einträge bedenkenlos löschen, da Sie Duplikate der DPMRADCOMTrustedMachines und DPMRADmTrustedMachines Gruppen sind. Sie können problemlos durch die CNF identifiziert werden: GUID-Text, der jeder Eintrag angehängt wird. Nachdem Sie diese Einträge gelöscht haben, führen Sie die Datei "Repadmin.exe" zum Erzwingen der Replikation der Änderungen an Active Directory zu den anderen Domänencontrollern oder können Ihnen Active Directory ausreichend Zeit, um diese Änderungen auf andere Domänencontroller replizieren.

Auflösung für den Fehler-ID: 326

Um dieses Problem zu beheben, melden Sie sich bei der Konsolensitzung auf dem Zielserver, und dann manuell bestätigen im Dialogfeld nach dem Sie es, erneut um den DPM-Agent zu installieren.

Eigenschaften

Artikel-ID: 978900 - Geändert am: Mittwoch, 10. März 2010 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft System Center Data Protection Manager 2007
Keywords: 
kbmt kbdeployment kbinstallation kbtshoot kbexpertiseadvanced kbsurveynew kbprb KB978900 KbMtde
Maschinell übersetzter Artikel
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