Connexions TCP échouent par intermittence lorsque les deux points de terminaison sont sur le même ordinateur dans Windows Server 2003 SP2

Traductions disponibles Traductions disponibles
Numéro d'article: 979230 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Envisagez le scénario suivant :
  • Mettre à jour de la version du pilote TCPIP.sys pour le 5.2.3790.4531 version ou une version ultérieure sur un ordinateur qui exécute Windows Server 2003 Service Pack 2 (SP2).
  • Vous créez une connexion TCP sur l'ordinateur. Les deux points de terminaison de cette connexion se trouvent sur le même ordinateur. Par exemple, vous établissez une connexion TCP pour localhost.

Dans ce scénario, l'application ou le service crée la connexion TCP peut rencontrer une défaillance de fonction ou une autre exception par intermittence. En outre, lorsque vous exécutez la commande netstat - ano après que le problème se produit, la sortie de cette commande indique que le nombre de connexions rester à l'état LAST_ACK, dans l'état FIN_WAIT_2 ou dans l'état de fermeture jusqu'à ce que l'ordinateur est redémarré.

Cause

Ce problème se produit en raison d'une condition de concurrence dans le pilote TCP/IP (Tcpip.sys). Lorsque la condition de concurrence critique se produit, la notification de déconnexion n'est pas envoyée au moment requis. Ce comportement rend orphelin certaines connexions TCP. Par conséquent, les applications ou les services qui s'appuient sur ces connexions échouent. En outre, ces connexions restent à l'état LAST_ACK, dans l'état FIN_WAIT_2 ou dans l'état de fermeture.

Résolution

Informations sur le correctif

Un correctif pris en charge est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant le problème décrit dans cet article. Ce correctif va peut-être subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielle qui contiendra ce correctif.

Si le correctif est disponible au téléchargement, il existe une section «Téléchargement de correctif logiciel disponible» en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux questions supplémentaires et aux problèmes qui ne relèvent pas de ce correctif spécifique. Pour obtenir une liste complète des numéros de téléphone Microsoft auprès des services de support technique ou pour créer une demande de service distincte, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ws=support
Remarque Le formulaire «Téléchargement de correctif logiciel disponible» affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est, car un correctif n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, votre ordinateur doit exécuter Windows Server 2003 Service Pack 2 (SP2).

La nécessité de redémarrer

Vous devez redémarrer l'ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement du correctif

Ce correctif ne remplace pas un correctif publié précédemment.

Informations de fichier

La version anglais (États-Unis) de ce correctif installe des fichiers dont les attributs répertoriés dans les tableaux suivants. Les dates et heures de ces fichiers figurent dans le temps universel coordonné (UTC). Les dates et heures de ces fichiers sur votre ordinateur local sont affichés dans votre heure locale avec votre POLARISATION heure (DST) en cours. En outre, les dates et les heures peuvent changer lorsque vous effectuez certaines opérations sur les fichiers.
Remarques sur les fichiers Windows Server 2003
  • Parallèlement aux fichiers répertoriés dans ces tableaux, ce correctif installe également un fichier de catalogue de sécurité associé (KB number .cat) qui est signé avec une signature de numérique de Microsoft.
Pour toutes les x 86 de versions de Windows Server 2003
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP requis
Tcpip.sys5.2.3790.4681400,89618-Mar-201017 : 57x 86SP2
W03a3409.dll5.2.3790.459043,52016-Sep-200912 : 16x 86SP2
Pour toutes les versions 64 de Windows Server 2003 x
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP requisDossier
Tcpip.sys5.2.3790.4681798,72018-Mar-201017 : 57x 64SP2Non applicable
W03a3409.dll5.2.3790.459044 03218-Mar-201017 : 57x 64SP2Non applicable
Ww03a3409.dll5.2.3790.459043,52018-Mar-201017 : 57x 86SP2WOW
Pour toutes les versions IA-64 de Windows Server 2003 prises en charge
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeSP requisDossier
Tcpip.sys5.2.3790.46811,336,83218-Mar-201017 : 57IA-64SP2Non applicable
W03a3409.dll5.2.3790.459042 49618-Mar-201017 : 57IA-64SP2Non applicable
Ww03a3409.dll5.2.3790.459043,52018-Mar-201017 : 57x 86SP2WOW

Statut

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section "S'applique à".

Plus d'informations

Pour plus d'informations sur la terminologie de mise à jour de logiciel, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
824684Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la base de connaissances Microsoft :
971383Perte de données se produit lorsque la fonction de «recv» Winsock renvoie 0 octets si le côté client et les applications côté serveur effectués sur le même ordinateur qui exécute Windows Server 2003

Propriétés

Numéro d'article: 979230 - Dernière mise à jour: mardi 4 mai 2010 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows Server 2003 Service Pack 2 sur le système suivant
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
    • Microsoft Windows Server 2003, Datacenter x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Mots-clés : 
kbmt kbfix kbautohotfix kbhotfixserver kbsurveynew kbqfe kbexpertiseadvanced KB979230 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 979230
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com