"A network error occurred. File cannot be played. Server is unavailable." error message when a domain user tries to access the publishing points of Windows Media Service 9 series which is installed on a Windows Server 2003 SP2-based computer

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Article ID: 979280 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • Windows Media Services 9 series is installed on a computer that is running Windows Server 2003 Service Pack 2 (SP2).
  • Both the WMS Publishing Points ACL Authorization plug-in and the WMS Negotiate Authentication plug-in are enabled in the Windows Media Services 9 series MMC snap-in.
  • A domain user tries to access publishing points that are hosted on the server.

    NoteThe domain user belongs to hundreds of security groups, the security groups can be more than 200 domain local groups.
In this scenario, the user cannot access the publishing points and receive the following error message:

A network error occurred. File cannot be played. Server is unavailable. Please check your network connectivity and proxy configuration

CAUSE

This problem occurs because the Kerberos ticket of the domain user is larger than 10000 bytes. Windows Media Services 9 series does not handle a Kerberos ticket if its size is larger than 10000 bytes.

RESOLUTION

To resolve this problem, install the following hotfix. After you install the hotfix, the limitation is changed to 16384 bytes.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running one of Windows Server 2003 Service Pack 2 with the "Windows Media Services" component installed. For more information about how to obtain a Windows Server 2003 service pack or a Windows XP Professional x64 Edition service pack, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows XP and Windows Server 2003 file information notes
  • In addition to the files that are listed in these tables, this hotfix also installs an associated security catalog file (KBnumber.cat) that is signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wmsserver.dll9.1.1.50033,170,30425-Jan-201014:25x86
For all supported x64-based versions of Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Wmsserver.dll9.1.1.50035,826,56025-Jan-201012:13x64

WORKAROUND

To work around this problem, reduce the number of security groups that the user belongs to.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 979280 - Last Review: March 10, 2010 - Revision: 1.0
APPLIES TO
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
Keywords: 
kbprb kbsurveynew kbexpertiseadvanced kbhotfixserver kbautohotfix kbqfe kbfix KB979280

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