รหัสข้อผิดพลาด 0x8100002F และหรือรหัสข้อผิดพลาด 0x80070002 เมื่อคุณสำรองแฟ้มใน Windows 7

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 979281 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

หลังจากที่คุณสำรองแฟ้ม โดยใช้การสำรองข้อมูลของ Windows บนคอมพิวเตอร์ที่ใช้ Windows 7 คุณได้รับการแจ้งเตือนที่คล้ายกับต่อไปนี้:
ตรวจสอบผลลัพธ์ที่ได้จากการสำรองข้อมูล
การสำรองข้อมูลเสร็จสมบูรณ์แล้วแต่แฟ้มบางแฟ้มถูกข้ามไป
เมื่อคุณคลิกปุ่มตัวเลือกที่อยู่ถัดจากการแจ้งเตือน คุณได้รับข้อความต่อไปนี้:
ตรวจสอบผลลัพธ์ที่ได้จากการสำรองข้อมูล
การสำรองข้อมูลเสร็จสมบูรณ์แล้วแต่แฟ้มบางแฟ้มถูกข้ามไป
ดูแฟ้มที่ข้ามไป

เมื่อคุณคลิก ดูแฟ้มที่ข้ามไป เชื่อมโยง คุณดูแฟ้มบันทึกข้อผิดพลาดต่อไปนี้อย่างใดอย่างหนึ่ง

สถานการณ์สมมติที่ 1:
การสำรองข้อมูลประสบปัญหาในขณะทำสำรองแฟ้ม C:\Windows\System32\config\systemprofile\<folder name=""></folder>. ข้อผิดพลาด: (ระบบไม่พบแฟ้มที่ระบุได้ (0x80070002))

สถานการณ์สมมติที่ 2:
การสำรองข้อมูลประสบปัญหาในขณะทำสำรองแฟ้ม C:\Users\<User name=""></User>\AppData\LocalLow ข้อผิดพลาด: (ระบบไม่พบแฟ้มที่ระบุได้ (0x80070002))
การสำรองข้อมูลประสบปัญหาในขณะทำสำรองแฟ้ม C:\Users\<User name=""></User>\Contacts ข้อผิดพลาด: (ระบบไม่พบแฟ้มที่ระบุได้ (0x80070002))
การสำรองข้อมูลประสบปัญหาในขณะทำสำรองแฟ้ม C:\Users\<User name=""></User>\Searches ข้อผิดพลาด: (ระบบไม่พบแฟ้มที่ระบุได้ (0x80070002))

สถานการณ์สมมติที่ 3:

การสำรองข้อมูลของ Windows จะล้มเหลว ด้วยรหัสข้อผิดพลาด 0x80070002 "ระบบไม่พบแฟ้มที่ระบุ ในสถานการณ์สมมตินี้ ปัญหาต่อไปนี้อย่างใดอย่างหนึ่งเกิด:
  • คอมพิวเตอร์หยุดการตอบสนอง
  • หยุดการดำเนินการคัดลอก

สาเหตุ

สถานการณ์สมมติ 1 สาเหตุ

ปัญหานี้เกิดขึ้นถ้าคุณสำรองข้อมูลไลบรารีที่ประกอบด้วยโฟลเดอร์ที่กำหนดเองที่อยู่ภายใต้ส่วนกำหนดค่าผู้ใช้ของคุณ

สถานการณ์สมมติ 2 สาเหตุ

ปัญหานี้เกิดขึ้นหากมีเงื่อนไขต่อไปนี้:
  • การสำรองข้อมูลของ Windows พยายามที่จะสำรองแฟ้มในโฟลเดอร์ LocalLow ผู้ติดต่อ และค้นหา
  • โฟลเดอร์เหล่านี้จะไม่มีอยู่บนคอมพิวเตอร์ของคุณ
หมายเหตุ โฟลเดอร์เหล่านี้ถูกสร้างขึ้นก็ต่อเมื่อมีการติดตั้งโปรแกรมประยุกต์บางโปรแกรมบนคอมพิวเตอร์

สถานการณ์สมมติ 3 สาเหตุ

ปัญหานี้เกิดขึ้นหากมีเงื่อนไขต่อไปนี้:
  • คอมพิวเตอร์ที่มีชิปเซ็ต NVIDIA USB ขั้นสูงโฮสต์ตัวควบคุมอินเทอร์เฟซ (EHCI) ได้
  • คอมพิวเตอร์ที่มี RAM น้อย 4 GB
  • คุณได้พยายามคัดลอกข้อมูลจากคอมพิวเตอร์ไปยังอุปกรณ์เก็บข้อมูล USB ภายนอก
บันทึกย่อ
  • ปัญหานี้อาจเกิดขึ้นเมื่อคุณใช้อุปกรณ์ USB แทนอุปกรณ์เก็บข้อมูล
  • ปัญหานี้อาจเกิดขึ้นหากคุณดำเนินการอื่น ๆ input/output (I/O) บนอุปกรณ์เก็บข้อมูล USB ในสถานการณ์นี้ การดำเนินการ I/O ล้มเหลว

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ใช้วิธีการใดวิธีการหนึ่งวิธีการแก้ปัญหาที่ระบุไว้สำหรับสถานการณ์ของคุณ

การแก้ปัญหาสถานการณ์สมมติที่ 1

เมื่อต้องการแก้ไขปัญหานี้ ทำการดำเนินการต่อไปนี้อย่างใดอย่างหนึ่ง:
  • ละเว้นข้อความแสดงข้อผิดพลาด
    หมายเหตุ แฟ้มไลบรารีแบบกำหนดเองที่เก็บอยู่ในส่วนกำหนดค่าผู้ใช้ของคุณจะไม่สามารถสำรอง
  • ย้ายโฟลเดอร์ไลบรารีจากเส้นทางส่วนกำหนดค่าผู้ใช้ไปยังตำแหน่งอยู่นอกเส้นทางโปรไฟล์ผู้ใช้ ตัวอย่างเช่น ย้ายโฟลเดอร์ไปยังโฟลเดอร์ C:\MyLibraries
  • แยกไลบรารีจากรายการของแฟ้มที่สำรองข้อมูลการสำรองข้อมูลของ Windows แล้ว รวมตำแหน่งที่ตั้งเดิมของเนื้อหาในไลบรารีในรายการการสำรองข้อมูล
  • ย้ายโฟลเดอร์ไลบรารีไปยังตำแหน่งอื่นนอกเหนือจากโฟลเดอร์ส่วนกำหนดค่าผู้ใช้ จากนั้น เพิ่มการเชื่อมโยงไปยังโฟลเดอร์ที่มีการย้ายจากไลบรารี ตรวจสอบให้แน่ใจว่า ไลบรารีที่ถูกรวมในการสำรองข้อมูล

    ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
    1. คลิกเริ่มแล้ว คลิกชื่อผู้ใช้ของคุณ
    2. คลิกขวาที่โฟลเดอร์ที่คุณต้องการย้าย และจากนั้น คลิก ตัด.
    3. ในบานหน้าต่างนำทาง ขยาย คอมพิวเตอร์สถานที่ที่คุณต้องการจัดเก็บโฟลเดอร์การค้นหา และจากนั้น วางโฟลเดอร์ในตำแหน่งที่ตั้ง
    4. คลิกขวาที่โฟลเดอร์ที่คุณย้ายไปยังตำแหน่งใหม่ และจากนั้น คลิก คัดลอก.
    5. คลิก เริ่มคลิกชื่อผู้ใช้ของคุณ คลิกขวาที่พื้นที่ว่างในโฟลเดอร์ และจากนั้น คลิก วางทางลัด.

      หมายเหตุ เมื่อต้องการเก็บโฟลเดอร์ไว้ในตำแหน่งที่ตั้งอื่นที่ไม่ใช่โฟลเดอร์ในโปรไฟล์ผู้ใช้ของคุณ คุณอาจต้องการสร้างโฟลเดอร์ใหม่ เมื่อต้องการทำเช่นนี้ เรียกดูไปยังรากของไดรฟ์ใน Windows Explorer คลิก โฟลเดอร์ใหม่ บนแถบเมนูใน Windows Explorer และชื่อโฟลเดอร์ที่แก้ไขแล้ว ตัวอย่างเช่น เปลี่ยนชื่อโฟลเดอร์ "MyLibraries"

สถานการณ์สมมติ 2 การแก้ปัญหา

คุณสามารถละเว้นข้อความแสดงข้อผิดพลาดนี้

อย่างไรก็ตาม คุณยังสามารถใช้หนึ่งในวิธีต่อไปนี้เพื่อตัดข้อความแสดงข้อผิดพลาดนี้ในระหว่างการดำเนินการสำรองข้อมูลในอนาคต:
  • สร้างที่หายไป LocalLow ผู้ติดต่อ และค้นหาโฟลเดอร์ที่ระบุอยู่ในข้อความแสดงข้อผิดพลาด
  • ไม่รวมโฟลเดอร์จากแฟ้มสำรองข้อมูลในการตั้งค่าการสำรองข้อมูล และการรวมโฟลเดอร์เหล่านั้นไว้ในตำแหน่งที่ตั้งเดิมแล้ว เมื่อต้องการแยกโฟลเดอร์ในตำแหน่งที่ตั้งเพิ่มเติม และเมื่อต้องการรวมโฟลเดอร์เหล่านั้นไว้ในตำแหน่งที่ตั้งเดิม ให้ทำตามขั้นตอนเหล่านี้:
    1. ใน'แผงควบคุม'เปิด การสำรองข้อมูลและคืนค่า.
    2. ในการการสำรองข้อมูล ส่วน คลิก เปลี่ยนการตั้งค่า.
    3. ในการ ตั้งค่าการสำรองข้อมูล กล่องโต้ตอบ คลิก ถัดไป.
    4. ในการ คุณต้องการสำรอง กล่องโต้ตอบ คลิก ให้ฉันเลือกแล้ว คลิก ถัดไป.
    5. ขยาย แฟ้มข้อมูลขยาย <your user="" name=""></your> ไลบรารีขยาย ตำแหน่งที่ตั้งเพิ่มเติมและจากนั้น คลิกเพื่อยกเลิกการ โฟลเดอร์ด้วย AppData, ผู้ติดต่อและ การค้นหากล่องกาเครื่องหมาย
    6. ขยาย คอมพิวเตอร์ขยายรายการสำหรับไดรฟ์ระบบของคุณ (ตัวอย่างเช่น ขยาย ดิสก์ภายในเครื่อง (c:)), ขยาย ผู้ใช้ขยาย<your user="" name=""></your>และจากนั้น คลิกเลือก ด้วย AppData, ผู้ติดต่อและ การค้นหากล่องกาเครื่องหมายถ้ามีอยู่
    7. คลิกถัดไปแล้ว คลิก บันทึกการตั้งค่า และจบการทำงาน.
    8. ในการสำรองข้อมูลและคืนค่า คลิก สำรองข้อมูลเดี๋ยวนี้ เมื่อต้องการทำการสำรองข้อมูลใหม่ การสำรองข้อมูลควรดำเนินการให้เสร็จสมบูรณ์ โดยไม่มีข้อผิดพลาด

การแก้ปัญหาสถานการณ์สมมติ 3

สำหรับข้อมูลเกี่ยวกับวิธีการแก้ไขปัญหานี้ ดูบทความฐานความรู้ของ Microsoft ต่อไปนี้:
976972 คุณพบปัญหาเมื่อคุณย้ายข้อมูลผ่าน USB จาก Windows 7 หรือคอมพิวเตอร์ที่ใช้ Windows Server 2008 R2 ที่มีชิปเซ็ต NVIDIA USB EHCI มี RAM น้อย 4GB

คุณสมบัติ

หมายเลขบทความ (Article ID): 979281 - รีวิวครั้งสุดท้าย: 29 เมษายน 2556 - Revision: 6.0
ใช้กับ
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
Keywords: 
kbtshoot kbexpertisebeginner kbsurveynew kbprb kbmt KB979281 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:979281

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com