Windows PE 2.1 tarda mucho tiempo para iniciar desde una unidad de disco duro ATAPI

Seleccione idioma Seleccione idioma
Id. de artículo: 979308 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tiene un disco de duro Advanced Technology Attachment ATAPI (interfaz de paquetes). Por ejemplo, tener una unidad extraíble DELL PowerVault RD1000. El disco duro puede trabajar en modo de transferencia de Ultra Direct Memory Access (UDMA) de alta velocidad. Cuando inicia el equipo en el entorno de preinstalación de Microsoft Windows (Windows PE) en 2.1 desde el disco duro, Windows PE 2.1 tarda mucho tiempo para iniciar. Además, experimenta un rendimiento lento en el disco duro después de que haya iniciado Windows PE 2.1.

Causa

Este problema se produce porque el disco de duro ATAPI se identifica incorrectamente en Windows PE 2.1. Esto hace que el disco duro para trabajar en el modo de transferencia de programado entrada y salida (PIO) modo 1.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe estar ejecutando uno de los sistemas operativos siguientes:
Nota Se trata de los sistemas operativos en el que puede instalar el Kit de instalación automatizada de Windows (Windows AIK).
  • Windows XP Service Pack 2 (SP2) con la revisión 926044
  • Windows XP Service Pack 3 (SP3)
  • Pack 1 (SP1) de Windows Server 2003 con revisión 926044
  • Windows Server 2003 Service Pack 2 (SP2)
  • Windows Vista Service Pack 1 (SP1)
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)
Para obtener más información acerca de cómo obtener service pack de Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP
Para obtener más información acerca de la revisión 926044, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
926044Cuando utiliza Windows Server 2003 o Windows XP para modificar una sección del registro de Windows Vista, se quitan los indicadores claves de Windows Vista del registro
Para obtener más información acerca de cómo obtener un service pack de Windows Server 2003, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100Cómo obtener la versión más reciente del Service Pack para Windows Server 2003
Para obtener más información acerca de cómo obtener service pack de Windows Vista, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista
Para obtener más información acerca de cómo obtener un service pack de Windows Server 2008, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
968849Cómo obtener el service pack más reciente para Windows Server 2008

Instrucciones de instalación

Debe aplicar esta revisión a la imagen de Windows PE 2.1 que usas para iniciar el equipo. Para aplicar esta revisión a la imagen de Windows PE 2.1, siga estos pasos:
  1. Instale Windows AIK.
    Para obtener Windows AIK, visite el siguiente sitio Web de Microsoft: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=94bb6e34-d890-4932-81a5-5b50c657de08
  2. Descargar el paquete de revisiones y, a continuación, extraiga los archivos del paquete de la revisión a una carpeta temporal. Para ello, siga estos pasos:
    1. Haga doble clic en el paquete de hotfix.
    2. En el cuadro de diálogo Self-Extract Microsoft, haga clic en continuar.
    3. Especificar una carpeta temporal y, a continuación, haga clic en Aceptar.
    4. Abra una ventana del símbolo.
      Nota Para abrir una ventana del símbolo del sistema en Windows Vista o en Windows Server 2008, haga clic en el botón de Windows, escriba cmd en el cuadro Buscar, haga clic con el botón secundario del mouse en cmd y, a continuación, haga clic en Ejecutar como administrador.
      Para abrir una ventana del símbolo del sistema en Windows XP o en Windows Server 2003, haga clic en Inicio, haga clic en Ejecutar, escriba cmd y, a continuación, haga clic en Aceptar.
    5. En el símbolo del sistema, ejecute el siguiente comando:
      Expand -f:* <TempFolder>\Windows6.0-KB979308-<Platform>.msu <TempFolder>
      Nota<TempFolder> representa la carpeta temporal que especifica en el paso 2c.
    6. En el símbolo del sistema, ejecute el siguiente comando:
      Expand -f:* <TempFolder>\Windows6.0-KB979308-<Platform>.cab <TempFolder>
  3. Agregar los archivos de la revisión a la imagen de Windows PE 2.1. Para ello, siga estos pasos:
    1. Cree otra carpeta temporal para almacenar la imagen de Windows PE 2.1. Suponga que la carpeta temporal es C:\Winpe.
    2. Copie la imagen de Windows PE 2.1 que usas para iniciar el equipo a la carpeta C:\Winpe.
    3. Cree una carpeta de montaje en la carpeta C:\Winpe.
    4. Abra una ventana de símbolo del sistema de las herramientas de Windows PE.
      Nota Para abrir una ventana de símbolo del sistema de las herramientas de Windows PE en Windows Vista o en Windows Server 2008, haga clic en el botón de Windows, seleccione Todos los programas, haga clic en Microsoft Windows AIK, haga clic con el botón secundario del mouse en símbolo del sistema de las herramientas de Windows PE y, a continuación, haga clic en Ejecutar como administrador.
      Para abrir una ventana de símbolo del sistema de las herramientas de Windows PE en Windows XP o en Windows Server 2003, haga clic en Inicio, seleccione Todos los programas, haga clic en Microsoft Windows AIK y, a continuación, haga clic en símbolo del sistema de las herramientas de Windows PE.
    5. En la ventana de símbolo del sistema de las herramientas de Windows PE, ejecute el siguiente comando para montar la imagen de Windows PE 2.1:
      imagex /mountrw C:\WinPE\winpe.wim 1 C:\WinPE\Mount
    6. Copie todos los archivos en el <TempFolder> \ <Platform> _mshdc.inf_31bf3856ad364e35_6.0.6001.22608_none_ <ID> carpeta a la carpeta C:\WinPE\Mount\Windows.
      Nota<ID> representa una serie de caracteres que varía en función de las plataformas.
    7. En la ventana de símbolo del sistema de las herramientas de Windows PE, ejecute el comando siguiente para confirmar los cambios en la imagen de Windows PE 2.1:
      imagex /unmount C:\WinPE\Mount /commit
  4. Utilice la imagen de Windows PE 2.1 actualizada para iniciar el equipo.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a una revisión lanzada anteriormente.

Información de archivo

La versión global de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Las fechas y horas de estos archivos en el equipo local se muestran en su hora local junto con su actual (DST) horario de verano. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Para la versión x 86 de Windows PE 2.1
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Aliide.sys1.2.0.014,21619-Ene-201022: 39x 86
Amdide.sys6.0.6001.2260814,72019-Ene-201022: 39x 86
ATAPI.sys6.0.6001.2260820,86419-Ene-201022: 39x 86
Ataport.sys6.0.6001.22608107,39219-Ene-201022: 39x 86
Cmdide.sys2.0.7.015,74419-Ene-201022: 39x 86
Intelide.sys6.0.6001.2260814,72019-Ene-201022: 40x 86
Msahci.sys6.0.6001.2260825,47219-Ene-201022: 40x 86
Mshdc.infNo aplicable47,45819-Ene-201017: 08No aplicable
Pciide.sys6.0.6001.2260813,19219-Ene-201022: 40x 86
Pciidex.sys6.0.6001.2260841,85619-Ene-201022: 40x 86
Viaide.sys5.1.3790.15016,77619-Ene-201022: 40x 86
Para la versión x 64 compatibles de Windows PE 2.1
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Aliide.sys1.2.0.015,24019-Ene-201023: 07x 64
Amdide.sys6.0.6001.2260815,24019-Ene-201023: 07x 64
ATAPI.sys6.0.6001.2260823,43219-Ene-201023: 07x 64
Ataport.sys6.0.6001.22608121,73619-Ene-201023: 07x 64
Cmdide.sys2.0.7.017,28819-Ene-201023: 07x 64
Intelide.sys6.0.6001.2260816,26419-Ene-201023: 07x 64
Msahci.sys6.0.6001.2260828,04019-Ene-201023: 07x 64
Mshdc.infNo aplicable47,61819-Ene-201008: 23No aplicable
Pciide.sys6.0.6001.2260813,19219-Ene-201023: 07x 64
Pciidex.sys6.0.6001.2260848,00819-Ene-201023: 07x 64
Viaide.sys5.1.3790.15017,28819-Ene-201023: 07x 64
Para la versión basadas en IA-64 de Windows PE 2.1
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Aliide.sys1.2.0.018,81620-Ene-201001: 56IA-64
ATAPI.sys6.0.6001.2260844,42420-Ene-201001: 56IA-64
Ataport.sys6.0.6001.22608305,54420-Ene-201001: 56IA-64
Cmdide.sys2.0.7.026,50420-Ene-201001: 56IA-64
Intelide.sys6.0.6001.2260820,86420-Ene-201001: 56IA-64
Msahci.sys6.0.6001.2260859,77620-Ene-201001: 56IA-64
Mshdc.infNo aplicable45,12619-Ene-201008: 15No aplicable
Pciide.sys6.0.6001.2260818,30420-Ene-201001: 56IA-64
Pciidex.sys6.0.6001.22608108,41620-Ene-201001: 56IA-64
Viaide.sys5.1.3790.15028,03220-Ene-201001: 56IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 979308 - Última revisión: viernes, 12 de febrero de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Preinstall Environment (WinPE) 32-bit
  • Microsoft Windows Preinstall Environment (WinPE) 64-bit
Palabras clave: 
kbmt kbautohotfix kbfix kbqfe kbexpertiseadvanced kbsurveynew kbhotfixserver KB979308 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 979308

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com