Die Spalte Windows-Betriebssystem weist den Status Nicht überwacht für einen neuen Operations Manager-Agent auf.

In diesem Artikel können Sie ein Problem umgehen, bei dem die Spalte Windows-Betriebssystem den Status Nicht überwacht aufweist, nachdem Sie einen Agent gelöscht und dann einen neuen Agent mit demselben NetBIOS-Namen in Operations Manager erstellt haben.

Ursprüngliche Produktversion: Microsoft System Center 2012 Operations Manager
Ursprüngliche KB-Nummer: 979387

Symptome

In der Operations Manager-Konsole von System Center Operations Manager weist die Spalte Windows-Betriebssystem möglicherweise den Status Nicht überwacht für einen neuen Client-Agent auf. Darüber hinaus ändert sich der Zustand nie in Fehlerfrei.

Ursache

Dieses Problem kann auftreten, weil der neue Agent denselben NetBIOS-Namen wie ein zuvor installierter Agent hat. Wenn der Agent aus Operations Manager gelöscht wird, ist die Bereinigung des gelöschten Agents hartcodiert und erfolgt nach zwei Tagen. Daher wird der Agent nicht sofort vollständig aus der Datenbank entfernt.

Problemumgehung

Um dieses Problem zu umgehen, nachdem der alte Agent aus der Konsole gelöscht wurde, warten Sie drei Tage, und fügen Sie dann den neuen Agent zu Operations Manager hinzu. Stellen Sie alternativ sicher, dass zwei vollständige Tage vergangen sind, und fügen Sie dann den neuen Agent zu Operations Manager hinzu.

Weitere Informationen

Wenn die Daten aus dem alten NetBIOS-Namen nicht aus der Datenbank entfernt werden (z. B. aus den Überwachungsdaten oder dem Statusänderungsverlauf), verwendet Operations Manager den NetBIOS-Namen, um die Datenbank nach einigen dieser Informationen zu durchsuchen.

Ein Nebeneffekt ist, dass die Ermittlungsdaten für den neuen Agent und der Zustand der ermittelten Objekte mit dem instance des alten NetBIOS-Namens verknüpft sind. Daher ist der Status des neuen Agents falsch, und die Spalte Windows-Betriebssystem der Operations Manager-Konsole hat möglicherweise den Status Nicht überwacht für einen neuen Agent.