La columna Sistema operativo Windows tiene un estado No supervisado para un nuevo agente de Operations Manager

Este artículo le ayuda a solucionar un problema en el que la columna Sistema operativo Windows tiene un estado No supervisado después de eliminar un agente y, a continuación, crear un nuevo agente que tenga el mismo nombre netBIOS en Operations Manager.

Versión original del producto: Microsoft System Center 2012 Operations Manager
Número de KB original: 979387

Síntomas

En la consola de Operations Manager de System Center Operations Manager, la columna Sistema operativo Windows puede tener un estado No supervisado para un nuevo agente cliente. Además, el estado nunca cambia a Correcto.

Causa

Este problema puede producirse porque el nuevo agente tiene el mismo nombre de NetBIOS que un agente instalado anteriormente. Cuando el agente se elimina de Operations Manager, el aseo del agente eliminado se codifica de forma rígida para que se produzca después de dos días. Por lo tanto, el agente no se limpia inmediatamente de la base de datos por completo.

Solución alternativa

Para solucionar este problema después de eliminar el agente anterior de la consola, espere tres días y agregue el nuevo agente a Operations Manager. Como alternativa, asegúrese de que han pasado dos días completos y, a continuación, agregue el nuevo agente a Operations Manager.

Más información

Si los datos del nombre netBIOS antiguo no se limpian fuera de la base de datos (por ejemplo, de los datos de supervisión o del historial de cambios de estado), Operations Manager usa el nombre NetBIOS para buscar parte de esta información en la base de datos.

Un efecto secundario es que los datos de detección del nuevo agente y el estado de los objetos detectados están vinculados a la instancia del nombre de NetBIOS antiguo. Por lo tanto, el estado del nuevo agente es incorrecto y la columna Sistema operativo Windows de la consola de Operations Manager puede tener un estado No supervisado para un nuevo agente.