La colonna Sistema operativo Windows ha uno stato Non monitorato per un nuovo agente di Operations Manager

Questo articolo consente di risolvere un problema in cui la colonna Sistema operativo Windows ha uno stato Non monitorato dopo aver eliminato un agente e quindi creato un nuovo agente con lo stesso nome NetBIOS in Operations Manager.

Versione originale del prodotto: Microsoft System Center 2012 Operations Manager
Numero KB originale: 979387

Sintomi

Nella console di Operations Manager di System Center Operations Manager, la colonna Sistema operativo Windows potrebbe avere uno stato Non monitorato per un nuovo agente client. Inoltre, lo stato non passa mai a Integro.

Causa

Questo problema può verificarsi perché il nuovo agente ha lo stesso nome NetBIOS di un agente installato in precedenza. Quando l'agente viene eliminato da Operations Manager, la pulitura dell'agente eliminato è hardcoded da eseguire dopo due giorni. Pertanto, l'agente non viene immediatamente estratto completamente dal database.

Soluzione alternativa

Per risolvere questo problema dopo l'eliminazione dell'agente precedente dalla console, attendere tre giorni e quindi aggiungere il nuovo agente a Operations Manager. In alternativa, assicurarsi che siano trascorsi due giorni completi e quindi aggiungere il nuovo agente a Operations Manager.

Ulteriori informazioni

Se i dati del nome NetBIOS precedente non vengono estratti dal database, ad esempio dai dati di monitoraggio o dalla cronologia delle modifiche dello stato, Operations Manager usa il nome NetBIOS per cercare alcune di queste informazioni nel database.

Un effetto collaterale è che i dati di individuazione per il nuovo agente e lo stato degli oggetti individuati sono collegati all'istanza del nome NetBIOS precedente. Di conseguenza, lo stato del nuovo agente non è corretto e la colonna Sistema operativo Windows della console di Operations Manager potrebbe avere uno stato Non monitorato per un nuovo agente.