FIX: You cannot deploy a BizTalk Server application in Visual Studio when the Restart Host Instances property is set to True

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Article ID: 979438 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Microsoft BizTalk Server 2006 R2 or BizTalk Server 2009, you create a BizTalk Server project in Microsoft Visual Studio.
  • You set the Restart Host Instances property to True in the project Deployment properties.
  • You try to deploy the BizTalk Server application from Microsoft Visual Studio.
In this scenario, the deployment takes a very long time. Additionally, the following events are logged in the System log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7011
Description: Timeout (30000 milliseconds) waiting for a transaction response from the service.

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7011
Description: Timeout (30000 milliseconds) waiting for a transaction response from the BTSSvc$BizTalkServerApplication service.

Notes
  • When the Restart Host Instances property is set to False, the deployment occurs immediately.
  • This issue also occurs in Microsoft BizTalk Server 2009.

CAUSE

The issue occurs because of a deadlock situation. The deadlock occurs when the deployment transaction reads data from the BizTalkMgmtDb database while the data is being updated.

RESOLUTION

Cumulative update information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009. 

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base: 

2429050 Cumulative update package 1 for BizTalk Server 2009

Hotfix information

For BizTalk Server 2006 R2

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Microsoft.biztalk.deployment.dll3.6.1559.2341,88004-Feb-201015:56x86

For BizTalk Server 2006 R2 SP1


The hotfix that resolves this problem is included in cumulative update package 1 for BizTalk Server 2006 R2 SP1.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
982061 Cumulative update package 1 for BizTalk Server 2006 R2 Service Pack 1

For more information about BizTalk Server 2006 R2 SP1 hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
974563 List of Microsoft BizTalk Server hot fixes that are included in BizTalk Server 2006 R2 Service Pack 1

WORKAROUND

To work around this issue, use one of the following methods:

Method 1

In Visual Studio, set the Restart Host Instances deployment property to False.

Method 2

Start and then stop the host instance by using the BizTalk Administration console.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce this problem

To reproduce this problem on a 64-bit-based computer that has BizTalk Server and Visual Studio installed, follow these steps:
  1. Create a new host instance in the BizTalk Administration console.
  2. In Visual Studio, create a BizTalk project that has an orchestration that uses a FILE receive port and a FILE send port.
  3. Set the Restart Host Instance property to True in the BizTalk Server project properties in Visual Studio.
  4. Deploy the project.
For more information about how to deploy a basic BizTalk application, visit the following Microsoft Developer Network (MSDN) Web site:
Deploying a basic BizTalk application
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information on BizTalk Server hot fixes

Properties

Article ID: 979438 - Last Review: December 8, 2010 - Revision: 3.0
APPLIES TO
  • Microsoft BizTalk Server 2006 R2 Branch Edition
  • Microsoft BizTalk Server 2006 R2 Developer Edition
  • Microsoft BizTalk Server 2006 R2 Enterprise Edition
  • Microsoft BizTalk Server 2006 R2 Standard Edition
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbexpertiseadvanced kbautohotfix kbbiztalk2006r2presp2fix kbsurveynew kbqfe kbbiztalk2009presp1fix KB979438

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