Update: Bereitstellen der BizTalk Server-Anwendung in Visual Studio sind beim Neustart Hostinstanzen-Eigenschaft auf True gesetzt ist

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 979438 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

Stellen Sie sich das folgende Szenario vor:
  • Auf einem Computer, auf dem Microsoft BizTalk Server 2006 R2 oder BizTalk Server 2009 ausgeführt wird, erstellen Sie eine BizTalk Server-Projekt in Microsoft Visual Studio.
  • Legen Sie dieNeustart Hostinstanzen-EigenschaftTrueim ProjektBereitstellungEigenschaften.
  • Sie versuchen, die BizTalk Server-Anwendung von Microsoft Visual Studio bereitstellen.
In diesem Fall die Bereitstellung sehr lange dauert. Darüber hinaus werden die folgenden Ereignisse im Systemprotokoll protokolliert:

Ereignistyp: Fehler
Ereignis Quelle: Dienststeuerungs-Manager
Ereigniskategorie: Keine
Ereignis-ID: 7011
Beschreibung: Timeout (30000 ms) warten auf eine Transaktionsrückmeldung von dem Dienst.

Ereignistyp: Fehler
Quelle: Dienststeuerungs-Manager
Ereigniskategorie: Keine
Ereignis-ID: 7011
Beschreibung: Timeout (30000 ms) warten auf eine Transaktionsrückmeldung von BTSSvc $ BizTalkServerApplication-Dienst.

Hinweise
  • Wenn das KontrollkästchenNeustart Hostinstanzen-EigenschaftFalse, die Bereitstellung sofort erfolgt.
  • Dieses Problem tritt auch in Microsoft BizTalk Server 2009.

Ursache

Das Problem tritt aufgrund einer Deadlocksituation. Der Deadlock tritt auf, wenn die Bereitstellung Transaktion liest Daten aus der Datenbank BizTalkMgmtDb, während die Daten aktualisiert wird.

Lösung

Kumulatives Update-Informationen

Für BizTalk Server 2009 ist der Hotfix, der dieses Problem behebt im kumulativen Update 1 für BizTalk Server 2009 enthalten.

Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken Sie auf die folgende KB-Artikelnummer:

2429050Kumulatives Updatepaket 1 für BizTalk Server 2009

Hotfix-Informationen

Für BizTalk Server 2006 R2

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur das Problem zu beheben, das in diesem Artikel beschriebene vorgesehen.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download verfügbar" am Anfang dieses Knowledge Base-Artikels. Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft Customer Service und Support, um den Hotfix zu erhalten.

Hinweis:Falls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für weitere Fragen und Problemen, die für diesen bestimmten Hotfix nicht qualifizieren. Eine vollständige Liste der technischen Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf der folgenden Microsoft-Website:
http://support.Microsoft.com/contactus/?ws=Support
Hinweis:Das Formular "Hotfix Download verfügbar" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Sie müssen BizTalk Server 2006 R2 installiert haben, um diesen Hotfix anwenden können.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keine anderen Hotfixes.

Dateiinformationen

Die englische Version dieses Updates besitzt die Dateiattribute (oder höher Dateiattribute), die in der folgenden Tabelle aufgelistet werden. Die Datums- und Uhrzeitangaben für diese Dateien sind aufgelistet in koordinierter Weltzeit (UTC). Wenn Sie sich die Dateiinformationen ansehen, werden diese Angaben in die lokale Zeit konvertiert. Um die Differenz zwischen UTC und der Ortszeit zu ermitteln, verwenden dieDie ZeitzoneRegisterkarte derDatum und UhrzeitElement in Control Panel.
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Microsoft.BizTalk.Deployment.dll3.6.1559.2341,88004-Feb 201015: 56X 86

Für BizTalk Server 2006 R2 SP1


Der Hotfix, der dieses Problem behebt, ist im Kumulatives Updatepaket 1 für BizTalk Server 2006 R2 SP1 enthalten.

Weitere Informationen dazu, wie Sie das kumulative Updatepaket zu erhalten, klicken Sie auf die folgende KB-Artikelnummer:
982061Kumulatives Updatepaket 1 für BizTalk Server 2006 R2 Service Pack 1

Weitere Informationen zu BizTalk Server 2006 R2 SP1-Hotfixes klicken Sie auf die folgende KB-Artikelnummer:
974563Liste von Microsoft BizTalk Server-Hotfixes, die in BizTalk Server 2006 R2 Service Pack 1 enthalten sind

Abhilfe

Wenden Sie eines der folgenden Verfahren an, um dieses Problem zu umgehen:

Methode 1

Legen Sie in Visual Studio denNeustart HostinstanzenBereitstellung-EigenschaftFalse.

Methode 2

Starten und beenden Sie die Hostinstanz mithilfe den BizTalk-Verwaltungskonsole.

Status

Microsoft hat bestätigt, dass es sich um ein Problem bei den Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Schritte zum Reproduzieren des Problems

Um dieses Problem auf einem Computer mit 64-Bit-basierte reproduzieren, der BizTalk-Server und Visual Studio installiert ist, gehen Sie folgendermaßen vor:
  1. Erstellen Sie eine neue Hostinstanz der in der BizTalk-Verwaltung Konsole.
  2. Erstellen Sie in Visual Studio ein BizTalk-Projekt verfügt über eine Orchestrierung, verwendet eine Datei Empfangsport und eine Datei senden, Port.
  3. Legen Sie dieStarten der Hostinstanz-EigenschaftTruein der BizTalk Server-Projekt Eigenschaften in Visual Studio.
  4. Bereitstellen des Projekts.
Weitere Informationen zur Bereitstellung der grundlegenden BizTalk-Anwendung finden Sie auf folgender Website von Microsoft Developer Network (MSDN):
Bereitstellen einer grundlegenden BizTalk-Anwendung
Weitere Informationen zu BizTalk Server-Hotfixes klicken Sie auf die folgende KB-Artikelnummer:
2003907Informationen zur BizTalk Server-Hotfixes

Eigenschaften

Artikel-ID: 979438 - Geändert am: Mittwoch, 8. Dezember 2010 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
Keywords: 
kbexpertiseadvanced kbautohotfix kbbiztalk2006r2presp2fix kbsurveynew kbqfe kbbiztalk2009presp1fix kbmt KB979438 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 979438
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com