FIX: をホスト インスタンスの再起動のプロパティを True に設定すると、Visual Studio では、BizTalk Server アプリケーション展開できません。

文書翻訳 文書翻訳
文書番号: 979438
すべて展開する | すべて折りたたむ

目次

現象

以下のシナリオを考えます。:
  • Microsoft BizTalk Server 2006 R2 または BizTalk Server 2009 を実行しているコンピューターでは、Microsoft Visual Studio では、BizTalk Server プロジェクトを作成します。
  • 設定は、ホスト インスタンスを再起動します。プロパティにTrue を指定プロジェクト内展開プロパティ。
  • Microsoft Visual Studio から BizTalk Server アプリケーションを展開しようとしました。
このシナリオでは、展開が非常に時間がかかります。 さらに、次のイベントがシステム ログに記録されます。

イベントの種類: エラー
イベント ソース: サービス コントロール マネージャー
分類 : None
イベント ID: 7011
説明: タイムアウト (30000 ミリ秒) をサービスからのトランザクション応答の待機します。

イベントの種類: エラー
イベント ソース: サービス コントロール マネージャー
分類 : None
イベント ID: 7011
説明: タイムアウト (30000 ミリ秒) に BTSSvc $ BizTalkServerApplication サービスからのトランザクション応答の待機します。

メモ
  • 場合は、ホスト インスタンスを再起動します。プロパティを設定するのにはFalse を指定します。、展開直後に発生します。
  • この問題は Microsoft BizTalk Server 2009 年にも発生します。

原因

問題は、デッドロックのために発生します。 デッドロックは、データの更新中に、展開のトランザクション データ、BizTalkMgmtDb データベースから読み取るときに発生します。

解決方法

累積的な更新プログラムの情報

BizTalk Server 2009 年には、この問題を解決する修正プログラムは累積的な更新プログラム 1 を BizTalk Server 2009 含まれています。

累積的な更新プログラム パッケージを取得し、マイクロソフト サポート技術資料を参照するのには、次の文書番号をクリックする方法の詳細については。

2429050BizTalk Server 2009 の累積的な更新プログラム パッケージ 1

修正プログラムについて

BizTalk Server 2006 R2

マイクロソフトでは、この問題を修正する修正プログラムを提供しています。。 ただし、この修正プログラムは、この資料に記載されている問題のみを修正するものです。

修正プログラムをダウンロードできる場合は、このサポート技術情報の上部に "修正プログラムのダウンロード" セクションが表示されています。。 このセクションが表示されていない場合は、マイクロソフト カスタマー サービス & サポートに問い合わせ、修正プログラムを入手します。。

注意: 未解決のインポート要求があるため、処理チェックは延期されました。別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。。 特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。。 マイクロソフト カスタマー サービス & サポートの電話番号一覧を参照する、または別のサービス リクエストを作成するには、次のマイクロソフト Web サイトを参照してください。:
http://support.microsoft.com/contactus/?ws=support
注意: 未解決のインポート要求があるため、処理チェックは延期されました。"修正プログラムのダウンロード" セクションは、修正プログラムが提供されている言語で表示されます。。 使用している言語で表示されない場合、その言語では修正プログラムは提供されていません。。

前提条件

BizTalk Server 2006 R2 のこの修正プログラムを適用するのにはインストールされている必要があります。

再起動の要件

この修正プログラムを適用した後、コンピューターを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムは、他の修正プログラムはしていません。

ファイル情報

この修正プログラムの英語版のファイル属性は次の表のとおりです。。 日付および時刻これらのファイルを世界協定時刻で表示されます (UTC)。 各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。。 UTC とローカル時刻との時差を確認するには、使用して、タイム ゾーンタブで、Date and Timeアイテム コントロールのパネル。
元に戻す全体を表示する
ファイル名ファイルのバージョンファイル サイズ日付:時間プラットフォーム
Microsoft.biztalk.deployment.dll3.6.1559.2341,88004-2 月 2 日-201015: 56x86

BizTalk Server 2006 R2 SP1 用


BizTalk Server 2006 R2 SP1 用の累積的な更新プログラム パッケージ 1 では、この問題を解決する修正プログラムが含まれています。

累積的な更新プログラム パッケージを取得し、マイクロソフト サポート技術資料を参照するのには、次の文書番号をクリックする方法の詳細については。
982061BizTalk Server 2006 R2 の Service Pack 1 用の累積的な更新プログラム パッケージ 1

BizTalk Server 2006 R2 SP1 の修正プログラムの詳細については、マイクロソフト サポート技術資料を参照するのには、次の資料番号をクリックします。
974563BizTalk Server 2006 R2 Service Pack 1 に含まれている Microsoft BizTalk Server ホット フィックスの一覧

回避策

この問題を解決するには、次のいずれかの方法を実行します。:

方法 1

Visual Studio では、設定、ホスト インスタンスを再起動します。展開プロパティFalse を指定します。.

方法 2

起動し、BizTalk を使用して、ホスト インスタンスを停止、管理コンソール。

状況

マイクロソフトでは、「以下の製品について」の項目に記載されているマイクロソフト製品の問題であることを確認しています。。

詳細

この問題の再現手順

BizTalk Server と Visual Studio が 64 ビット ベースのコンピューターでこの問題を再現するのにはインストールされている、次の手順を実行します。
  1. 新しいホスト インスタンスは、BizTalk 管理コンソールで作成コンソール。
  2. Visual Studio では、受信ポートのファイルを使用し、FILE 送信ポートをオーケストレーションを持つ BizTalk プロジェクトを作成します。
  3. 設定は、ホスト インスタンスを再起動します。プロパティにTrue を指定BizTalk Server でプロジェクトに Visual Studio のプロパティ。
  4. プロジェクトを展開します。
基本は、BizTalk の展開方法の詳細についてはアプリケーションは、次のマイクロソフトの開発者ネットワーク (MSDN) Web サイトを参照してください。
基本的な BizTalk アプリケーションを展開します。
BizTalk Server の修正プログラムの詳細については、マイクロソフト サポート技術資料を参照するのには、次の資料番号をクリックします。
2003907BizTalk Server の修正について

プロパティ

文書番号: 979438 - 最終更新日: 2010年12月8日 - リビジョン: 2.0
キーワード:?
kbqfe kbexpertiseadvanced kbhotfixserver kbautohotfix kbmt kbsurveynew kbbiztalk2009presp1fix kbbiztalk2006r2presp2fix KB979438 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:979438
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com