Ein Windows Server 2003-basierten terminal-Server reagiert nach viele Benutzer an ihn, und melden Sie sich Anmelden Abmelden daraus

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Artikel-ID: 979522 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Sie müssen einen Terminalserver, auf dem Windows Server 2003 ausgeführt wird. Viele Benutzer anmelden oder Abmelden vom Terminalserver häufig. Nach einiger Zeit der Terminalserver ausgeführt wird, reagiert der gesamte Terminalserver. Sie können nicht aus diesem Grund eine terminal Server-Sitzung zum Terminalserver nicht mehr erstellen. Darüber hinaus wird möglicherweise das folgende Ereignis im Systemprotokoll protokolliert.

Ereignistyp: Fehler
Quelle: SRV
Ereigniskategorie: Keine
Ereignis-ID: 2020
Beschreibung: Der Server konnte nicht ausgelagerten Poolspeicher reservieren, da der Pool leer war.

Wenn Sie die Speicherabbilddatei, die aufgezeichnet wird analysieren, wenn das Problem auftritt, werden Sie feststellen, dass die ausgelagerten Pool Ressource erschöpft ist. Sie finden Sie außerdem, dass ein Großteil der ausgelagerte Pool wird von der Speicherpool, der das Tag "DrDr" verwendet.

Ursache

Dieses Problem tritt aufgrund eines ein Zeitsteuerungsproblem in den Microsoft Remote Desktop Protocol (RDP) Geräte-Redirector (Rdpdr.sys). Wenn das Timing-Problem auftritt, wird ein e/a-Anforderungspaket (IRP) nicht richtig vom Treiber Rdpdr.sys abgebrochen. Dieses Verhalten hat zur Folge, dass einige reservierten Speicher des ausgelagerten Pools, die nicht freigegeben werden sollen. Die Ressource für ausgelagerte Pool ist nach einer Weile erschöpft. Daher kommt es zu das Szenario, das im Abschnitt "Problembeschreibung" erwähnt wird.

Lösung

Hotfix-Informationen

Ein unterstützter Hotfix ist von Microsoft erhältlich. Der Hotfix ist jedoch nur zur Behebung des Problems, die in diesem Artikel beschriebene vorgesehen. Installieren Sie diesen Hotfix nur auf Systemen, bei die das in diesem Artikel beschriebene Problem auftritt. Dieser Hotfix wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfehlen wir, auf das nächste Softwareupdate zu warten, das diesen Hotfix enthält.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfix Download available (Hotfixdownload verfügbar", am Anfang dieses Knowledge Base-Artikels. Wenn in diesem Abschnitt nicht angezeigt wird, wenden Sie sich an Microsoft-Kundendienst und Support, um den Hotfix zu erhalten.

Hinweis: Wenn weitere Probleme auftreten oder wenn eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Normale Servicegebühren werden jedoch für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf folgender Website von Microsoft:
http://support.microsoft.com/contactus/?ws=support
Hinweis: Das Formular "Hotfix Download available (Hotfixdownload verfügbar" zeigt die Sprachen für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist ein Hotfix nicht für diese Sprache zur Verfügung steht.

Voraussetzungen:

Um diesen Hotfix anwenden zu können, müssen Sie Windows Server 2003 Service Pack 2 (SP2) auf Ihrem Computer ausgeführt werden.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix installiert haben.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfixes.

Dateiinformationen

Die globale (USA) Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datums- und Uhrzeitangaben für diese Dateien werden in Coordinated Universal Time (UTC) aufgelistet. Die Datums- und Uhrzeitangaben für diese Dateien auf dem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Ihren aktuellen Zeitunterschied Sommerzeit (DST) angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf die Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2003
  • Zusätzlich zu den in diesen Tabellen aufgeführten Dateien installiert dieses Update auch zugehörige Sicherheitskatalogdatei (KB-number .cat), die signiert ist mit einer digitalen Signatur von Microsoft.
Für alle unterstützten x 86-basierten Versionen von Windows Server 2003
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdpdr.sys5.2.3790.4683201,21622-Mär-201015: 21X 86
Für alle unterstützten x 64-basierten Versionen von Windows Server 2003
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdpdr.sys5.2.3790.4683333.31223-Mär-201004: 32X 64
Für alle unterstützten IA-64-basierten Versionen von Windows Server 2003
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumUhrzeitPlattform
Rdpdr.sys5.2.3790.4683641,53623-Mär-201004: 32IA-64

Status

Microsoft hat bestätigt, dass dies ein Problem in der Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie die folgende KB-Artikelnummer:
824684Erläuterung von Standardbegriffen bei Microsoft Softwareupdates

Eigenschaften

Artikel-ID: 979522 - Geändert am: Montag, 26. April 2010 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
Keywords: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB979522 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 979522
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