Un servidor de Terminal Server basado en Windows Server 2003 deja de responder tras muchos usuarios inicien en él y de registro fuera de ella

Seleccione idioma Seleccione idioma
Id. de artículo: 979522 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Dispone de un servidor Terminal Server que ejecuta Windows Server 2003. Los usuarios inicien sesión en, muchos o inicie sesión desactivar desde la sesión de terminal server con frecuencia. Después de servicios de terminal server se ejecute durante algún tiempo, completos servicios de terminal server deja de responder. Por tanto, no puede crear una sesión de terminal server al servidor de terminal server ya. Además, el suceso siguiente puede grabarse en el registro del sistema:

Tipo de suceso: error
Origen del suceso: SRV
Categoría del suceso: ninguno
ID. de suceso: 2020
Descripción: El servidor no pudo asignar la memoria desde bloque paginado del sistema porque el bloque estaba vacío.

Si analizar el archivo de volcado de memoria que se captura cuando se produce el problema, verá que se ha agotado el recurso de grupo paginado del sistema. También, encontrará que la mayor parte de la paginada pool es utilizada por el grupo de memoria que tiene la etiqueta "DrDr".

Causa

Este problema se produce debido a un problema de temporización en el redirector de dispositivos de protocolo de escritorio remoto (RDP) de Microsoft (Rdpdr.sys). Cuando se produce el problema de sincronización, se abandona incorrectamente un paquete de solicitud de E/s (IRP) por el controlador Rdpdr.sys. Este comportamiento hace que algunos memoria asignada del bloque paginado no para ser emitidas. Después de un tiempo, se ha agotado el recurso de bloque paginado. Por lo tanto, experimenta el escenario que se menciona en la sección "Síntomas".

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe ejecutar Windows Server 2003 Service Pack 2 (SP2) en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a una revisión lanzada anteriormente.

Información de archivo

La versión global de (Estados Unidos) de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Las fechas y horas de estos archivos en el equipo local se muestran en su hora local junto con su actual (DST) horario de verano. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivo de Windows Server 2003
  • Además de los archivos que se muestran en estas tablas, esta revisión también instala un archivo de catálogo de seguridad asociado (KB number .cat) firmado con una firma digital de Microsoft.
Para todas las versiones basadas en 86 de Windows Server 2003 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdpdr.sys5.2.3790.4683201.21622-Mar-201015: 21x 86
Para todas-versiones basadas en x 64 de Windows Server 2003
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdpdr.sys5.2.3790.4683333,31223-Mar-201004: 32x 64
Para todas las versiones basadas en IA-64 de Windows Server 2003 compatibles
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdpdr.sys5.2.3790.4683641,53623-Mar-201004: 32IA-64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 979522 - Última revisión: lunes, 26 de abril de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
Palabras clave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbhotfixserver KB979522 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 979522

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com