Сервер терминалов на базе Windows Server 2003 перестает отвечать на запросы после многих вход пользователей на его и журнал Отключение от него

Переводы статьи Переводы статьи
Код статьи: 979522 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Проблема

У вас есть сервер терминалов под управлением Windows Server 2003. Многие вход пользователей на или выход из сервера терминалов часто. После запуска сервера терминалов в течение некоторого времени совершенно терминалов перестает отвечать на запросы. Таким образом не удается создать сеанс сервера терминалов к серверу терминалов больше. Кроме того в журнале системных событий регистрируется следующее событие:

Тип события: ошибка
Источник события: SRV могла
Категория события: нет
КОД события: 2020
Описание: Серверу не удалось выделить память из выгружаемого пула, поскольку пул пуст.

При анализе файла дампа памяти, захваченного при возникновении этой проблемы можно найти, будет исчерпан ресурс выгружаемого пула. Кроме того, можно найти, большинство из выгружаемого пула памяти, который имеет тег "DrDr" используется пул.

Причина

Эта проблема возникает из-за ошибки синхронизации в Перенаправитель протокола удаленного рабочего стола Microsoft (RDP) устройства (Rdpdr.sys). При возникновении ошибки синхронизации драйвером Rdpdr.sys неправильно завершается пакет запроса ввода-вывода (IRP). Это приводит к выделенной памяти выгружаемого пула не к освобождению. Через некоторое время исчерпано выгружаемого пула ресурсов. Таким образом возникают ситуации, описанное в разделе «Проблема».

Решение

Сведения об исправлении

Вам доступно исправление от корпорации Майкрософт.. Это исправление предназначено для устранения проблемы, описанной в этой статье.. Это исправление необходимо применять только в тех системах, в которых наблюдается данная проблема.. Исправление может проходить дополнительное тестирование.. Таким образом эта проблема не является постоянной для вас, мы рекомендуем дождаться следующего автоматического обновления программного обеспечения, содержащего это исправление..

Если исправление доступно для загрузки, имеется раздел «Доступные загрузки» в верхней части этой статьи базы знаний.. Если этот раздел не отображается, обратитесь в Службу поддержки клиентов Microsoft для получения исправления..

Примечание.Другие проблемы или если требуется устранить неполадки, возможно, потребуется создать отдельный запрос. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются вами дополнительно.. Полный список телефонов поддержки и обслуживания клиентов Microsoft или информацию по созданию отдельного запроса на обслуживание вы можете найти на веб-сайте Майкрософт::
http://support.microsoft.com/contactus/?ws=support
Примечание.В форме "Исправление доступно для загрузки" отображаются языки, для которых доступно исправление. Если язык не отображается, это значит, что исправление не доступно для данного языка..

Предвартельные требования

Для установки данного исправления в на вашем компьютере должна быть запущена Windows Server 2003 с пакетом обновления 2 (SP2).

Необходимость перезагрузки

После установки исправления компьютер необходимо перезагрузить..

Сведения о заменяемых исправлениях

Это исправление не заменяет ранее выпущенные исправления..

СВЕДЕНИЯ О ФАЙЛАХ

Глобальные (США) версия данного исправления устанавливает файлы, которые имеют атрибуты, перечисленные в следующей таблице. Дата и время для этих файлов указаны в формате UTC.. Дата и время для версий файлов на локальном компьютере отображаются с учетом часового пояса и перехода на летнее время.. Кроме того Дата и время могут изменяться при выполнении определенных операций с файлами.
Примечания к сведениям о файле Windows Server 2003
  • В дополнение к файлам, которые перечислены в этих таблицах данное исправление также устанавливает соответствующий файл каталога безопасности (KBНомер.cat), подписывается цифровой подписью Майкрософт.
Для всех поддерживаемых 32-разрядных версий Windows Server 2003 (x86)
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформа
Rdpdr.sys5.2.3790.4683201,21622 Марта 2010 г15: 21X86
Для всех поддерживаемых 64-разрядных (x64) версий Windows Server 2003
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформа
Rdpdr.sys5.2.3790.4683333,31223 Марта 2010 г04: 32X64
Для всех поддерживаемых версий Windows Server 2003 для платформы IA-64
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файла:Дата:времяПлатформа
Rdpdr.sys5.2.3790.4683641,53623 Марта 2010 г04: 32IA-64

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Майкрософт, перечисленных в разделе «Применяется к»..

Дополнительная информация

Дополнительные сведения о терминах, используемых при описании обновлений программного обеспечения, см. в следующей статье базы знаний Майкрософт::
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
Примечание. Это ЭКСПРЕСС-ПУБЛИКАЦИЯ, подготовленная непосредственно службой технической поддержки Майкрософт . Сведения, содержащиеся в данном документе, предоставлены в качестве отклика на возникшие проблемы. Из-за срочности в материалах могут быть опечатки, и в любое время и без уведомления в них могут быть внесены изменения. Чтобы получить дополнительные сведения, см. Условия использования.

Свойства

Код статьи: 979522 - Последний отзыв: 30 ноября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003, Standard x64 Edition
Ключевые слова: 
kbautohotfix kbexpertiseadvanced kbfix kbsurveynew kbqfe kbmt KB979522 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:979522

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com