FIX: You receive a System.Configuration.ConfigurationErrorsException exception when you browse a Commerce Server SharePoint Web site

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Article ID: 979528 - View products that this article applies to.
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SYMPTOMS

When you open a Microsoft Commerce Server SharePoint Web site on a computer that is running Microsoft Commerce Server 2009, you receive an exception that resembles the following:
Type : System.Configuration.ConfigurationErrorsException, System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a
Message : An error occurred creating the configuration section handler for ServiceConfiguration: Object reference not set to an instance of an object. (<path>\web.config line <n>)
Source : System.Configuration
Help link:
BareMessage : An error occurred creating the configuration section handler for ServiceConfiguration: Object reference not set to an instance of an object.
Filename : <path>\web.config Line : <n>
Errors : System.Configuration.ConfigurationException[]
BareMessage : An error occurred creating the configuration section handler for ServiceConfiguration: Object reference not set to an instance of an object.

CAUSE

This issue occurs because there is a race condition when the Commerce Server 2009 Channel Configuration file (ChannelConfiguration.config) is being accessed.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: -
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2009 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart Internet Information Services (IIS) after you apply this hotfix. To restart IIS, open a command prompt, type the following command, and then press ENTER:
IISRESET /RESTART
Note This option stops and then restarts all IIS services that are running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Microsoft.commerce.application.common.dll1.0.20123.2283,84817-Jan-201021:17x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 979528 - Last Review: October 7, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Commerce Server 2009 Enterprise
  • Microsoft Commerce Server 2009 Standard
Keywords: 
kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB979528

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