Mensaje de error cuando intenta conectarse a una impresora mediante un registro de recursos de alias (CNAME): "Windows no pudo conectarse a la impresora"

Seleccione idioma Seleccione idioma
Id. de artículo: 979602 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando intenta conectarse a una impresora mediante un registro de recursos de alias (CNAME) para un servidor de impresión que se está ejecutando Windows Server 2008 R2 o para un equipo cliente que se está ejecutando Windows 7 y que aloja una impresora, recibe mensaje de error siguientes:
Windows no pudo conectar con la impresora. Compruebe el nombre de la impresora y vuelva a intentarlo. Si se trata de una impresora de red, asegúrese de que la impresora está encendida y que la dirección de la impresora es correcta.
Además, la siguiente es un ejemplo de la traza se genera mediante Monitor de red:
[client request]
34 4.421875  {MSRPC:9, SMB2:8, TCP:2, IPv4:1} IP addressIP address Winspool Winspool:RpcOpenPrinterEx Request, Printer = \\printsvr\Microsoft XPS Document Writer
[server response]
37 4.843750  {MSRPC:9, SMB2:8, TCP:2, IPv4:1} IP addressIP address Winspool Winspool:RpcOpenPrinterEx Response, Status = ERROR_INVALID_PRINTER_NAME

Causa

Este problema se produce debido a algunos cambios de optimización al código de la cola de impresión para equipos no agrupados. Cuando se carga el sistema operativo, el servicio de cola de impresión carga el nombre local del equipo y los nombres locales que se encuentran en la caché de DNS. El servicio de cola de impresión utiliza los nombres locales a las solicitudes de servicio. Por lo tanto, el servicio debe tener acceso a la red y, a continuación, consultar nombres como un registro de recursos de alias (CNAME). Este comportamiento reduce el rendimiento del servicio.

Solución

Para evitar este problema, utilice el comando siguiente para agregar una clave del registro del servidor de impresión que ejecuta Windows 2008 Server R2 y que esté accediendo a un registro de recursos de alias (CNAME):
reg add HKLM\SYSTEM\CurrentControlSet\Control\Print /v DnsOnWire /t REG_DWORD /d 1
Nota Esta clave del registro disminuye el rendimiento. Por tanto, se recomienda agregar esta clave de registro en sólo los servidores de impresión se deben tener acceso a un registro de recursos de alias (CNAME).

Más información

No se admite el equilibrio de la carga algunas impresoras, mediante una tecnología de equilibrio de carga de red (NLB) o Sistema de nombres de dominio (DNS) redondo característica de operación por turnos. La solución que se menciona en este artículo es sólo del escenario donde un registro de recursos de alias (CNAME) que hace referencia a sólo ese servidor acceso a un servidor de impresión que está ejecutando Windows Server 2008 R2.

Propiedades

Id. de artículo: 979602 - Última revisión: viernes, 29 de enero de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Datacenter without Hyper-V
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Enterprise without Hyper-V
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Standard without Hyper-V
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
Palabras clave: 
kbmt kbsurveynew kbexpertiseinter kbtshoot KB979602 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 979602

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com