エイリアス (CNAME) リソース レコードを使用してプリンターに接続しようとすると、エラー メッセージ:「Windows をプリンターに接続できませんでした」

文書翻訳 文書翻訳
文書番号: 979602 - 対象製品
すべて展開する | すべて折りたたむ

現象

Windows 7 およびホスト プリンターが実行されているクライアント コンピューターの Windows Server 2008 R2 を実行するプリント サーバーのエイリアス (CNAME) リソース レコードを使用してプリンターに接続しようとすると、次のエラー メッセージが表示されます。
Windows がプリンターに接続できませんでした。プリンターの名前を確認してやり直してください。ネットワーク プリンターの場合は、プリンターがオンになっていること、およびプリンターのアドレスが正しいことを確認してください。
さらに、ネットワーク モニターによって生成されたトレースのサンプルを次に示します:
[client request]
34 4.421875  {MSRPC:9, SMB2:8, TCP:2, IPv4:1} IP addressIP address Winspool Winspool:RpcOpenPrinterEx Request, Printer = \\printsvr\Microsoft XPS Document Writer
[server response]
37 4.843750  {MSRPC:9, SMB2:8, TCP:2, IPv4:1} IP addressIP address Winspool Winspool:RpcOpenPrinterEx Response, Status = ERROR_INVALID_PRINTER_NAME

原因

この問題は、スプーラー コードの非クラスター化コンピューターによって最適化が変更されたためのに発生します。 オペレーティング システムが読み込まれると、印刷スプーラー サービスは、コンピューターのローカル名と DNS キャッシュで、他のローカル名を読み込みます。印刷スプーラー サービスをローカル名サービス要求に使用します。 したがって、サービスは、ネットワークにアクセスしてエイリアス (CNAME) リソース レコードのような名前を照会する必要があります。この現象は、サービスのパフォーマンスが低下します。

回避策

この問題を回避するには、Windows 2008 Server R2 を実行しているし、エイリアス (CNAME) リソース レコードによってアクセスされているプリント サーバー上のレジストリ キーを追加するのには、次のコマンドを使用します。
レジストリの追加 HKLM\SYSTEM\CurrentControlSet\Control\Print/v DnsOnWire/t REG_DWORD/d 1
メモこのレジストリ キー、パフォーマンスが低下します。そのため、エイリアス (CNAME) リソース レコードでアクセスする必要があるプリント サーバーだけでは、このレジストリ キーを追加することをお勧めします。

詳細

一部のプリンターは、ネットワーク負荷分散 (NLB) テクノロジまたはドメイン ネーム システム (DNS) を使用してラウンド ロビン機能負荷はサポートされていません。 この資料に記載されている回避策は、その 1 つのサーバーにのみを参照するエイリアス (CNAME) リソース レコードによって、Windows Server 2008 R2 を実行している 1 つのプリント サーバーがアクセス シナリオのみです。

プロパティ

文書番号: 979602 - 最終更新日: 2010年1月29日 - リビジョン: 1.0
この資料は以下の製品について記述したものです。
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Datacenter without Hyper-V
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Enterprise without Hyper-V
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Standard without Hyper-V
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
キーワード:?
kbtshoot kbexpertiseinter kbmt kbsurveynew KB979602 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:979602
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com