No puede tener acceso a un archivo recién copiado en una carpeta compartida en un equipo que ejecuta Windows Server 2008 o Windows Vista

Seleccione idioma Seleccione idioma
Id. de artículo: 980044 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Tiene tres equipos que ejecutan Windows Server 2008 o Windows Vista en una red de área local (LAN). Uno de los equipos es un servidor de archivos de bloque (SMB) de mensaje de servidor. Los dos equipos son clientes de servidor de archivos SMB.
  • Cree dos carpetas compartidas en el equipo que es un servidor de archivos SMB.
  • Asigne ambas carpetas compartidas en uno de los equipos es un cliente de servidor de archivos SMB.
  • Copiar un archivo de una de las carpetas compartidas en una unidad local mediante la función CopyFile() en el equipo que asigna ambas carpetas compartidas.
  • Copiar un archivo diferente desde esta carpeta compartida en la otra carpeta compartida mediante la función CopyFile() en el equipo que asigna ambas carpetas compartidas.
  • Se intenta obtener acceso a esta copia del segundo archivo desde otro equipo es un cliente de servidor de archivos SMB.
En este escenario, no puede tener acceso al archivo y recibirá mensaje de error siguientes:
El archivo está en uso por otro proceso
Si intenta obtener acceso al mismo archivo nuevo varios segundos más tarde, puede obtener acceso a él.

Por ejemplo, suponga lo siguiente:
  • El equipo es el servidor de archivos SMB se denomina equipo 1.
  • Los equipos que son clientes de servidor de archivos SMB se denominan equipo 2 y 3 del equipo.
  • Crear dos carpetas compartidas que se denominan recurso 1 y 2 en el equipo 1 de compartir.
  • Asignar recurso compartido de 1 y comparta 2 en el equipo 2.
  • Copiar un archivo de recurso compartido de 1 a una unidad local en el equipo 2 mediante la función CopyFile().
  • Copiar un archivo diferente de recurso compartido 1 compartir 2 mediante la función CopyFile().
  • Usar equipo 3 para acceder a esta copia del segundo archivo.
En este escenario, no puede tener acceso al archivo y recibe el mensaje de error. Sin embargo, puede tener acceso al archivo después de 10 segundos.

Causa

Este problema se produce porque el protocolo SMB 2.0 mantiene una operación de bloqueo innecesariamente una vez completada una operación de copia de archivo. Cualquier acceso al archivo desde un sistema distinto el originador de la copia se ha denegado por aproximadamente 10 segundos.

Solución

Información de revisiones

Nota Para resolver este problema, instale la revisión en todos los tres equipos del entorno de LAN.

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten el problema descrito en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con los servicios de cliente de Microsoft y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión en cuestión. Para obtener una lista completa de números de teléfono de Microsoft servicios de soporte técnico y de asistencia al cliente o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar esta revisión, el equipo debe ejecutar uno de los sistemas operativos siguientes:
  • Windows Vista Service Pack 2 (SP2)
  • Windows Server 2008 Service Pack 2 (SP2)
Para obtener más información acerca de cómo obtener service pack de Windows Vista, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
935791Cómo obtener el service pack más reciente de Windows Vista
Para obtener más información acerca de cómo obtener un service pack de Windows Server 2008, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
968849Cómo obtener el service pack más reciente para Windows Server 2008

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a una revisión lanzada anteriormente.

Información de archivo

La versión en inglés (Estados Unidos) de esta revisión instala los archivos que tienen los atributos que se enumeran en las tablas siguientes. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). Las fechas y horas de estos archivos en el equipo local se muestran en su hora local junto con su actual (DST) horario de verano. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.
Notas sobre la información de archivos de Windows Vista y Windows Server 2008
Importante Las revisiones de Windows Vista y las revisiones de Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo "Windows Vista" aparece en la página solicitud de revisión. Para solicitar el paquete de hotfix que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparecen bajo "Windows Vista" en la página. Consulte siempre la sección "La información de este artículo se refiere A" en los artículos para determinar el sistema operativo real que se aplica cada revisión.
  • Los archivos que se aplican a un producto específico, SR_Level (RTM, SP n) y servicio (LDR, GDR) se pueden identificar examinando los números de versión del archivo tal como se muestra en la tabla siguiente.
    Contraer esta tablaAmpliar esta tabla
    6.0.600 2. 22xxxWindows Vista y Windows Server 2008SP2LDR
  • Los archivos MANIFEST (.manifest) y los MUM (.mum) que se instalan para cada entorno están listed separately en la sección "Información para Windows Server 2008 y Windows Vista de archivo adicional". Archivos MUM y archivos MANIFEST y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos del catálogo de seguridad, para el que los atributos no aparecen en la lista, están firmados con una firma digital de Microsoft.
Para todas versiones de 86 de Windows Server 2008 y Windows Vista x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdbss.sys6.0.6002.22348225,28025-Feb-201013: 17x 86
Para todas-versiones basadas en x 64 de Windows Server 2008 y Windows Vista
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdbss.sys6.0.6002.22348288,76825-Feb-201013: 25x 64
Para todas las versiones basadas en IA-64 de Windows Server 2008
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataforma
Rdbss.sys6.0.6002.22348679,42425-Feb-201013: 16IA-64

Solución

Solución para Windows Vista y Windows Server 2008

Para evitar este problema, deshabilite SMBv2. Para ello, siga estos pasos:
  1. Haga clic en Inicio, escriba regedit en el cuadro Iniciar búsqueda y, a continuación, presione ENTRAR.
  2. Busque y haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
  3. En el menú Edición, seleccione nuevo y, a continuación, haga clic en valor DWORD.
  4. Escriba SMB2 y, a continuación, presione ENTRAR.
  5. En el menú Edición, haga clic en Modificar.
  6. Escriba 0 (cero) y, a continuación, haga clic en Aceptar
  7. Salir del Editor del registro.
  8. Reinicie el equipo.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología relativa a las actualizaciones de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Para obtener más información función CopyFile, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
CopyFile Function

Información adicional de archivos

Información adicional de archivos para Windows Vista y Windows Server 2008

Archivos adicionales para todas las versiones basadas en 86 de Windows Vista y de Windows Server 2008 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoUpdate.mum
Versión del archivoNo aplicable
Tamaño del archivo3,068
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable
Nombre de archivoX86_1d029f19fde4b57e3db8a4d0b2b24644_31bf3856ad364e35_6.0.6002.22348_none_592cb8acd4c6a52e.manifest
Versión del archivoNo aplicable
Tamaño del archivo693
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable
Nombre de archivoVentanas de X86_microsoft de rdbss_31bf3856ad364e35_6.0.6002.22348_none_5c21b29d77c690c1.manifest
Versión del archivoNo aplicable
Tamaño del archivo6,856
Fecha (UTC)25-Feb-2010
Hora (UTC)17: 47
PlataformaNo aplicable
Archivos adicionales para todas-versiones basadas en x 64 de Windows Vista y de Windows Server 2008
Contraer esta tablaAmpliar esta tabla
Nombre de archivoAmd64_48ab6590a980d341f4b3d702e25eaf62_31bf3856ad364e35_6.0.6002.22348_none_039c0ec13c4c6c05.manifest
Versión del archivoNo aplicable
Tamaño del archivo697
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable
Nombre de archivoVentanas de Amd64_microsoft de rdbss_31bf3856ad364e35_6.0.6002.22348_none_b8404e21302401f7.manifest
Versión del archivoNo aplicable
Tamaño del archivo7,113
Fecha (UTC)25-Feb-2010
Hora (UTC)17: 24
PlataformaNo aplicable
Nombre de archivoUpdate.mum
Versión del archivoNo aplicable
Tamaño del archivo3.092
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable
Archivos adicionales para todas las versiones basadas en IA-64 de Windows Server 2008 compatibles
Contraer esta tablaAmpliar esta tabla
Nombre de archivoIa64_0c1c72f67c1519a86046c002b14c340a_31bf3856ad364e35_6.0.6002.22348_none_3e72e587bb470fb0.manifest
Versión del archivoNo aplicable
Tamaño del archivo695
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable
Nombre de archivoVentanas de Ia64_microsoft de rdbss_31bf3856ad364e35_6.0.6002.22348_none_5c23569377c499bd.manifest
Versión del archivoNo aplicable
Tamaño del archivo7,107
Fecha (UTC)25-Feb-2010
Hora (UTC)17: 06
PlataformaNo aplicable
Nombre de archivoUpdate.mum
Versión del archivoNo aplicable
Tamaño del archivo2,247
Fecha (UTC)26-Feb-2010
Hora (UTC)01: 08
PlataformaNo aplicable

Propiedades

Id. de artículo: 980044 - Última revisión: miércoles, 14 de abril de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Vista Service Pack 2 sobre las siguientes plataformas
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Ultimate
  • Windows Server 2008 Service Pack 2 sobre las siguientes plataformas
    • Windows Server 2008 Datacenter
    • Windows Server 2008 Enterprise
    • Windows Server 2008 Standard
Palabras clave: 
kbmt kbfix kbautohotfix kbhotfixserver kbsurveynew kbqfe kbexpertiseadvanced KB980044 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 980044

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com