Accedi con Microsoft
Accedi o crea un account.
Salve,
Seleziona un altro account.
Hai più account
Scegli l'account con cui vuoi accedere.

Sintomi

Si consideri lo scenario seguente:

  • Si dispone di un computer che esegue Windows 7, Windows Server 2008 R2, Windows Vista o Windows Server 2008.

  • Attivare la funzionalità Cambio rapido utente o la funzionalità Desktop remoto in questo computer.

  • È direttamente accedere al computer. In alternativa, è possibile utilizzare una sessione di Desktop remoto per accedere al computer.

  • Si apre un file di immagine utilizzando Visualizzatore foto di Windows nel computer in uso.

  • Mentre è connessi al computer, utilizzare un altro account utente per accedere al computer utilizzando la funzionalità Cambio rapido utente o utilizzando una sessione di Desktop remoto.

  • Si tenta di avviare Visualizzatore foto di Windows utilizzando questo secondo account utente.

In questo scenario, è possibile avviare il Visualizzatore foto di Windows. Inoltre, viene visualizzato il seguente messaggio di errore se non si dispongono dei privilegi di amministratore:

Impossibile accedere il dispositivo specificato, un percorso o un file. Non si dispone delle autorizzazioni appropriate per accedere all'elemento.

Nota: Questo problema si verifica se si utilizza un'altra applicazione per aprire il file di immagine, ad esempio Microsoft Paint.

Causa

Il problema è dovuto al fatto che in Visualizzatore foto di Windows viene utilizzato Microsoft COM+ (Dllhost.exe) processo di hosting. Questo processo è configurato per consentire solo un'istanza di se stesso per l'esecuzione su ciascun computer.

Risoluzione

Informazioni sull'hotfix

Nota: Questo hotfix è solo per Windows 7 e Windows Server 2008 R2. Se si esegue Windows Vista o Windows Server 2008, vedere la sezione "Workaround".

Un hotfix supportato è disponibile da Microsoft. Tuttavia, questo hotfix è destinato esclusivamente alla correzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verifica il problema descritto in questo articolo. Questo hotfix potrebbe essere sottoposto ad ulteriori test. Se il problema non causa gravi difficoltà, si consiglia di attendere il successivo aggiornamento software contenente tale hotfix.

Se l'hotfix è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se questa sezione non viene visualizzata, contattare il servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota: Se si verificano ulteriori problemi o se è necessaria attività di risoluzione aggiuntiva, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare specifico hotfix in questione. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'hotfix. Se non viene visualizzata la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario essere in esecuzione Windows 7 o Windows Server 2008 R2 nel computer in uso.

Informazioni del Registro di sistema

Per utilizzare questo hotfix, non è necessario apportare modifiche al Registro di sistema.

Richiesta di riavvio

Non è necessario riavviare il computer dopo avere applicato questo hotfix.

Informazioni sulla sostituzione dell'aggiornamento rapido

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare file con gli attributi elencati nelle tabelle seguenti. Le date e ore per questi file sono elencate nel tempo universale coordinato (UTC). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale (DST). Inoltre, le date e gli orari possono cambiare quando si eseguono determinate operazioni sui file.

Note relative alle informazioni dei file di Windows 7 e Windows Server 2008 R2


Importante Aggiornamenti rapidi di Windows 7 e aggiornamenti rapidi di Windows Server 2008 R2 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina richiesta Hotfix sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'hotfix elencato nella pagina in "Windows 7 e Windows Server 2008 R2". Fare sempre riferimento alla sezione "Si applica a" negli articoli per determinare il sistema operativo effettivo a cui si applica ogni aggiornamento rapido .

  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamente nella sezione "Ulteriori file di informazioni per Windows Server 2008 R2 e Windows 7". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associato, sono estremamente importanti per mantenere lo stato del componente aggiornato. I file catalogo di protezione elencati senza attributi sono firmati con firma digitale Microsoft.

Per tutte le versioni x86 di Windows 7

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Photoviewer.dll

6.1.7600.20645

1,456,128

16-Feb-2010

07:08

x86

Per tutte le versioni x64 di Windows 7 e Windows Server 2008 R2

Nome del file

Versione del file

Dimensione del file

Data

Ora

Piattaforma

Photoviewer.dll

6.1.7600.20645

1,728,000

16-Feb-2010

07:37

x64

Photoviewer.dll

6.1.7600.20645

1,456,128

16-Feb-2010

07:08

x86

Soluzione alternativa

Per risolvere questo problema, utilizzare uno dei metodi descritti di seguito.

Metodo 1

  1. Fare clic su Start, digitare regedit nella casella di ricerca e quindi fare clic su Regedit nei risultati della ricerca.

  2. Nell'Editor del Registro di sistema individuare la seguente sottochiave del Registro di sistema:

    HKEY_CLASSES_ROOT\AppID\{76D0CB12-7604-4048-B83C-1005C7DDC503}

  3. La voce di registro RunAs destro e quindi fare clic su Elimina.

Metodo 2

  1. Fare clic su Start, digitare dcomcnfg nella casella di ricerca e quindi fare clic su .exe dcomcnfgnei risultati della ricerca.

  2. Nella finestra Servizi componenti espandere Servizi componenti, espandere computere quindi espandere Risorse del Computer.

  3. Fare Le applicazioni COM+, scegliere Visualizzae quindi fare clic su stato.

  4. Destro dell'applicazione COM+ che ha un ID applicazione di {76D0CB12-7604-4048-B83C-1005C7DDC503} e quindi scegliere proprietà.

  5. Nella finestra di dialogo proprietà , fare clic sulla scheda identità .

  6. Nella scheda identità , fare clic sull' opzione utente che avvia l'operazionee quindi fare clic su OK.

Stato

Microsoft ha confermato che questo è un problema dei prodotti Microsoft elencati nella sezione "Si applica a".

Ulteriori informazioni

Per ulteriori informazioni su Fast commutazione compatibilità servizio utente, fare clic sul numero riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base riportato di seguito:

Descrizione 294855 del servizio di compatibilità di cambio rapido utente

Per ulteriori informazioni sulla funzionalità Cambio rapido utente, visitare il seguente sito Web Microsoft:

Come nascondere la funzionalità Cambio rapido utentePer ulteriori informazioni sull'account utente interattivo, visitare il seguente sito Web Microsoft:

Informazioni generali sull'account utente interattivoPer ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul seguente numero di articolo per visualizzare l'articolo della Microsoft Knowledge Base:

824684 descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows 7 e Windows Server 2008 R2

File aggiuntivi per tutte le versioni x86 supportate di Windows 7

Nome del file

Update.mum

Versione del file

Non applicabile

Dimensione del file

1,635

Data (UTC)

16-Feb-2010

Ora (UTC)

15:30

Piattaforma

Non applicabile

Nome del file

X86_c76c749764ee75c2445fdfceea66abcb_31bf3856ad364e35_6.1.7600.20645_none_4e01cac8e8cb5db8.manifest

Versione del file

Non applicabile

Dimensione del file

699

Data (UTC)

16-Feb-2010

Ora (UTC)

15:30

Piattaforma

Non applicabile

Nome del file

X86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest

Versione del file

Non applicabile

Dimensione del file

50,296

Data (UTC)

16-Feb-2010

Ora (UTC)

07:37

Piattaforma

Non applicabile

File aggiuntivi per tutte supportate versioni basate su x64 di Windows 7 e Windows Server 2008 R2

Nome del file

Amd64_c758ef1a37fd7346bbcb0cc1489d847d_31bf3856ad364e35_6.1.7600.20645_none_358bbd4c4e634088.manifest

Versione del file

Non applicabile

Dimensione del file

1,046

Data (UTC)

16-Feb-2010

Ora (UTC)

15:30

Piattaforma

Non applicabile

Nome del file

Amd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_38e85d2b02666a2b.manifest

Versione del file

Non applicabile

Dimensione del file

50,300

Data (UTC)

16-Feb-2010

Ora (UTC)

08:13

Piattaforma

Non applicabile

Nome del file

Update.mum

Versione del file

Non applicabile

Dimensione del file

1,850

Data (UTC)

16-Feb-2010

Ora (UTC)

15:30

Piattaforma

Non applicabile

Nome del file

X86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest

Versione del file

Non applicabile

Dimensione del file

50,296

Data (UTC)

16-Feb-2010

Ora (UTC)

07:37

Piattaforma

Non applicabile

Serve aiuto?

Vuoi altre opzioni?

Esplorare i vantaggi dell'abbonamento e i corsi di formazione, scoprire come proteggere il dispositivo e molto altro ancora.

Le community aiutano a porre e a rispondere alle domande, a fornire feedback e ad ascoltare gli esperti con approfondite conoscenze.

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?
Premendo Inviare, il tuo feedback verrà usato per migliorare i prodotti e i servizi Microsoft. L'amministratore IT potrà raccogliere questi dati. Informativa sulla privacy.

Grazie per il feedback!

×