FIX: "Communication with all MessageBoxes has now been re-established" entries are logged unexpectedly in the BizTalk Server 2009 Application log

Article translations Article translations
Article ID: 980560 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You have a computer that is running BizTalk Server 2009. You change the status of a BizTalk Server artifact. For example, you start or stop an orchestration. In this situation, two events that resemble the following are logged in the Application log:

Event 1
Event Type: Information
Event Source: BizTalk Server 2009
Event Category: (1)
Event ID: 6999
Description: Communication with MessageBox BizTalkMsgBoxDb on SQL Instance <SQL instance name> has been re-established

Event 2
Event Type: Information
Event Source: BizTalk Server 2009
Event Category: (1)
Event ID: 7000
Description: Communication with all MessageBoxes has now been re-established

Notes
  • These Application log entries do not contain important information. Because these entries are generated frequently, they may be inserted among other entries that contain important information.
  • This issue does not occur in earlier versions of BizTalk Server.

CAUSE

This behavior occurs because of a design change in the Btsmessageagent.dll file in BizTalk Server 2009.

RESOLUTION

After you apply this hotfix, BizTalk Server 2009 does not generate these Application log entries.

Cumulative update information

For BizTalk Server 2009, the hotfix that resolves this issue is included in Cumulative Update 1 for BizTalk Server 2009. 

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base: 

2429050 Cumulative update package 1 for BizTalk Server 2009

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2009 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For 32-bit versions of BizTalk Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Btsmessageagent.dll3.8.420.2712,03204-Mar-201016:05x86
For 64-bit versions of BizTalk Server 2009
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Btsmessageagent.dll3.8.420.21,345,37604-Mar-201019:11x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information on BizTalk Server hot fixes

Properties

Article ID: 980560 - Last Review: December 8, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbbtsadmin kbbiztalk2009presp1fix kbautohotfix kbexpertiseadvanced kbsurveynew kbqfe KB980560

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com