FIX: A BizTalk 2009 Accelerator for RosettaNet configuration wizard fails because it cannot verify that there is a valid network connection

Article ID: 980641 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • You use BizTalk Server 2009 on a computer that is running Windows Vista or Windows Server 2008.
  • You install Microsoft BizTalk 2009 Accelerator for RosettaNet (BTARN 2009).
  • You run Microsoft BizTalk 2009 Accelerator for RosettaNet configuration wizard after the installation.
In this scenario, the configuration wizard fails. Additionally, the following message is logged in the Configuration log:
[time PM Error Configuration Framework]Feature: [Runtime] Failed to configure with error message [Configuration Wizard is unable to verify your network connection. A valid network connection is required.]
However, there are no issues with the network connection on the computer.

CAUSE

The issue occurs because of the method that the BTARN 2009 configuration wizard uses to return addresses for the host in Windows Vista and in Windows Server 2008. The BTARN 2009 configuration wizard uses the getAddrInfo function to return addresses for the host. The getAddrInfo function returns both global and local addresses if the flag AI_ADDRCONFIG is not set in Windows Vista, Windows Server 2008 and later versions of Windows. Therefore, the getAddrInfo function may return a loopback address. When this occurs, the configuration wizard determines that there is no valid network connection.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

The following list contains prerequisites for the hotfix package:
  • You must have Microsoft BizTalk 2009 Accelerator for RosettaNet installed to apply this hotfix. For more information about how to obtain Microsoft BizTalk 2009 Accelerator for RosettaNet, visit the following Microsoft Product page:
    BizTalk Accelerator for RosettaNet

Restart requirement

You do not have to restart the computer after you apply this hotfix package.

Hotfix replacement information

This hotfix does not replace a previously released hotfix package.

File information

The English (United States) version of this hotfix package uses a Microsoft Windows Installer package to install the hotfix package. The dates and the times for these files are listed in Coordinated Universal Time (UTC) in the following table. When you view the file information, the date is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft BizTalk 2009 Accelerator for RosettaNet

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File nameFile versionFile sizeDateTimePlatform
Rnconfig.dll3.7.602.2319,82411-Feb-201009:43x86
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the getAddrInfo function, visit the following MSDN Web site:
addrinfo Structure
For more information about operating systems support by different versions of BizTalk Server, click the following article number to view the article in the Microsoft Knowledge Base:
926628 Summary of 64-bit support and operating systems and SQL Server versions supported by different versions of BizTalk Server
For more information about BizTalk Server hot fixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information on BizTalk Server hot fixes

Properties

Article ID: 980641 - Last Review: October 6, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft BizTalk Server 2009 Branch
  • Microsoft BizTalk Server 2009 Developer
  • Microsoft BizTalk Server 2009 Enterprise
  • Microsoft BizTalk Server 2009 Standard
Keywords: 
kbhotfixserver kbexpertiseinter kbsurveynew kbbug kbfix kbqfe kbpubtypekc KB980641

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