An Exchange Server 2010 mailbox user receives a NDR message when the user sends an email message to multiple internal users

Article translations Article translations
Article ID: 980701 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You create a disclaimer on a computer that is running the Microsoft Exchange Server 2010 Hub Transport Server role.
  • An Exchange Server 2010 mailbox user sends an email message to multiple internal users.
  • The internal users are located in different mailbox database stores.
  • The email message contains a large attachment which is bigger than 200KB.
In this scenario, the user who sends the email message receives the following NDR message:

From: Microsoft Outlook
Sent: <Date, Time>
To: <Recipient>
Subject: Undeliverable: <subject>
Delivery has failed to these recipients or groups:
<Recipient names, addresses>
The email system had a problem processing this message. Exchange will not try to redeliver this message for you.
Diagnostic information for administrators:
Generating server: <Hub Transport Server name>
<Recipient address>
#554 5.6.0 STOREDRV.Deliver; Corrupt message content ##
......

CAUSE

This problem occurs because multiple threads are leveraged to process the affected message when the disclaimer is configured on the Hub Transport Server. A race condition is encountered, and then the contents of the message are corrupted.

RESOLUTION

To resolve this problem, install the following update rollup:
982639 Description of Update Rollup 4 for Exchange Server 2010

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about disclaimers, visit the following Microsoft website:
General information about disclaimers

Properties

Article ID: 980701 - Last Review: June 18, 2010 - Revision: 2.0
APPLIES TO
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
Keywords: 
kbfix kbhotfixrollup kbexpertiseinter kbqfe kbsurveynew KB980701

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com