Article ID: 980867 - Last Review: March 4, 2010 - Revision: 1.0

A security program is still listed in Windows Security Center and in Action Center after the security program is uninstalled

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SYMPTOMS

You uninstall a security program, such as an antivirus program, an antispyware program, or a firewall program, from a computer that is running one of the following operating systems:
  • Windows XP
  • Windows Vista
  • Windows 7
However, the security program is still listed in the Windows Security Center or in the Action Center.

CAUSE

This issue occurs because the program does not correctly unregister itself from the Windows Security Center or from the Action Center when the program is uninstalled.

WORKAROUND

To work around this issue, you must manually remove that program’s instance by using Windows Management Instrumentation (WMI). To do this, follow these steps:
  1. Use administrative credentials to open a Command Prompt window. To do this, follow these steps.

    For Windows XP:
    1. Click Start, point to All Programs, point to Accessories, and then right-click Command Prompt.
    2. Click Run as.
    3. Select The following user, and enter the administrative credentials of an account on the computer.
    4. Click OK.
    For Windows Vista or Windows 7:
    1. Click Start
      Collapse this imageExpand this image
      Start button
      , type cmd in the search box, and then press ENTER.
    2. In the results list, right-click cmd, and then click Run as administrator.
    3. If you are prompted, enter administrative credentials.
  2. At the command prompt, type wbemtest, and then press ENTER.
  3. In the Windows Management Instrumentation Tester dialog box, click Connect.
  4. As appropriate for your version of the operating system, type the following in the Namespace text box:
    • For Windows XP and Windows Vista:
      root\SecurityCenter
    • For Windows Vista SP1, Windows Vista SP2, and Windows 7:
      root\SecurityCenter2
  5. Click Connect.
  6. Click Enum Classes.
  7. Leave the Superclass name text box blank, and then click OK.
  8. Double-click AntispywareProduct, AntiVirusProduct, or FirewallProduct, as appropriate for your version of the operating system.
  9. Click Instances.
  10. For each GUID that is listed, follow these steps:
    1. Double-click a GUID.
    2. Locate the displayName property, and verify that the name matches the name of the security program that is uninstalled.
    3. Click Close.
    4. Select the GUID instance, and then click Delete.

APPLIES TO
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Vista Service Pack 2, when used with:
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Ultimate
  • Windows Vista Service Pack 1, when used with:
    • Windows Vista Business
    • Windows Vista Enterprise
    • Windows Vista Home Basic
    • Windows Vista Home Premium
    • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Microsoft Windows XP Service Pack 3, when used with:
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
Keywords: 
kbwmi kbuninstall kbantivirus kbexpertisebeginner kbsurveynew kbprb KB980867